python-django-nose_1.4.3-1_all.deb


Advertisement

Description

python-django-nose - Django test runner that uses python-nose

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: python-django-nose
Package version: 1.4.3
Package release: 1
Package architecture: all
Package type: deb
Installed size: 100 B
Download size: 22.96 KB
Official Mirror: archive.ubuntu.com
python-django-nose integrates python-nose into Django test runner by extending the Django management CLI with nose-related options. Those options are targeted at running nose tests directly from within the Django management system (e.g. django-admin).

Alternatives

    Download

    Source package: django-nose

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-django-nose deb package:
      # sudo apt-get install python-django-nose

    Files

    • /usr/lib/python2.7/dist-packages/django_nose/__init__.py
    • /usr/lib/python2.7/dist-packages/django_nose/fixture_tables.py
    • /usr/lib/python2.7/dist-packages/django_nose/plugin.py
    • /usr/lib/python2.7/dist-packages/django_nose/runner.py
    • /usr/lib/python2.7/dist-packages/django_nose/testcases.py
    • /usr/lib/python2.7/dist-packages/django_nose/tools.py
    • /usr/lib/python2.7/dist-packages/django_nose/utils.py
    • /usr/lib/python2.7/dist-packages/django_nose-1.4.3.egg-info/PKG-INFO
    • /usr/lib/python2.7/dist-packages/django_nose-1.4.3.egg-info/dependency_links.txt
    • /usr/lib/python2.7/dist-packages/django_nose-1.4.3.egg-info/not-zip-safe
    • /usr/lib/python2.7/dist-packages/django_nose-1.4.3.egg-info/requires.txt
    • /usr/lib/python2.7/dist-packages/django_nose-1.4.3.egg-info/top_level.txt
    • /usr/lib/python2.7/dist-packages/django_nose/management/__init__.py
    • /usr/lib/python2.7/dist-packages/django_nose/management/commands/__init__.py
    • /usr/lib/python2.7/dist-packages/django_nose/management/commands/test.py
    • /usr/lib/python2.7/dist-packages/testapp/migrations/0001_initial.py
    • /usr/lib/python2.7/dist-packages/testapp/migrations/__init__.py
    • /usr/lib/python2.7/dist-packages/testapp/south_migrations/0001_initial.py
    • /usr/lib/python2.7/dist-packages/testapp/south_migrations/__init__.py
    • /usr/share/doc/python-django-nose/README.rst
    • /usr/share/doc/python-django-nose/changelog.Debian.gz
    • /usr/share/doc/python-django-nose/copyright

    Changelog

    2016-01-07 - Michael Fladischer <fladi@debian.org> django-nose (1.4.3-1) unstable; urgency=low * New upstream release. * Refresh patches. * Add patch to disable tests that use REUSE_DB as they are broken.

    2015-10-26 - Brian May <bam@debian.org> django-nose (1.4.2-2) unstable; urgency=medium * Fix python3 depends. Closes: #803005.

    2015-10-16 - Michael Fladischer <fladi@debian.org> django-nose (1.4.2-1) unstable; urgency=medium * New upstream release. * Refresh runtests.patch. * Add 0003-Remove-unnecessary-dependency-on-dj_database_url.patch to remove test dependency on dj_database_url module. * Bump debhelper compatibility and version to 9. * Initialize git-dpm. * Update Vcs fields for git migration.

    2015-07-06 - Michael Fladischer <fladi@debian.org> django-nose (1.4.1-1) unstable; urgency=low * New upstream release.

    2015-05-19 - Michael Fladischer <fladi@debian.org> django-nose (1.4-1) unstable; urgency=medium * New upstream release. * Use github repository for uscan. * Bump Standards-Version to 3.9.6. * Add gawk to Build-Depends because it is required by runtests.sh. * Refresh runtests.patch. * Use correct Python version to determine tests to run in runtests.patch. * Remove PHONY target declarations from d/rules. * Use only one for loop to run the tests for all requested Python versions. * Use distinctive description for python3 package. * Line-wrap Depends fields for easier reading. * Add X-Python3-Version for versions => 3.3. * Add DEP3 header to django17.patch. * Change my email address to fladi@debian.org.

    2014-09-29 - Brian May <bam@debian.org> django-nose (1.2-3) unstable; urgency=low * Fix Django 1.7 AppRegistryNotReady error, by calling django.setup() in tests. Closes: #763252.

    2014-08-13 - Brian May <bam@debian.org> django-nose (1.2-2) unstable; urgency=low * Python 3 package. * Disable django-south in tests. Closes: #755665.

    2013-12-16 - Michael Fladischer <FladischerMichael@fladi.at> django-nose (1.2-1) unstable; urgency=low [ Jakub Wilk ] * Use canonical URIs for Vcs-* fields. [ Michael Fladischer ] * New upstream release (Closes: #711360). * Switch to dh_python2. * Build-Depends on dh-python. * Bump Standards version to 3.9.5. * Bump Build-Depends on debhelper to >= 8.1.0 to satisfy build-arch and build-indep targets. * Drop versioned Build-Depends on python-all as no prior versions are available in Wheezy. * Drop versioned Depends and Build-Depends on python-django as no prior versions are available in Wheezy. * Use correct DEP5 format URL for d/copyright. * Rename BSD-django-nose to BSD-3-clause license. * Refresh patch. * Update years in d/copyright.

    2012-06-04 - Michael Fladischer <FladischerMichael@fladi.at> django-nose (1.1-1) unstable; urgency=low * New upstream release. * Make temporary Metadata-Version fix more generic for future versions. * Bump Standards version to 3.9.3. * Use BSD-django-nose as license name in d/copyright. * Change order of my name. * Add email addresses to authors in d/copyright. * Use PyPi URL in d/watch.

    2011-11-26 - Fladischer Michael <FladischerMichael@fladi.at> django-nose (0.1.3-1) unstable; urgency=low * New upstream release. * Bump standards version to 3.9.2 (no change). * Use wrap-and-sort on debian/*. * Bump python-django dependency to (>= 1.2). * Temporary fix for Metadata-Version in PKG-INFO (see #645125). * Use http://githubredir.debian.net in d/watch to get clean tarball. * Use runtests.sh provided by upstream to run all tests. * Add python-django-south to Build-Depends to be able to run all tests. * Add patch for runtests.sh to enable the use of non-default python versions for running the tests.

    Advertisement
    Advertisement