python-django-auth-ldap_1.2.7+dfsg-1_all.deb


Advertisement

Description

python-django-auth-ldap - Django LDAP authentication backend

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe amd64
Package name python-django-auth-ldap
Package version 1.2.7+dfsg
Package release 1
Package architecture all
Package type deb
Installed size 131 B
Download size 21.19 KB
Official Mirror archive.ubuntu.com
Django authentication backend that authenticates against an LDAP
service. Configuration can be as simple as a single distinguished
name template, but there are many rich configuration options for
working with users, groups, and permissions.

Alternatives

Package Version Architecture Repository
python-django-auth-ldap_1.2.7+dfsg-1_all.deb 1.2.7+dfsg all Ubuntu Universe
python-django-auth-ldap - - -

Requires

Name Value
python-django >= 1.3
python-ldap -
python:any >= 2.7.5-5~
python:any << 2.8

Download

Type URL
Binary Package python-django-auth-ldap_1.2.7+dfsg-1_all.deb
Source Package django-auth-ldap

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-django-auth-ldap deb package:
    # sudo apt-get install python-django-auth-ldap

Files

Path
/usr/lib/python2.7/dist-packages/django_auth_ldap/__init__.py
/usr/lib/python2.7/dist-packages/django_auth_ldap/backend.py
/usr/lib/python2.7/dist-packages/django_auth_ldap/config.py
/usr/lib/python2.7/dist-packages/django_auth_ldap/dn.py
/usr/lib/python2.7/dist-packages/django_auth_ldap/models.py
/usr/lib/python2.7/dist-packages/django_auth_ldap/tests.py
/usr/lib/python2.7/dist-packages/django_auth_ldap-1.2.7.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/django_auth_ldap-1.2.7.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/django_auth_ldap-1.2.7.egg-info/requires.txt
/usr/lib/python2.7/dist-packages/django_auth_ldap-1.2.7.egg-info/top_level.txt
/usr/share/doc/python-django-auth-ldap/changelog.Debian.gz
/usr/share/doc/python-django-auth-ldap/copyright

Changelog

2016-01-02 - Michael Fladischer <fladi@debian.org>
django-auth-ldap (1.2.7+dfsg-1) unstable; urgency=medium
[ Michael Fladischer ]
* New upstream release (Closes: #806344).
* Bump debhelper compatibility and version to 9.
* Clean django_auth_ldap.egg-info/requires.txt to allow two builds in a row.
[ SVN-Git Migration ]
* git-dpm config
* Update Vcs fields for git migration
2015-05-28 - Michael Fladischer <fladi@debian.org>
django-auth-ldap (1.2.6+dfsg-1) unstable; urgency=medium
* New upstream release.
* Bump Standards-Version to 3.9.6.
* Use pypi.debian.net service for uscan.
* Add repacksuffix to d/watch for DFSG-compliant repacks.
* Add dversionmangle for DFSG-repack to d/watch.
* Change my email address to fladi@debian.org.
2014-09-23 - Michael Fladischer <FladischerMichael@fladi.at>
django-auth-ldap (1.2.2+dfsg-1) unstable; urgency=low
* New upstream relese (Closes: #755588).
* Add dh-python to Build-Depends.
* Switch buildsystem to pybuild.
* Remove superfluous install file.
* Use upstream test environment.
* Rename license to BSD-2-clause.
2014-04-23 - Michael Fladischer <FladischerMichael@fladi.at>
django-auth-ldap (1.2.0+dfsg-1) unstable; urgency=low
* New upstream release.
* Remove minified JavaScript files from source tarball.
* Mangle "+dfsg" in debian/watch.
* Check PGP signature on upstream tarball:
+ Add signature URL to debian/watch.
+ Include upstream public PGP key D0FA0E76.
+ Allow debian/upstream-signing-key.pgp to be included as a binary.
2014-02-12 - Michael Fladischer <FladischerMichael@fladi.at>
django-auth-ldap (1.1.8-1) unstable; urgency=medium
* New upstream release.
* Update years in d/copyright.
2013-12-27 - Michael Fladischer <FladischerMichael@fladi.at>
django-auth-ldap (1.1.7-2) unstable; urgency=medium
* Add mockldap to Build-Depends, reenabling tests.
2013-11-26 - Michael Fladischer <FladischerMichael@fladi.at>
django-auth-ldap (1.1.7-1) unstable; urgency=low
[ Michael Fladischer ]
* New upstream release (Closes: #678703).
* Add python-setuptools to Build-Depends, upstream switched from distutils
to setuptools.
* Bump python version support to >= 2.5.
* Bump dependency on Django to >= 1.3.
* Bump Standards-Version to 3.9.5.
* Bump debhelper in Build-Depends to >= 8.1.0~.
* Drop unnecessary versioned dependencies in Depends and Build-Depends:
+ python-all
+ python-ldap
* Ommit installing archived documentation:
+ Add patch docs-do_not_install_archive.patch.
* Use locally installed objects.inv for intersphinx mapping:
+ Add patch docs-use_local_intersphinx_mapping.patch.
+ Add python-doc to Build-Depends.
+ Add python-django-doc to Build-Depends.
* Format packaging files with wrap-and-sort.
* Change documentation source directory for sphinx.
* Update years in d/copyright.
* Drop temporary fix for PKG-INFO.
* Run dh_clean in override target.
* Clean django_auth_ldap.egg-info/SOURCES.txt after each build.
[ Jakub Wilk ]
* Use canonical URIs for Vcs-* fields.
2012-07-08 - Michael Fladischer <FladischerMichael@fladi.at>
django-auth-ldap (1.0.19-2) unstable; urgency=low
* Make dependency on python-django unversioned again.
2012-07-08 - Michael Fladischer <FladischerMichael@fladi.at>
django-auth-ldap (1.0.19-1) unstable; urgency=low
* New upstream release.
* Fix tests for django (>= 1.4) FTBFS (Closes: #669486).
* Bump dependency on python-django to (>= 1.2).
2012-03-16 - Michael Fladischer <FladischerMichael@fladi.at>
django-auth-ldap (1.0.18-1) unstable; urgency=low
* New upstream release.
* Update years in d/copyright.
* Update DEP-5 URL to 1.0.
* Bump Standards-Version to 3.9.3.

See Also

Package Description
python-django-auth-openid_0.5-2.3_all.deb provides optional OpenID integration for Django
python-django-authority_0.5-2_all.deb more powerful permission system for Django
python-django-babel-doc_0.4.0-1_all.deb Utilities for using Babel in Django - doc
python-django-babel_0.4.0-1_all.deb Utilities for using Babel in Django - Python 2.7
python-django-bitfield_1.8.0-1_all.deb Django module implementing BitFields
python-django-braces-doc_1.8.0-2_all.deb set of reusable, generic mixins for Django class based views (Documentation)
python-django-braces_1.8.0-2_all.deb set of reusable, generic mixins for Django class based views
python-django-captcha_0.5.1-1_all.deb Django Simple Captcha Django application
python-django-celery-doc_3.1.17-3_all.deb Celery integration for Django (Documentation)
python-django-celery-haystack_0.10-1_all.deb utilize Celery for automatic haystack index updates
python-django-celery-transactions_0.3.6-1_all.deb Django transaction support for Celery tasks
python-django-celery_3.1.17-3_all.deb Celery integration for Django
python-django-classy-tags-doc_0.7.1-1_all.deb Class based template tags for Django projects (Documentation)
python-django-classy-tags_0.7.1-1_all.deb Class based template tags for Django projects
python-django-compat_1.0.8-1ubuntu2_all.deb Forward and backwards compatibility layer for Django 1.4.x to 1.9.x
Advertisement
Advertisement