python-distorm3_3.3.0-3_all.deb


Advertisement

Description

python-distorm3 - powerful disassembler library for x86/AMD64 binary streams (Python bindings)

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: python-distorm3
Package version: 3.3.0
Package release: 3
Package architecture: all
Package type: deb
Installed size: 64 B
Download size: 15.07 KB
Official Mirror: archive.ubuntu.com
diStorm3 is a binary stream disassembler library project. With diStorm3, no more parsing strings is needed. diStorm3 is really a decomposer, which means it takes an instruction and returns a binary structure which describes it rather than static text. This is great for advanced binary code analysis. This package provides the Python bindings.

Alternatives

    Download

    Source package: distorm3

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-distorm3 deb package:
      # sudo apt-get install python-distorm3

    Files

    • /usr/lib/python2.7/dist-packages/distorm3-3.3.0.egg-info
    • /usr/lib/python2.7/dist-packages/distorm3/__init__.py
    • /usr/share/doc/python-distorm3/changelog.Debian.gz
    • /usr/share/doc/python-distorm3/copyright
    • /usr/share/doc/python-distorm3/examples/sample.py

    Changelog

    2015-09-12 - Joao Eriberto Mota Filho <eriberto@debian.org> distorm3 (3.3.0-3) unstable; urgency=medium * New upstream homepage.

    2015-05-05 - Joao Eriberto Mota Filho <eriberto@debian.org> distorm3 (3.3.0-2) unstable; urgency=medium * Upload to unstable.

    2015-02-24 - Joao Eriberto Mota Filho <eriberto@debian.org> distorm3 (3.3.0-1) experimental; urgency=medium * New upstream release. * debian/copyright: - Added the 'Files: python/distorm3/*' block. - Updated the packaging and upstream copyright years. * debian/libdistorm3-3.links: updated to point to 3.3.0 version. * debian/libdistorm3-dev.links: updated to point to 3.3.0 version. * debian/libdistorm3-3.symbols: updated the symbols. * debian/pydist-overrides: added to override the dh_python2 error while trying read the non-existent file requires.txt. * debian/rules: updated the lib real version.

    2015-01-05 - Joao Eriberto Mota Filho <eriberto@debian.org> distorm3 (3.0-3) experimental; urgency=medium * debian/watch: added a new site to search (PyPI).

    2014-10-26 - Joao Eriberto Mota Filho <eriberto@debian.org> distorm3 (3.0-2) unstable; urgency=medium * Bumped Standards-Version to 3.9.6. * debian/control: added dh-python as build dependency.

    2014-08-30 - Joao Eriberto Mota Filho <eriberto@debian.org> distorm3 (3.0-1) unstable; urgency=low * Initial release (Closes: #759767)

    Advertisement
    Advertisement