python-dictclient_1.0.3.1+nmu2_all.deb


Advertisement

Description

python-dictclient - Python client library for DICT (RFC2229) protocol

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: python-dictclient
Package version: 1.0.3.1+nmu2
Package release:
Package architecture: all
Package type: deb
Installed size: 52 B
Download size: 11.90 KB
Official Mirror: archive.ubuntu.com
This is a new library for interacting with Dict servers. It defines three classes -- Connection, Database, and Definition. It supports all common Dict server requests, including definitions, matching, and getting information about available databases, capabilities, etc. You can use it to communicate to a local or remote dictd database. The homepage for this package (includes docs) is at gopher://quux.org/1/devel/dictclient.

Alternatives

Provides

  • python2.7-dictclient

    Download

    Source package: dictclient

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-dictclient deb package:
      # sudo apt-get install python-dictclient

    Files

    • /usr/lib/python2.7/dist-packages/dictclient-1.0.1.egg-info
    • /usr/lib/python2.7/dist-packages/dictclient.py
    • /usr/share/doc/python-dictclient/ChangeLog
    • /usr/share/doc/python-dictclient/changelog.gz
    • /usr/share/doc/python-dictclient/copyright
    • /usr/share/doc/python-dictclient/dictclient.html
    • /usr/share/doc/python-dictclient/dictclient.txt.gz

    Changelog

    2016-03-27 - Giovani Augusto Ferreira <giovani@riseup.net> dictclient (1.0.3.1+nmu2) unstable; urgency=medium * Non-maintainer upload. * Update DH level to 9. (Closes: #800233) * debian/compat: created and set to 9, instead of using DH_COMPAT. * debian/control: - Added dh-python in Build-Depends. - Added the ${misc:Depends} variable to provide the right install dependencies. - Bumped Standards-Version to 3.9.7. * debian/rules: - Disabled the DH_COMPAT line. - Fixed ignores make clean target errors. Thanks to Sebastian Carneiro (Closes: #694764)

    2013-05-27 - Luca Falavigna <dktrkranz@debian.org> dictclient (1.0.3.1+nmu1) unstable; urgency=low * Non-maintainer upload. * Convert to dh_python2 (Closes: #616789).

    2008-07-18 - Matthias Klose <doko@debian.org> dictclient (1.0.3.1) unstable; urgency=low * NMU. Rebuild to move files to /usr/share/pyshared. Closes: #490456.

    2006-09-11 - John Goerzen <jgoerzen@complete.org> dictclient (1.0.3) unstable; urgency=medium * Update to new Python policy. Closes: #380774.

    2003-08-18 - John Goerzen <jgoerzen@complete.org> dictclient (1.0.2) unstable; urgency=low * Updated Debian package for Python 2.3.

    2002-04-18 - John Goerzen <jgoerzen@complete.org> dictclient (1.0.1) unstable; urgency=low * Added a fix for matching.

    2002-04-18 - John Goerzen <jgoerzen@complete.org> dictclient (1.0) unstable; urgency=low * Initial release. Closes: #143451.

    Advertisement
    Advertisement