python-dhm_0.6-4_all.deb


Advertisement

Description

python-dhm - collection of Python utilities / helper

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: python-dhm
Package version: 0.6
Package release: 4
Package architecture: all
Package type: deb
Installed size: 125 B
Download size: 21.49 KB
Official Mirror: archive.ubuntu.com
A collection of various tools wich cover a broad range of things: classes to make it easier to deal with LDAP and SQL databases, CGI-related tools, general string manipulation, process handling, file management, etc.

Alternatives

Provides

  • python2.7-dhm

    Download

    Binary package: python-dhm_0.6-4_all.deb
    Source package: python-dhm

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-dhm deb package:
      # sudo apt-get install python-dhm

    Files

    • /usr/lib/python2.7/dist-packages/dhm-0.6.egg-info
    • /usr/lib/python2.7/dist-packages/dhm/__init__.py
    • /usr/lib/python2.7/dist-packages/dhm/cgiutils.py
    • /usr/lib/python2.7/dist-packages/dhm/command.py
    • /usr/lib/python2.7/dist-packages/dhm/config.py
    • /usr/lib/python2.7/dist-packages/dhm/ldapObject.py
    • /usr/lib/python2.7/dist-packages/dhm/nestdict.py
    • /usr/lib/python2.7/dist-packages/dhm/sectionedfile.py
    • /usr/lib/python2.7/dist-packages/dhm/simplerfc822.py
    • /usr/lib/python2.7/dist-packages/dhm/strtools.py
    • /usr/lib/python2.7/dist-packages/dhm/textfile.py
    • /usr/lib/python2.7/dist-packages/dhm/sql/__init__.py
    • /usr/lib/python2.7/dist-packages/dhm/sql/dict.py
    • /usr/lib/python2.7/dist-packages/dhm/sql/object.py
    • /usr/lib/python2.7/dist-packages/dhm/sql/persistence.py
    • /usr/lib/python2.7/dist-packages/dhm/sql/row.py
    • /usr/lib/python2.7/dist-packages/dhm/sql/utils.py
    • /usr/lib/python2.7/dist-packages/dhm/sql/wrap.py
    • /usr/share/doc/python-dhm/NEWS.gz
    • /usr/share/doc/python-dhm/changelog.Debian.gz
    • /usr/share/doc/python-dhm/copyright

    Changelog

    2015-06-14 - Luca Falavigna <dktrkranz@debian.org> python-dhm (0.6-4) unstable; urgency=low * Team upload. [ Sandro Tosi ] * debian/control - bump Standards-Version to 3.8.2 (no changes needed) [ Jakub Wilk ] * Use canonical URIs for Vcs-* fields. * Drop obsolete Conflicts/Replaces with python2.3-dhm and python2.4-dhm. [ Luca Falavigna ] * Switch to dh_python2 (Closes: #786018).

    2009-01-30 - Sandro Tosi <morph@debian.org> python-dhm (0.6-3) unstable; urgency=low * debian/control - switch Vcs-Browser field to viewsvn - updated my email address - bump Standards-Version to 3.8.0 (no changes needed) - added ${misc:Depends} to binary package Depends - build-depends only on python (it's an arch:all package) * debian/rules - simplified since we need only to build with a python interpreter (not all those supported) * debian/copyright - updated my email address - indented with 4 spaces license, upstream author and copyright - fixed copyright notice updating years for Debian packaging * debian/{dirs,pycompat} - removed, since not needed

    2007-12-02 - Sandro Tosi <matrixhasu@gmail.com> python-dhm (0.6-2) unstable; urgency=low * Given to DPMT * debian/control - DPMT as maintainer (me as uploader) - added Vcs-Browser and Vcs-Svn - bump Standards-Version to 3.7.3 (no changes) - capitalized Python in short description - changed build-dep from python-all-dev to python-all

    2007-09-29 - Sandro Tosi <matrixhasu@gmail.com> python-dhm (0.6-1) unstable; urgency=low * New upstream release * debian/watch - added

    2007-09-27 - Sandro Tosi <matrixhasu@gmail.com> python-dhm (0.5-3) unstable; urgency=low * Adopting this package (Closes: #439041) * debian/control - set myself as package maintainer - Homepage field is now in the source stanza, linking to the right URL (Closes: #435511) - added field XS-Python-Version - simple changes to long and short package description * debian/compat - bump to 5 * debian/copyright - updated maintainer info - updated upstream website - added copyright for the package - added right copyright information for upstream, moving previous under licence area - removed wrong BSD licence, replaced with GPLv2, as mentioned in every source file * Acknowledging NMU (Closes: #351139) * Acknowledging NMU (Closes: #373527) * debian/rules - minor cleanup (comments at the beginning) - remove dh_python since using python-support

    2006-07-01 - Pierre Habouzit <madcoder@debian.org> python-dhm (0.5-2.3) unstable; urgency=low * Non-maintainer upload. * Update package to the last python policy (Closes: #373527).

    2006-04-22 - Torsten Marek <shlomme@debian.org> python-dhm (0.5-2.2) unstable; urgency=low * Non-maintainer upload. * Remove python2.2-dhm (Closes: #351139) * Added python2.4-dhm * Build-depend on python-all-dev * Updated Debian policy version to 3.6.2 (no changes required)

    2004-08-02 - Joshua Kwan <joshk@triplehelix.org> python-dhm (0.5-2.1) unstable; urgency=low * Non-maintainer upload. * Add Build-Depends on python to fix FTBFS. (Closes: #259121)

    2003-10-19 - Michelle Ribeiro <michelle@cipsga.org.br> python-dhm (0.5-2) unstable; urgency=low * Fixed the license, changing it BSD.

    2003-10-18 - Michelle Ribeiro <michelle@cipsga.org.br> python-dhm (0.5-1) unstable; urgency=low * Initial Release. (closes: #204821)

    Advertisement
    Advertisement