python-darts.lib.utils.lru - Simple dictionary with LRU behaviour in Python2

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: python-darts.lib.utils.lru
Package version: 0.5
Package release: 3
Package architecture: all
Package type: deb
Installed size: 71 B
Download size: 15.72 KB
Official Mirror:
An LRUDict is basically a simple dictionary, which has a defined maximum capacity, that may be supplied at construction time, or modified at run-time via the capacity property. The class SynchronizedLRUDict, which exposes the same interface as plain LRUDict, but fully thread-safe. This is the Python 2 version of the package.



    Source package: python-darts.lib.utils.lru

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-darts.lib.utils.lru deb package:
      # sudo apt-get install python-darts.lib.utils.lru


    • /usr/lib/python2.7/dist-packages/darts.util.lru-0.5.egg-info/PKG-INFO
    • /usr/lib/python2.7/dist-packages/darts.util.lru-0.5.egg-info/dependency_links.txt
    • /usr/lib/python2.7/dist-packages/darts.util.lru-0.5.egg-info/namespace_packages.txt
    • /usr/lib/python2.7/dist-packages/darts.util.lru-0.5.egg-info/top_level.txt
    • /usr/lib/python2.7/dist-packages/darts.util.lru-0.5.egg-info/zip-safe
    • /usr/lib/python2.7/dist-packages/darts/lib/utils/
    • /usr/share/doc/python-darts.lib.utils.lru/README.txt.gz
    • /usr/share/doc/python-darts.lib.utils.lru/changelog.Debian.gz
    • /usr/share/doc/python-darts.lib.utils.lru/copyright
    • /usr/share/doc/python-darts.lib.utils.lru/index.txt.gz
    • /usr/share/python/ns/python-darts.lib.utils.lru


    2015-11-05 - Gianfranco Costamagna <> python-darts.lib.utils.lru (0.5-3) unstable; urgency=medium * Update my uid.

    2015-04-02 - Gianfranco Costamagna <> python-darts.lib.utils.lru (0.5-2) unstable; urgency=medium * Add debian/watch file, following upstream tag release.

    2015-03-19 - Gianfranco Costamagna <> python-darts.lib.utils.lru (0.5-1) unstable; urgency=medium * Rename the orig tarball in 0.5. - upstream doesn't release tarballs, but also PyPI calls it 0.5. * Move the repository to collab-maint and set myself as Maintainer.

    2015-02-20 - Gianfranco Costamagna <> python-darts.lib.utils.lru (0.5~git20140220-1) unstable; urgency=low * Initial release (Closes: #778837)