python-cssselect_0.9.1+git90c72b0-1_all.deb


Advertisement

Description

python-cssselect - cssselect parses CSS3 Selectors and translates them to XPath 1.0

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: python-cssselect
Package version: 0.9.1+git90c72b0
Package release: 1
Package architecture: all
Package type: deb
Installed size: 149 B
Download size: 23.82 KB
Official Mirror: archive.ubuntu.com
cssselect parses CSS3 Selectors and translate them to XPath 1.0 expressions. Such expressions can be used in lxml or another XPath engine to find the matching elements in an XML or HTML document. This module used to live inside of lxml as lxml.cssselect before it was extracted as a stand-alone project. This package provides the Python 2.x module.

Alternatives

Requires

    Download

    Source package: python-cssselect

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-cssselect deb package:
      # sudo apt-get install python-cssselect

    Files

    • /usr/lib/python2.7/dist-packages/cssselect/__init__.py
    • /usr/lib/python2.7/dist-packages/cssselect/parser.py
    • /usr/lib/python2.7/dist-packages/cssselect/tests.py
    • /usr/lib/python2.7/dist-packages/cssselect/xpath.py
    • /usr/lib/python2.7/dist-packages/cssselect-0.9.1.egg-info/PKG-INFO
    • /usr/lib/python2.7/dist-packages/cssselect-0.9.1.egg-info/dependency_links.txt
    • /usr/lib/python2.7/dist-packages/cssselect-0.9.1.egg-info/top_level.txt
    • /usr/share/doc/python-cssselect/README.rst
    • /usr/share/doc/python-cssselect/changelog.Debian.gz
    • /usr/share/doc/python-cssselect/copyright

    Changelog

    2014-10-11 - W. Martin Borgert <debacle@debian.org> python-cssselect (0.9.1+git90c72b0-1) unstable; urgency=low * Support python3 (Closes: #755031), thanks to 宋文武 <iyzsong@gmail.com> * Use new upstream non-release (some bug fixes) * Move packaging to team git

    2013-10-26 - TANIGUCHI Takaki <takaki@debian.org> python-cssselect (0.9.1-1) unstable; urgency=low [ Barry Warsaw ] * New upstream release. * debian/control: - Remove unnecessary Build-Dep on python-support. - Bumped Standards-Version to 3.9.4 with no changes necessary. - Add X-Python-Version header.

    2013-05-07 - TANIGUCHI Takaki <takaki@debian.org> python-cssselect (0.8-1) unstable; urgency=low [ Jakub Wilk ] * Use canonical URIs for Vcs-* fields. [ TANIGUCHI Takaki ] * New upstream release * debian/copyright: update Format URL.

    2012-05-10 - TANIGUCHI Takaki <takaki@debian.org> python-cssselect (0.6.1-1) unstable; urgency=low * Initial release. (Closes: #672323)

    Advertisement
    Advertisement