python-coverage_3.7.1+dfsg.1-1ubuntu7_amd64.deb


Advertisement

Description

python-coverage - code coverage tool for Python 2

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: python-coverage
Package version: 3.7.1+dfsg.1
Package release: 1ubuntu7
Package architecture: amd64
Package type: deb
Installed size: 310 B
Download size: 65.22 KB
Official Mirror: archive.ubuntu.com
The ‘coverage’ library measures which parts (statements) of a Python program are executed while it is run. This is useful for testing: those parts of a program that are not executed by the tests have not been tested. This package contains the Python version 2 ‘coverage’ library, and the ‘python-coverage’ program to perform and report coverage tests.

Alternatives

    Download

    Source package: python-coverage

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-coverage deb package:
      # sudo apt-get install python-coverage

    Files

    • /usr/bin/python-coverage
    • /usr/bin/python2-coverage
    • /usr/bin/python2.7-coverage
    • /usr/lib/python2.7/dist-packages/coverage/__init__.py
    • /usr/lib/python2.7/dist-packages/coverage/__main__.py
    • /usr/lib/python2.7/dist-packages/coverage/annotate.py
    • /usr/lib/python2.7/dist-packages/coverage/backward.py
    • /usr/lib/python2.7/dist-packages/coverage/bytecode.py
    • /usr/lib/python2.7/dist-packages/coverage/cmdline.py
    • /usr/lib/python2.7/dist-packages/coverage/codeunit.py
    • /usr/lib/python2.7/dist-packages/coverage/collector.py
    • /usr/lib/python2.7/dist-packages/coverage/config.py
    • /usr/lib/python2.7/dist-packages/coverage/control.py
    • /usr/lib/python2.7/dist-packages/coverage/data.py
    • /usr/lib/python2.7/dist-packages/coverage/debug.py
    • /usr/lib/python2.7/dist-packages/coverage/execfile.py
    • /usr/lib/python2.7/dist-packages/coverage/files.py
    • /usr/lib/python2.7/dist-packages/coverage/html.py
    • /usr/lib/python2.7/dist-packages/coverage/htmlfiles
    • /usr/lib/python2.7/dist-packages/coverage/misc.py
    • /usr/lib/python2.7/dist-packages/coverage/parser.py
    • /usr/lib/python2.7/dist-packages/coverage/phystokens.py
    • /usr/lib/python2.7/dist-packages/coverage/report.py
    • /usr/lib/python2.7/dist-packages/coverage/results.py
    • /usr/lib/python2.7/dist-packages/coverage/summary.py
    • /usr/lib/python2.7/dist-packages/coverage/templite.py
    • /usr/lib/python2.7/dist-packages/coverage/tracer.so
    • /usr/lib/python2.7/dist-packages/coverage/version.py
    • /usr/lib/python2.7/dist-packages/coverage/xmlreport.py
    • /usr/lib/python2.7/dist-packages/coverage-3.7.1.egg-info/PKG-INFO
    • /usr/lib/python2.7/dist-packages/coverage-3.7.1.egg-info/dependency_links.txt
    • /usr/lib/python2.7/dist-packages/coverage-3.7.1.egg-info/entry_points.txt
    • /usr/lib/python2.7/dist-packages/coverage-3.7.1.egg-info/not-zip-safe
    • /usr/lib/python2.7/dist-packages/coverage-3.7.1.egg-info/top_level.txt
    • /usr/share/doc/python-coverage/README.Debian
    • /usr/share/doc/python-coverage/changelog.Debian.gz
    • /usr/share/doc/python-coverage/copyright
    • /usr/share/man/man1/python-coverage.1.gz
    • /usr/share/man/man1/python2-coverage.1.gz
    • /usr/share/man/man1/python2.7-coverage.1.gz
    • /usr/share/python-coverage/htmlfiles/coverage_html.js
    • /usr/share/python-coverage/htmlfiles/index.html
    • /usr/share/python-coverage/htmlfiles/keybd_closed.png
    • /usr/share/python-coverage/htmlfiles/keybd_open.png
    • /usr/share/python-coverage/htmlfiles/pyfile.html
    • /usr/share/python-coverage/htmlfiles/style.css

    Changelog

    2016-01-18 - Matthias Klose <doko@ubuntu.com> python-coverage (3.7.1+dfsg.1-1ubuntu7) xenial; urgency=medium * No-change rebuild to drop python3.4 support.

    2015-10-26 - Dmitry Shachnev <mitya57@ubuntu.com> python-coverage (3.7.1+dfsg.1-1ubuntu6) xenial; urgency=medium * Add back closing endif.

    2015-10-26 - Dmitry Shachnev <mitya57@ubuntu.com> python-coverage (3.7.1+dfsg.1-1ubuntu5) xenial; urgency=medium * Drop wrong override_dh_auto_test target.

    2015-10-23 - Matthias Klose <doko@ubuntu.com> python-coverage (3.7.1+dfsg.1-1ubuntu4) xenial; urgency=medium * No-change rebuild for python3 defaults change.

    2015-07-22 - Steve Langasek <steve.langasek@ubuntu.com> python-coverage (3.7.1+dfsg.1-1ubuntu3) wily; urgency=medium * No-change rebuild for python3.5 transition

    2014-03-23 - Matthias Klose <doko@ubuntu.com> python-coverage (3.7.1+dfsg.1-1ubuntu2) trusty; urgency=medium * No-change rebuild to drop support for Python 3.3.

    2014-03-07 - Dmitry Shachnev <mitya57@ubuntu.com> python-coverage (3.7.1+dfsg.1-1ubuntu1) trusty; urgency=medium * Merge with Debian unstable, remaining change: - Add python3-coverage.preinst to correctly handle upgrades from previous releases.

    2014-03-05 - Ben Finney <ben+debian@benfinney.id.au> python-coverage (3.7.1+dfsg.1-1) unstable; urgency=medium * The “Ziauddin Yousafzai” release. * Urgency “medium” because we fix a bug of severity “serious”. * New upstream version. (Closes: bug#735359) * debian/patches/: + Patches incorporated upstream: * 02.use-system-ecmascript-libraries.patch Remaining patch files re-sequenced contiguously. + Add editor hints to patch files. * debian/repack: + Correct quoting of parameters (quote parameters used as filesystem entry names, don't quote parameters used as numbers). * debian/rules: + Explicitly replace shebang for programs needing default Python interpreter (Closes: bug#736121). + Correct generation of Python version strings for object code filenames (Closes: bug#740053). Thanks to Dmitry Shachnev for the bug report and patch.

    2014-02-19 - Matthias Klose <doko@ubuntu.com> python-coverage (3.7+dfsg.1-4ubuntu2) trusty; urgency=medium * Build for python 3.4.

    2014-01-20 - Dmitry Shachnev <mitya57@ubuntu.com> python-coverage (3.7+dfsg.1-4ubuntu1) trusty; urgency=medium * Add python3-coverage.preinst (based on existing python-coverage.preinst) to correctly handle upgrades from previous releases. Previously /usr/lib/python3/dist-packages/coverage/htmlfiles was a directory, now it is a symbolic link (see Debian #734850).

    Advertisement
    Advertisement