python-coverage-test-runner_1.11-1_all.deb


Advertisement

Description

python-coverage-test-runner - fail Python program unit tests unless they test everything

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: python-coverage-test-runner
Package version: 1.11
Package release: 1
Package architecture: all
Package type: deb
Installed size: 25 B
Download size: 5.85 KB
Official Mirror: archive.ubuntu.com
This package contains the Python module CoverageTestRunner, which runs unit tests implemented using the unittest module in the Python standard library. It runs them using coverage.py (in the python-coverage package) and fails the test if all statements are not covered.

Alternatives

    Download

    Source package: python-coverage-test-runner

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-coverage-test-runner deb package:
      # sudo apt-get install python-coverage-test-runner

    Files

    • /usr/lib/python2.7/dist-packages/CoverageTestRunner-1.11.egg-info
    • /usr/lib/python2.7/dist-packages/CoverageTestRunner.py
    • /usr/share/doc/python-coverage-test-runner/changelog.Debian.gz
    • /usr/share/doc/python-coverage-test-runner/copyright

    Changelog

    2015-10-25 - Lars Wirzenius <liw@liw.fi> python-coverage-test-runner (1.11-1) unstable; urgency=low * New upstream version. * debian/control: Move Homepage: to source stanza. * debian/control: Update Standards-Version to 3.9.5. No further changes required.

    2013-04-17 - Lars Wirzenius <liw@liw.fi> python-coverage-test-runner (1.10-1) unstable; urgency=low * New upstream release.

    2012-09-23 - Lars Wirzenius <liw@liw.fi> python-coverage-test-runner (1.9-1) unstable; urgency=low * New upstream release.

    2012-01-19 - Lars Wirzenius <liw@liw.fi> python-coverage-test-runner (1.8-1) unstable; urgency=low * New upstream release.

    2011-09-04 - Lars Wirzenius <liw@liw.fi> python-coverage-test-runner (1.7.1-1) unstable; urgency=low * New upstream release.

    2011-09-04 - Lars Wirzenius <liw@liw.fi> python-coverage-test-runner (1.7-1) unstable; urgency=low * New upstream version. * Update packaging to use dh_python2.

    2011-05-26 - Lars Wirzenius <liw@liw.fi> python-coverage-test-runner (1.6-1) unstable; urgency=low * New upstream version. - license change to GPL3+ - tweaks to documentation (README) * Re-uploaded to Debian. (Closes: #628016) * debian/copyright: Updated to reflect reality (GPL3+, not GPL2+), and converted to DEP5. * debian/control: - Standards-Version bumped to 3.9.2 (no other changes required). - Add python-coverage to Build-Depends. - Add X-Python-Version header. - Add Homepage. * debian/source/format: Use 3.0 (quilt).

    2011-02-18 - Lars Wirzenius <liw@liw.fi> python-coverage-test-runner (1.5) squeeze; urgency=low * New upstream release

    2010-04-05 - Lars Wirzenius <liw@liw.fi> python-coverage-test-runner (1.4.1) squeeze; urgency=low * New upstream version.

    2010-02-14 - Lars Wirzenius <liw@liw.fi> python-coverage-test-runner (1.3) karmic; urgency=low * New upstream version.

    Advertisement
    Advertisement