python-configargparse_0.10.0-2_all.deb


Advertisement

Description

python-configargparse - replacement for argparse with config files and environment variables (Python 2)

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: python-configargparse
Package version: 0.10.0
Package release: 2
Package architecture: all
Package type: deb
Installed size: 75 B
Download size: 19.77 KB
Official Mirror: archive.ubuntu.com
Applications with more than a handful of user-settable options are best configured through a combination of command line args, config files, hard-coded defaults, and in some cases, environment variables. Python’s command line parsing modules such as argparse have very limited support for config files and environment variables, so this module extends argparse to add these features. This is the Python 2 module.

Alternatives

    Download

    Source package: python-configargparse

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-configargparse deb package:
      # sudo apt-get install python-configargparse

    Files

    • /usr/lib/python2.7/dist-packages/configargparse.py
    • /usr/lib/python2.7/dist-packages/ConfigArgParse-0.10.0.egg-info/PKG-INFO
    • /usr/lib/python2.7/dist-packages/ConfigArgParse-0.10.0.egg-info/dependency_links.txt
    • /usr/lib/python2.7/dist-packages/ConfigArgParse-0.10.0.egg-info/pbr.json
    • /usr/lib/python2.7/dist-packages/ConfigArgParse-0.10.0.egg-info/top_level.txt
    • /usr/share/doc/python-configargparse/README.rst.gz
    • /usr/share/doc/python-configargparse/changelog.Debian.gz
    • /usr/share/doc/python-configargparse/copyright

    Changelog

    2016-01-24 - Francois Marier <francois@debian.org> python-configargparse (0.10.0-2) unstable; urgency=medium [ Harlan Lieberman-Berg ] * Change package maintainer to the Let's Encrypt team. [ Francois Marier ] * Point Vcs-* URLs to the new team repo

    2015-11-13 - Francois Marier <francois@debian.org> python-configargparse (0.10.0-1) unstable; urgency=medium * New upstream release

    2015-05-31 - Francois Marier <francois@debian.org> python-configargparse (0.9.3-1) unstable; urgency=low * Initial release (Closes: #787319)

    Advertisement
    Advertisement