python-commando_0.3.4-1.1_all.deb


Advertisement

Description

python-commando - wrapper for argparse to define declaratively

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: python-commando
Package version: 0.3.4
Package release: 1.1
Package architecture: all
Package type: deb
Installed size: 73 B
Download size: 8.90 KB
Official Mirror: archive.ubuntu.com
A simple wrapper for `argparse` that allows commands and arguments to be defined declaratively using decorators. Note that this does not support all the features of `argparse` yet.

Alternatives

    Download

    Source package: commando

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-commando deb package:
      # sudo apt-get install python-commando

    Files

    • /usr/lib/python2.7/dist-packages/commando/__init__.py
    • /usr/lib/python2.7/dist-packages/commando/application.py
    • /usr/lib/python2.7/dist-packages/commando/conf.py
    • /usr/lib/python2.7/dist-packages/commando/util.py
    • /usr/lib/python2.7/dist-packages/commando-0.3.4.egg-info/PKG-INFO
    • /usr/lib/python2.7/dist-packages/commando-0.3.4.egg-info/dependency_links.txt
    • /usr/lib/python2.7/dist-packages/commando-0.3.4.egg-info/top_level.txt
    • /usr/share/doc/python-commando/README.rst
    • /usr/share/doc/python-commando/changelog.Debian.gz
    • /usr/share/doc/python-commando/copyright

    Changelog

    2014-02-01 - Andreas Moog <andreas.moog@warperbbs.de> commando (0.3.4-1.1) unstable; urgency=medium * Non-maintainer Upload * Add patch to stop using deprecated python module "distribute" to build. (Closes: #733437) * debian/control, debian/rules: Build-Depend on dh-python and use the pybuild buildsystem * Add Build-Depends on python-fswrap, python-markdown, python-mock, python-nose python-yaml, required for the nosetests to succeed.

    2013-05-30 - Julien Danjou <acid@debian.org> commando (0.3.4-1) unstable; urgency=low * New upstream release * Bump standard policy

    2011-12-20 - Julien Danjou <acid@debian.org> commando (0.1.2a-3) unstable; urgency=low * Add missing build-deps on python-setuptools

    2011-12-20 - Julien Danjou <acid@debian.org> commando (0.1.2a-2) unstable; urgency=low * Drop requirements on argparse in egg

    2011-12-19 - Julien Danjou <acid@debian.org> commando (0.1.2a-1) unstable; urgency=low * Initial release (Closes: #651928)

    Advertisement
    Advertisement