python-comedilib_0.10.2-4_amd64.deb


Advertisement

Description

python-comedilib - Python wrapper for Comedilib

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe amd64
Package name python-comedilib
Package version 0.10.2
Package release 4
Package architecture amd64
Package type deb
Installed size 610 B
Download size 67.88 KB
Official Mirror archive.ubuntu.com
Comedilib is a library for using Comedi, a driver interface for data
acquisition hardware.  See the libcomedi0 package for more information.
This package provides Python bindings to the comedi library.

Alternatives

Package Version Architecture Repository
python-comedilib_0.10.2-4_i386.deb 0.10.2 i386 Ubuntu Universe
python-comedilib - - -

Requires

Name Value
libc6 >= 2.14
libcomedi0 >= 0.10.0
python << 2.8
python >= 2.7

Provides

Name Value
python2.7-comedilib -

Download

Type URL
Binary Package python-comedilib_0.10.2-4_amd64.deb
Source Package comedilib

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-comedilib deb package:
    # sudo apt-get install python-comedilib

Files

Path
/usr/lib/python2.7/dist-packages/_comedi.so
/usr/lib/python2.7/dist-packages/comedi.py
/usr/share/doc/python-comedilib/changelog.Debian.gz
/usr/share/doc/python-comedilib/copyright

Changelog

2016-01-16 - Gudjon I. Gudjonsson <gudjon@gudjon.org>
comedilib (0.10.2-4) unstable; urgency=medium
* Update build dependencies for GSL 2, change libgsl0-dev to libgsl-dev.
(Closes: #807191)
2015-08-02 - Gudjon I. Gudjonsson <gudjon@gudjon.org>
comedilib (0.10.2-3) unstable; urgency=medium
* Fix extension names for python3.5 (Closes: #793576)
* Bump standards version to 3.9.6
* Remove pycompat
2014-07-10 - Gudjon I. Gudjonsson <gudjon@gudjon.org>
comedilib (0.10.2-2) unstable; urgency=medium
* Add dh_autoreconf (Closes: #754195)
2014-07-01 - Gudjon I. Gudjonsson <gudjon@gudjon.org>
comedilib (0.10.2-1) unstable; urgency=medium
* New upstream version (Closes: #711203)
* Bump standards version to 3.9.5
* Update comedi calibrate to version 2 (Closes: #732685)
* Remove all patches. Already in upstream.
* Add directories for comedi-calibrate (thanks to √Čric Piel)
* Add dependency on  libboost-dev
* Add patch 02_configure to disable checking of libcomedi
* Update hardening to standard
* Remove dh-autoreconf
2014-05-11 - Petter Reinholdtsen <pere@debian.org>
comedilib (0.10.1-1.1) unstable; urgency=low
* Non-maintainer upload to fix RC bug #733322.
* Fix build problem with newer bison (Closes: #733322).  Patch from
Daniel T Chen and Ubuntu via A. Maitland Bottoms backporting
upstream changesets 90ce9a9, cc0c9e7, f4e228e, c689eff, and
2277e82.
* Use dh-autoreconf to fix build problem on some architectures
(Closes: #727345).  Drop now obsolete autotools-dev build
dependency.  Patch from Daniel T Chen and Ubuntu via A. Maitland
Bottoms.
* Add new executables comedi_soft_calibrate and comedi_board_info to
the libcomedi1 package (Closes: #711203). Add new directory
/var/lib/comedi/calibrations to the package, and build using
--localstatedir=/var to store the state to the correct location.
Patch from A. Maitland Bottoms.
* Adjusted 01_calibrate_build.patch to remove check for comedilib.h too,
to ensure the comedi-calibrate/configure script work without libcomedi0.
2013-08-18 - Gudjon I. Gudjonsson <gudjon@gudjon.org>
comedilib (0.10.1-1) unstable; urgency=low
* New upstream release
* Bump compat to 9
* Add hardening
* Upgraded copyright file
2013-08-11 - Sebastian Ramacher <sramacher@debian.org>
comedilib (0.10.0-3.1) unstable; urgency=low
* Non-maintainer upload.
* debian/patches/03_bison.patch: Apply patch from upstream to fix build
failure with bison 2.6. (Closes: #710622)
* debian/python-comedilib.install: Don't install static libraries for the
Python package. They are of no use and cause a lintian autoreject.
2012-07-05 - Gudjon I. Gudjonsson <gudjon@gudjon.org>
comedilib (0.10.0-3) unstable; urgency=low
* Change pdf backend from fop to no. Fixes compilation on mips.
2012-06-25 - Gudjon I. Gudjonsson <gudjon@gudjon.org>
comedilib (0.10.0-2) unstable; urgency=low
* Add dependency on adduser (Closes: #677573)
2012-06-12 - Gudjon I. Gudjonsson <gudjon@gudjon.org>
comedilib (0.10.0-1) unstable; urgency=low
[ Bernd Porr ]
* Removed ruby from the build dependencies
* Disabled install of firmware (via ./configure)
[ Gudjon I. Gudjonsson ]
* Upstream release (Closes: #669353)
* Dropping ruby bindings support.
Commented out all references to ruby (Closes: #676095)
* Rename comedi.rules to 90-comedi.rules
* Move 90-comedi.rules to /lib/udev/rules.d/
* Add comedi_calibrate (Closes: #544906)
* Add LDFLAGS= -lm to configure (Closes: #558848)
* Change bash to sh in postinst script
* Fix a few errors in manpages. Add patch
02_fix_manpages.patch (Thanks to Yaroslav Halchenko)
* Add upstream changelog
* Update symbols file
* Update copyright file to DEP5

See Also

Package Description
python-commandnotfound_0.3ubuntu16.04_all.deb Python 2 bindings for command-not-found
python-commando_0.3.4-1.1_all.deb wrapper for argparse to define declaratively
python-compizconfig_0.9.12.2+16.04.20160415-0ubuntu1_amd64.deb Compizconfig bindings for Python
python-confargparse_1.1.20-2build1_amd64.deb argument/configuration file parser with the syntax of argparser (Python 2)
python-configargparse_0.10.0-2_all.deb replacement for argparse with config files and environment variables (Python 2)
python-configglue_1.1.2-0ubuntu3_all.deb Glues together optparse.OptionParser and ConfigParser.ConfigParser
python-configparser_3.3.0r2-2_all.deb backport of the enhanced config parser introduced in Python 3.2
python-configshell_1.6.1~g020d540-2_all.deb framework to create cli interfaces
python-congress_3.0.0+dfsg1-1_all.deb OpenStack Policy as a Service - Python libraries
python-congressclient-doc_1.2.3-2_all.deb client for the open policy framework for the cloud - doc
python-congressclient_1.2.3-2_all.deb client for the open policy framework for the cloud - Python 2.x
python-construct_2.5.2-0.1_all.deb powerful declarative parser (and builder) for binary data
python-contract_1.4-4_all.deb Programming by contract for Python
python-convoy_0.2.1+bzr39-1_all.deb WSGI app for loading multiple files in the same request
python-cookiecutter-doc_1.3.0-2_all.deb create projects from project templates (documentation)
Advertisement
Advertisement