python-chm_0.8.4.1-1_amd64.deb


Advertisement

Description

python-chm - Python binding for CHMLIB

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe amd64
Package name python-chm
Package version 0.8.4.1
Package release 1
Package architecture amd64
Package type deb
Installed size 114 B
Download size 20.51 KB
Official Mirror archive.ubuntu.com
PyCHM is a package that provides Python binding for Jed Wing's CHMLIB library.
The chm package contains four modules, namely chm.chm, chm.chmlib,
chm.extra and chm._chmlib, which provide access to the API implemented
by the C library chmlib and some additional classes and functions.
They are used to access MS-ITSS encoded files - Compressed Html Help
files (.chm).

Alternatives

Package Version Architecture Repository
python-chm_0.8.4.1-1_i386.deb 0.8.4.1 i386 Ubuntu Universe
python-chm - - -

Requires

Name Value
libc6 >= 2.4
libchm1 >= 0.40
python << 2.8
python >= 2.7~
python:any >= 2.7.5-5~

Download

Type URL
Binary Package python-chm_0.8.4.1-1_amd64.deb
Source Package pychm

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-chm deb package:
    # sudo apt-get install python-chm

Files

Path
/usr/lib/python2.7/dist-packages/chm/__init__.py
/usr/lib/python2.7/dist-packages/chm/_chmlib.x86_64-linux-gnu.so
/usr/lib/python2.7/dist-packages/chm/chm.py
/usr/lib/python2.7/dist-packages/chm/chmlib.py
/usr/lib/python2.7/dist-packages/chm/extra.x86_64-linux-gnu.so
/usr/lib/python2.7/dist-packages/pychm-0.8.4.1.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/pychm-0.8.4.1.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/pychm-0.8.4.1.egg-info/top_level.txt
/usr/share/doc/python-chm/README
/usr/share/doc/python-chm/changelog.Debian.gz
/usr/share/doc/python-chm/copyright

Changelog

2014-08-11 - Sandro Tosi <morph@debian.org>
pychm (0.8.4.1-1) unstable; urgency=low
[ Sandro Tosi ]
* New upstream release
* debian/control
- bump Standards-Version to 3.8.2 (no changes needed)
- switch me to Maintainer (team to Uploaders)
- updated upstream homepage
- removed useless fields from bin package
- bump Standards-Version to 3.9.5 (no changes needed)
- rename XS-P-V to X-P-V
- add python-setuptools to b-d
* debian/watch
- update to point to PyPI
* debian/copyright
- update and switch to DEP-5 format
* debian/docs
- removed NEWS, no longer shipped
* Switch to dh sequencer and dh_python2; Closes: #631400
* debian/source/format
- switch to 3.0 (quilt) format
* debian/pycompat
- removed, no longer used
[ Jakub Wilk ]
* Use canonical URIs for Vcs-* fields.
2009-01-31 - Sandro Tosi <morph@debian.org>
pychm (0.8.4-1) unstable; urgency=low
* Adopting under DPMT umbrella; Closes: #512460
* debian/control
- set DPMT as maintainer, me as uploader
- bump Standards-Version to 3.8.0
- moved Homepage file from long description to source stanza
- added Vcs-{Browser,Svn} fields
- s/python/Python/ in long description
- added XS-Python-Version flag
- don't wrap b-d, adding a space on versioned libchm-dev b-d
* debian/watch
- removed comments and cruft
* debian/copyright
- added Upstream author section
- added a clear statement about copyright holder
- added files that are based on other copyright materials
- indented license with 4 spaces
- clarified the reference to Debian license file to be GPLv2 one
2006-12-06 - Ganesan Rajagopal <rganesan@debian.org>
pychm (0.8.4-0.1) unstable; urgency=low
* Non-maintainer upload.
* New upstream release (Closes: #379582).
2006-07-06 - Carlos Z.F. Liu <carlosliu@users.sourceforge.net>
pychm (0.8.3-1) unstable; urgency=low
* New upstream release
* Acknowledge NMU, Thanks Pierre Habouzit. (Closes: #373487)
* Bump Standards-Version to 3.7.2, no change needed.
2006-06-29 - Pierre Habouzit <madcoder@debian.org>
pychm (0.8.2-4.1) unstable; urgency=low
* Non-maintainer upload.
* Update package to the new python policy (Closes: #373487).
2005-12-13 - Carlos Z.F. Liu <carlosliu@users.sourceforge.net>
pychm (0.8.2-4) unstable; urgency=low
* Build-Depend on libchm-dev instead of chmlib-dev. (Closes: #343065)
* bump Standards-Version to 3.6.2, no change needed.
* debian/copyright : update FSF address.
* debian/watch : updated
2005-06-22 - Carlos Z.F. Liu <carlosliu@users.sourceforge.net>
pychm (0.8.2-3) unstable; urgency=low
* First official Debian release (Closes: #277087)
* Don't Provide python-pychm anymore. 
2005-06-19 - Carlos Z.F. Liu <carlosliu@users.sourceforge.net>
pychm (0.8.2-2) unstable; urgency=low
* Rename binary package to python-chm, thanks Josselin Mouette
for suggestion.
* debian/copyright: use new template, thanks Bartosz Fenski.
2005-03-06 - Carlos Z.F. Liu <carlosliu@users.sourceforge.net>
pychm (0.8.2-1) unstable; urgency=low
* New upstream release
* switch the build system to cdbs
* Improve the description, thanks Paul Wise <pabs@zip.to>
2004-11-09 - Carlos Z.F. Liu <carlosliu@users.sourceforge.net>
pychm (0.8.1-1) unstable; urgency=low
* New upstream release
* Make the description clearer
* Change maintainer's email address
* Builde-Depend on python-dev instead of python2.3-dev,
otherwise dh_python wouldn't work.

See Also

Package Description
python-cigi_3.3.3a+svn818-10ubuntu1_amd64.deb Python bindings for the CIGI class library
python-cinfony_1.2-1_all.deb Python abstraction layer to cheminformatics toolkits
python-circuits-doc_3.1.0+ds1-1_all.deb event-driven framework with a component architecture (Documentation)
python-circuits_3.1.0+ds1-1_all.deb event-driven framework with a component architecture
python-citeproc_0.3.0-1_all.deb Citation Style Language (CSL) processor for Python
python-cjson_1.1.0-2_amd64.deb Very fast JSON encoder/decoder for Python
python-ckanclient_0.9-1.1_amd64.deb CKAN client Python package
python-clang-3.5_3.5.2-3ubuntu1_amd64.deb Clang Python Bindings
python-clang-3.6_3.6.2-3ubuntu2_amd64.deb Clang Python Bindings
python-clang-3.7_3.7.1-2ubuntu2_amd64.deb Clang Python Bindings
python-clang-3.8_3.8-2ubuntu1_amd64.deb Clang Python Bindings
python-clearsilver_0.10.5-1.6build1_amd64.deb Python bindings for clearsilver
python-cliapp_1.20160109-1_all.deb Python framework for Unix command line programs
python-click-plugins_1.0.2-1ubuntu3_all.deb Click extension to register external CLI commands (Python 2)
python-click_6.2-2ubuntu1_all.deb Simple wrapper around optparse for powerful command line utilities - Python 2.7
Advertisement
Advertisement