python-caja_1.12.0-1_amd64.deb


Advertisement

Description

python-caja - Python binding for Caja components

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe amd64
Package name python-caja
Package version 1.12.0
Package release 1
Package architecture amd64
Package type deb
Installed size 53 B
Download size 12.00 KB
Official Mirror archive.ubuntu.com
Caja is the official file manager for the MATE desktop. It allows one
to browse directories, preview files and launch applications associated
with them. It is also responsible for handling the icons on the MATE
desktop. It works on local and remote filesystems.
The Python binding for Caja allows one to write Caja property page
and menu item extensions in Python.

Alternatives

Package Version Architecture Repository
python-caja_1.12.0-1_i386.deb 1.12.0 i386 Ubuntu Universe
python-caja - - -

Requires

Name Value
gir1.2-caja -
libc6 >= 2.4
libcaja-extension1 >= 1.6.3
libglib2.0-0 >= 2.16.0
libgtk2.0-0 >= 2.8.0
libpython2.7 >= 2.7
python-caja-common = 1.12.0-1

Download

Type URL
Binary Package python-caja_1.12.0-1_amd64.deb
Source Package python-caja

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-caja deb package:
    # sudo apt-get install python-caja

Files

Path
/usr/lib/x86_64-linux-gnu/caja/extensions-2.0/libcaja-python.so
/usr/lib/x86_64-linux-gnu/pkgconfig/caja-python.pc
/usr/share/caja-python/extensions/.placeholder
/usr/share/doc/python-caja/changelog.Debian.gz
/usr/share/doc/python-caja/copyright
/usr/share/lintian/overrides/python-caja

Changelog

2016-01-02 - Mike Gabriel <sunweaver@debian.org>
python-caja (1.12.0-1) unstable; urgency=medium
[ Martin Wimpress ]
* New upstream release.
* debian/control:
+ Versioned B-D: mate-common (>= 1.12) and libcaja-extension-dev (>= 1.12).
* debian/pycompat:
+ Not used by any modern Python helper. Removed.
[ Mike Gabriel ]
* Make build reproducible. Thanks to Cris Lamb for providing the patch.
(Closes: #809027).
* debian/control:
+ Fix grammar error in LONG_DESCRIPTION of several bin:packages.
* lintian:
+ Drop non-used-anymore override: postrm-has-useless-call-to-ldconfig
(python-caja).
2015-09-17 - Mike Gabriel <sunweaver@debian.org>
python-caja (1.10.0-2) unstable; urgency=medium
[ Martin Wimpress ]
* debian/control:
+ B-D libgirepository1.0-dev.
* debian/patches:
+ Add 2001_fix-python-libdir-not-found.patch.
[ Mike Gabriel ]
* debian/patches:
+ Add README file explaining about patch naming scheme.
2015-08-21 - Mike Gabriel <sunweaver@debian.org>
python-caja (1.10.0-1) unstable; urgency=medium
[ Martin Wimpress ]
* debian/python-caja.install:
+ Remove usr/share/doc/python-caja/
* debian/python-caja-common.install:
+ Add usr/share/doc/.
[ Mike Gabriel ]
* Upload to unstable.
2015-07-14 - Mike Gabriel <sunweaver@debian.org>
python-caja (1.10.0-1~exp2) experimental; urgency=medium
* debian/python-caja*.install:
+ Make sure, both packages don't share common files. (Closes: #789626).
2015-06-19 - Mike Gabriel <sunweaver@debian.org>
python-caja (1.10.0-1~exp1) experimental; urgency=medium
* New upstream release.
* debian/control:
+ Add python-caja-common.
* debian/patches:
+ Drop 1001_multi-arch-libdir-in-pkgconfig.patch. Applied upstream.
+ Drop 1002_dont-install-xsl-files.patch. Applied upstream.
+ Drop 2001_debian-python-multiarch.patch. Debian bug #770935 has
been fixed. This patch is no longer required.
[ Mike Gabriel ]
* debian/control:
+ Versioned B-D: mate-common (>= 1.10).
+ Add Martin Wimpress to Uploaders: field.
* debian/copyright:
+ Update for this upstream release. Provide info for po/*.po.
2014-11-25 - Mike Gabriel <sunweaver@debian.org>
python-caja (1.8.1-2) unstable; urgency=medium
[ Vangelis Mouhtsis ]
* debian/control:
+ Fix typo in python-caja-dbg LONG_DESCRIPTION. (Closes: #768819, #768820).
[ Mike Gabriel ]
* debian/patches:
+ Add 1002_dont-install-xsl-files.patch. Stop attempting to install XSL
docbook source files into bin:package. (Closes: #770927).
+ Add 2001_debian-python-multiarch.patch. Enforce usage of multiarch path
for PY_LIB_LOC. (Closes: 766879, LP: #1170017).
* lintian:
+ Add overrides for debhelper's erroneously triggered makeshlibs script.
2014-10-24 - Mike Gabriel <sunweaver@debian.org>
python-caja (1.8.1-1) unstable; urgency=medium
[ Vangelis Mouhtsis ]
* debian/rules:
+ Replace on dh_install --list-missing -> --fail-missing
* debian/control:
+ Bump Standards: to 3.9.6. No changes needed.
[ Mike Gabriel ]
* New upstream release.
- Detect Python variables via pkg-config. (LP: #1170017).
* debian/patches:
+ Add 1001_multi-arch-libdir-in-pkgconfig.patch. Put multi-arch linker
path in caja-python.pc.
* debian/rules:
+ Provide an empty caja-python/extensions folder (with .placeholder file).
2014-04-25 - Mike Gabriel <sunweaver@debian.org>
python-caja (1.8.0-1) unstable; urgency=low
* Initial release. (Closes: #734993).

See Also

Package Description
python-calabash_0.0.3-3_all.deb Bash-style pipelining syntax for Python generators
python-caldav_0.4.0-1_all.deb CalDAV (RFC4791) client library
python-camera-calibration-parsers_1.11.10-5_amd64.deb Robot OS camera_calibration_parsers Python package
python-canl_1.1.0-2_amd64.deb EMI Common Authentication Library - Python bindings
python-cap-ng_0.7.7-1_amd64.deb Python bindings for libcap-ng
python-capstone_3.0.4-0.2_amd64.deb lightweight multi-architecture disassembly framework - Python bindings
python-captcha_0.4-2_all.deb collection of Python modules implementing CAPTCHAs
python-carquinyol-0.88_0.88.0-4_amd64.deb Sugar graphical shell - datastore
python-carquinyol_0.106.0-1_amd64.deb Sugar Learning Platform - datastore
python-carrot_0.10.7-1.1_all.deb AMQP messaging queue framework
python-casmoothing_0.2-1_amd64.deb Context-aware mesh smoothing for biomedical applications
python-cassandra_2.5.1-1_all.deb Python driver for Apache Cassandra
python-catcher_0.1.7+git20140530-1_all.deb beautiful stack traces generator for Python
python-catkin-pkg_0.2.10-2_all.deb Low-level build system macros for Robot OS -- Python module
python-catwalk_2.0.2-6_all.deb model management interface for the Turbogears web framework
Advertisement
Advertisement