python-breathe_4.1.0-1_all.deb


Advertisement

Description

python-breathe - Sphinx autodox support for languages other than Python (Python 2)

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe amd64
Package name python-breathe
Package version 4.1.0
Package release 1
Package architecture all
Package type deb
Installed size 491 B
Download size 51.66 KB
Official Mirror archive.ubuntu.com
Breathe provides a bridge between the Sphinx and doxygen documentation
systems. It enables Sphinx to generate autodoc for languages other than Python
with the help of doxygen. It also allows one to embed reStructuredText in
doxygen markup.
This package provides the module for Python 2.

Alternatives

Package Version Architecture Repository
python-breathe_4.1.0-1_all.deb 4.1.0 all Ubuntu Universe
python-breathe - - -

Requires

Name Value
doxygen -
python-docutils -
python-six -
python-sphinx -
python:any >= 2.7.5-5~
python:any << 2.8

Download

Type URL
Binary Package python-breathe_4.1.0-1_all.deb
Source Package breathe

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-breathe deb package:
    # sudo apt-get install python-breathe

Files

Path
/usr/lib/python2.7/dist-packages/breathe/__init__.py
/usr/lib/python2.7/dist-packages/breathe/directives.py
/usr/lib/python2.7/dist-packages/breathe/exception.py
/usr/lib/python2.7/dist-packages/breathe/process.py
/usr/lib/python2.7/dist-packages/breathe/project.py
/usr/lib/python2.7/dist-packages/breathe-4.1.0.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/breathe-4.1.0.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/breathe-4.1.0.egg-info/not-zip-safe
/usr/lib/python2.7/dist-packages/breathe-4.1.0.egg-info/requires.txt
/usr/lib/python2.7/dist-packages/breathe-4.1.0.egg-info/top_level.txt
/usr/lib/python2.7/dist-packages/breathe/directive/__init__.py
/usr/lib/python2.7/dist-packages/breathe/directive/base.py
/usr/lib/python2.7/dist-packages/breathe/directive/file.py
/usr/lib/python2.7/dist-packages/breathe/directive/index.py
/usr/lib/python2.7/dist-packages/breathe/finder/__init__.py
/usr/lib/python2.7/dist-packages/breathe/finder/core.py
/usr/lib/python2.7/dist-packages/breathe/finder/doxygen/__init__.py
/usr/lib/python2.7/dist-packages/breathe/finder/doxygen/base.py
/usr/lib/python2.7/dist-packages/breathe/finder/doxygen/compound.py
/usr/lib/python2.7/dist-packages/breathe/finder/doxygen/core.py
/usr/lib/python2.7/dist-packages/breathe/finder/doxygen/index.py
/usr/lib/python2.7/dist-packages/breathe/parser/__init__.py
/usr/lib/python2.7/dist-packages/breathe/parser/doxygen/__init__.py
/usr/lib/python2.7/dist-packages/breathe/parser/doxygen/compound.py
/usr/lib/python2.7/dist-packages/breathe/parser/doxygen/compoundsuper.py
/usr/lib/python2.7/dist-packages/breathe/parser/doxygen/index.py
/usr/lib/python2.7/dist-packages/breathe/parser/doxygen/indexsuper.py
/usr/lib/python2.7/dist-packages/breathe/renderer/__init__.py
/usr/lib/python2.7/dist-packages/breathe/renderer/rst/__init__.py
/usr/lib/python2.7/dist-packages/breathe/renderer/rst/doxygen/__init__.py
/usr/lib/python2.7/dist-packages/breathe/renderer/rst/doxygen/base.py
/usr/lib/python2.7/dist-packages/breathe/renderer/rst/doxygen/compound.py
/usr/lib/python2.7/dist-packages/breathe/renderer/rst/doxygen/filter.py
/usr/lib/python2.7/dist-packages/breathe/renderer/rst/doxygen/index.py
/usr/lib/python2.7/dist-packages/breathe/renderer/rst/doxygen/mask.py
/usr/lib/python2.7/dist-packages/breathe/renderer/rst/doxygen/target.py
/usr/share/doc/python-breathe/changelog.Debian.gz
/usr/share/doc/python-breathe/copyright

Changelog

2015-08-28 - Sebastian Ramacher <sramacher@debian.org>
breathe (4.1.0-1) unstable; urgency=medium
* New upstream release (Closes: #797142)
* debian/control:
- Remove XS-Autotest field.
- Add python-six and python3-six to Build-Depends.
2015-05-03 - Sebastian Ramacher <sramacher@debian.org>
breathe (4.0.0-2) unstable; urgency=medium
* debian/tests/control: Add texlive-latex-extra and
texlive-fonts-recommended to test dependencies.
2015-04-03 - Sebastian Ramacher <sramacher@debian.org>
breathe (4.0.0-1) unstable; urgency=medium
* New upstream release.
* Upload to unstable.
* debian/control:
- Move to collab-maint and git.
- Set myself as sole Maintainer.
- Build-Depends: Add texlive-latex-extra and texlive-fonts-recommended.
* debian/patches/conf.py-version.patch: Refreshed.
2014-11-16 - Sebastian Ramacher <sramacher@debian.org>
breathe (3.2.0-1) experimental; urgency=medium
* New upstream release.
* debian/control: Bump Standards-Version, no changes required.
* debian/patches: Refresh patches.
* debian/rules: Export READTHEDOCS and TRAVIS_CI to control documentation
build.
2014-09-16 - Sebastian Ramacher <sramacher@debian.org>
breathe (3.1.0-1) unstable; urgency=medium
* New upstream release.
2014-08-10 - Sebastian Ramacher <sramacher@debian.org>
breathe (3.0.0-2) unstable; urgency=medium
* debian/tests/control: Add make to Depends which is needed by the tests.
2014-08-07 - Sebastian Ramacher <sramacher@debian.org>
breathe (3.0.0-1) unstable; urgency=medium
* New upstream release.
* debian/watch: Mangle filename.
2014-06-18 - Sebastian Ramacher <sramacher@debian.org>
breathe (2.0.0-1) unstable; urgency=medium
* New upstream release.
* debian/control:
- Add Suggests: breathe-doc to python{,3}-breathe. (Closes: #743781)
- Point Homepage to upstream repository.
* debian/rules: Call pybuild with --test instead of --build to run tests and
run the test for the correct Python version.
* debian/patches:
- undefined-names.patch: Removed, applied upstream.
- conf.py-version.patch: Hardcode version for documentation instead of
running git describe.
* Fix MathJax symlinks:
- debian/{rules,breathe-doc.links}: Link _static/mathjax to the packaged
MathJax directory and create the appropriate symlinks in the package.
- debian/patches/packaged-mathjax.patch: Refreshed and adopted for the new
symlink.
* debian/tests: Add DEP-8 tests.
* debian/copyright: Update copyright years
2014-02-03 - Sebastian Ramacher <sramacher@debian.org>
breathe (1.2.0-1) unstable; urgency=low
* Initial release. (Closes: #736990)

See Also

Package Description
python-brian-doc_1.4.3-1_all.deb simulator for spiking neural networks - documentation
python-brian-lib_1.4.3-1_amd64.deb simulator for spiking neural networks -- extensions
python-brian_1.4.3-1_all.deb simulator for spiking neural networks
python-brlapi_5.3.1-2ubuntu2_amd64.deb Braille display access via BRLTTY - Python bindings
python-broccoli_0.59+1-1_amd64.deb Python bindings for Broccoli
python-brotli_0.3.0+dfsg-2_amd64.deb lossless compression algorithm and format (Python 2 version)
python-bson-ext_3.2-1build1_amd64.deb C-coded extension to the python-bson package
python-bson_3.2-1build1_amd64.deb Python implementation of BSON for MongoDB
python-btchip_0.1.16-1_all.deb Python library to communicate with BTChip dongle
python-buffy_0.16build1_amd64.deb Python wrapper for the libbuffy library
python-bunch_1.0.1-1_all.deb Dot-accessible Python dictionary (a la JavaScript objects)
python-burrito_0.9.1-1_all.deb Python 2 framework for wrapping and controlling command-line applications
python-buzhug_1.8-3_all.deb pure-Python database engine, using a Pythonic, no-SQL syntax
python-bz2file_0.98-1_all.deb Python library for reading and writing bzip2-compressed files
python-bzrlib.tests_2.7.0-2ubuntu1_all.deb distributed version control system - testsuite
Advertisement
Advertisement