python-bobo_0.2.2-3build1_all.deb


Advertisement

Description

python-bobo - Web application framework for the impatient

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: python-bobo
Package version: 0.2.2
Package release: 3build1
Package architecture: all
Package type: deb
Installed size: 111 B
Download size: 18.30 KB
Official Mirror: archive.ubuntu.com
Bobo is a light-weight framework for creating WSGI web applications. It's goal is to be easy to use and remember. It addresses 2 problems: Mapping URLs to objects, calling objects to generate HTTP responses. Bobo doesn't have a templateing language, a database integration layer, or a number of other features that are better provided by WSGI middle-ware or application-specific libraries. Bobo builds on other frameworks, most notably WSGI and WebOb.

Alternatives

Provides

  • python2.7-bobo

    Download

    Source package: bobo

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-bobo deb package:
      # sudo apt-get install python-bobo

    Files

    • /usr/bin/bobo
    • /usr/lib/python2.7/dist-packages/bobo.py
    • /usr/lib/python2.7/dist-packages/boboserver.py
    • /usr/lib/python2.7/dist-packages/bobo-0.2.2.egg-info/PKG-INFO
    • /usr/lib/python2.7/dist-packages/bobo-0.2.2.egg-info/SOURCES.txt
    • /usr/lib/python2.7/dist-packages/bobo-0.2.2.egg-info/dependency_links.txt
    • /usr/lib/python2.7/dist-packages/bobo-0.2.2.egg-info/entry_points.txt
    • /usr/lib/python2.7/dist-packages/bobo-0.2.2.egg-info/requires.txt
    • /usr/lib/python2.7/dist-packages/bobo-0.2.2.egg-info/top_level.txt
    • /usr/share/doc/python-bobo/README.txt
    • /usr/share/doc/python-bobo/changelog.Debian.gz
    • /usr/share/doc/python-bobo/copyright
    • /usr/share/pyshared/bobo.py
    • /usr/share/pyshared/boboserver.py
    • /usr/share/pyshared/bobo-0.2.2.egg-info/PKG-INFO
    • /usr/share/pyshared/bobo-0.2.2.egg-info/SOURCES.txt
    • /usr/share/pyshared/bobo-0.2.2.egg-info/dependency_links.txt
    • /usr/share/pyshared/bobo-0.2.2.egg-info/entry_points.txt
    • /usr/share/pyshared/bobo-0.2.2.egg-info/requires.txt
    • /usr/share/pyshared/bobo-0.2.2.egg-info/top_level.txt

    Changelog

    2011-12-31 - Matthias Klose <doko@ubuntu.com> bobo (0.2.2-3build1) precise; urgency=low * Rebuild to drop python2.6 dependencies.

    2011-05-16 - Arnaud Fontaine <arnau@debian.org> bobo (0.2.2-3) unstable; urgency=low * Team upload. Closes: #623918. * Switch to "3.0 (quilt)" source format. * debian/control: + Bump Standards-Version to 3.9.2. No changes needed. + Add Vcs-Browser fields. + Rename XS-Vcs-Svn to Vcs-Svn (dpkg supports it now). + Remove minimum required version of python-setuptools because even stable has a greater version. + Build-Depends on python-all (not -dev). + Add Depends on python-pkg-resources as it is required by the script. Closes: #602023. * debian/rules: + Drop versioned scripts. * Switch from deprecated dh_pycentral to dh_python2. Closes: #616749. + debian/control: - Bump python-all minimum version to 2.6.6-3~. - Remove python-central from Build-Depends. - Remove deprecated XB-Python-Version. - Rename deprecated XS-Python-Version to X-Python-Version and specify explicitly the minimum supported version. + debian/rules: - Use --with python2 rather than --with python-central. * debian/docs: + Add README.txt.

    2010-01-26 - Brian Sutherland <brian@vanguardistas.net> bobo (0.2.2-2) unstable; urgency=low * Bump the build depends on python-setuptools to 0.6c9 to prevent the attempted download of a newer setuptools.

    2010-01-12 - Brian Sutherland <brian@vanguardistas.net> bobo (0.2.2-1) unstable; urgency=low * Initial Packaging.

    Advertisement
    Advertisement