python-beaker_1.6.4-2build1_all.deb


Advertisement

Description

python-beaker - cache and session library

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: python-beaker
Package version: 1.6.4
Package release: 2build1
Package architecture: all
Package type: deb
Installed size: 209 B
Download size: 34.96 KB
Official Mirror: archive.ubuntu.com
Beaker is a web session and general caching library that includes WSGI middleware for use in web applications. As a general caching library, Beaker can handle storing for various times any Python object that can be pickled with optional back-ends on a fine-grained basis. Features: * Fast, robust performance * Multiple reader/single writer lock system to avoid duplicate simultaneous cache creation * Cache back-ends include dbm, file, memory, memcached, and database (using SQLAlchemy for multiple-db vendor support) * Signed cookies to prevent session hijacking/spoofing * Cookie-only sessions to remove the need for a database or file backend (ideal for clustered systems) * Extensible Container object to support new back-ends * Caches can be divided into namespaces (to represent templates, objects, etc.) then keyed for different copies * Create functions for automatic call-backs to create new cache copies after expiration * Fine-grained toggling of back-ends, keys, and expiration per Cache object

Alternatives

    Download

    Source package: beaker

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-beaker deb package:
      # sudo apt-get install python-beaker

    Files

    • /usr/lib/python2.7/dist-packages/Beaker-1.6.4.egg-info/PKG-INFO
    • /usr/lib/python2.7/dist-packages/Beaker-1.6.4.egg-info/dependency_links.txt
    • /usr/lib/python2.7/dist-packages/Beaker-1.6.4.egg-info/entry_points.txt
    • /usr/lib/python2.7/dist-packages/Beaker-1.6.4.egg-info/not-zip-safe
    • /usr/lib/python2.7/dist-packages/Beaker-1.6.4.egg-info/requires.txt
    • /usr/lib/python2.7/dist-packages/Beaker-1.6.4.egg-info/top_level.txt
    • /usr/lib/python2.7/dist-packages/beaker/__init__.py
    • /usr/lib/python2.7/dist-packages/beaker/cache.py
    • /usr/lib/python2.7/dist-packages/beaker/container.py
    • /usr/lib/python2.7/dist-packages/beaker/converters.py
    • /usr/lib/python2.7/dist-packages/beaker/exceptions.py
    • /usr/lib/python2.7/dist-packages/beaker/middleware.py
    • /usr/lib/python2.7/dist-packages/beaker/session.py
    • /usr/lib/python2.7/dist-packages/beaker/synchronization.py
    • /usr/lib/python2.7/dist-packages/beaker/util.py
    • /usr/lib/python2.7/dist-packages/beaker/crypto/__init__.py
    • /usr/lib/python2.7/dist-packages/beaker/crypto/jcecrypto.py
    • /usr/lib/python2.7/dist-packages/beaker/crypto/nsscrypto.py
    • /usr/lib/python2.7/dist-packages/beaker/crypto/pbkdf2.py
    • /usr/lib/python2.7/dist-packages/beaker/crypto/pycrypto.py
    • /usr/lib/python2.7/dist-packages/beaker/crypto/util.py
    • /usr/lib/python2.7/dist-packages/beaker/ext/__init__.py
    • /usr/lib/python2.7/dist-packages/beaker/ext/database.py
    • /usr/lib/python2.7/dist-packages/beaker/ext/google.py
    • /usr/lib/python2.7/dist-packages/beaker/ext/memcached.py
    • /usr/lib/python2.7/dist-packages/beaker/ext/sqla.py
    • /usr/share/doc/python-beaker/NEWS.Debian.gz
    • /usr/share/doc/python-beaker/changelog.Debian.gz
    • /usr/share/doc/python-beaker/copyright
    • /usr/share/python/dist/python-beaker

    Changelog

    2015-07-22 - Steve Langasek <steve.langasek@ubuntu.com> beaker (1.6.4-2build1) wily; urgency=medium * No-change rebuild for python3.5 transition

    2014-10-19 - Piotr Ożarowski <piotr@debian.org> beaker (1.6.4-2) unstable; urgency=low [ Jakub Wilk ] * Use canonical URIs for Vcs-* fields. [ Piotr Ożarowski ] * Upload to unstable * Switch to debhelper compat level 9 * Add dh-python to Build-Depends * Use default compression in dh_builddeb * Update Standards-Version to 3.9.6 (no change needed)

    2012-09-13 - Piotr Ożarowski <piotr@debian.org> beaker (1.6.4-1) experimental; urgency=low * New upstream release * Upload to experimental due to Wheezy freeze

    2012-08-24 - David Prévot <taffit@debian.org> beaker (1.6.3-1.1) unstable; urgency=low * Non-maintainer upload. * Fix security issue, with PyCrypto not securing data such that an attacker could possibly determine parts of the encrypted payload. Patch by Miloslav Trmac of Redhat. [CVE-2012-3458] Closes: #684890

    2012-05-06 - Piotr Ożarowski <piotr@debian.org> beaker (1.6.3-1) unstable; urgency=low [ Andrey Rahmatullin ] * Update Standards-Version to 3.9.1 (no change needed) * Switch from dh_pysupport to dh_python2 [ Piotr Ożarowski ] * New upstream release - delete_cookie's expire date calculated via timedelta instead or .replace(year=2003). Closes: #661670 * Remove egg-info/* files in clean target (regenerated in install) - debhelper compatibility level bumped to 7 (debian/clean file used) * Source format changed to 3.0 (quilt) * Standards-Version bumped to 3.9.3 (no changes needed)

    2010-09-23 - Piotr Ożarowski <piotr@debian.org> beaker (1.5.4-4) unstable; urgency=low * Upload to unstable

    2010-09-12 - Piotr Ożarowski <piotr@debian.org> beaker (1.5.4-3) experimental; urgency=low * Rebuild against newer python3 package (python3.1 now uses /usr/lib/python3/) * Minimum python3-all version bumped to 3.1.2-8

    2010-09-06 - Piotr Ożarowski <piotr@debian.org> beaker (1.5.4-2) experimental; urgency=low * Provide python3-beaker * Provide pydist files

    2010-06-19 - Piotr Ożarowski <piotr@debian.org> beaker (1.5.4-1) unstable; urgency=low * New upstream release

    2010-03-03 - Piotr Ożarowski <piotr@debian.org> beaker (1.5.3-1) unstable; urgency=low * New upstream release

    Advertisement
    Advertisement