python-bashate_0.3.1-2_all.deb


Advertisement

Description

python-bashate - bash script style guide checker - Python 2.x

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: python-bashate
Package version: 0.3.1
Package release: 2
Package architecture: all
Package type: deb
Installed size: 46 B
Download size: 7.92 KB
Official Mirror: archive.ubuntu.com
This program attempts to be an automated style checker for bash scripts to fill the same part of code review that pep8 does in most OpenStack projects. It started from humble beginnings in the DevStack project, and will continue to evolve over time. This package contains the Python 2.x module and command line utility.

Alternatives

    Download

    Source package: python-bashate

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-bashate deb package:
      # sudo apt-get install python-bashate

    Files

    • /usr/bin/python2-bashate
    • /usr/lib/python2.7/dist-packages/bashate/__init__.py
    • /usr/lib/python2.7/dist-packages/bashate/bashate.py
    • /usr/lib/python2.7/dist-packages/bashate-0.3.1.egg-info/PKG-INFO
    • /usr/lib/python2.7/dist-packages/bashate-0.3.1.egg-info/dependency_links.txt
    • /usr/lib/python2.7/dist-packages/bashate-0.3.1.egg-info/entry_points.txt
    • /usr/lib/python2.7/dist-packages/bashate-0.3.1.egg-info/not-zip-safe
    • /usr/lib/python2.7/dist-packages/bashate-0.3.1.egg-info/requires.txt
    • /usr/lib/python2.7/dist-packages/bashate-0.3.1.egg-info/top_level.txt
    • /usr/lib/python2.7/dist-packages/bashate/tests/__init__.py
    • /usr/lib/python2.7/dist-packages/bashate/tests/base.py
    • /usr/lib/python2.7/dist-packages/bashate/tests/test_bashate.py
    • /usr/share/doc/python-bashate/changelog.Debian.gz
    • /usr/share/doc/python-bashate/copyright

    Changelog

    2015-10-23 - Thomas Goirand <zigo@debian.org> python-bashate (0.3.1-2) unstable; urgency=medium * override_dh_python3 to fix Py3 shebang.

    2015-06-15 - Thomas Goirand <zigo@debian.org> python-bashate (0.3.1-1) unstable; urgency=medium * New upstream release: - The package no-longer does file discover by itself (Closes: #776549). * Added dh-python as build-depends. * Switching to gz compression for the orig.tar. * Dropped version in most (build-)depends, since they are available in both Jessie and Trusty. * Fixed watch file to use github tag instead of pypi. * Standards-Version is now 3.9.6 (no change).

    2014-08-17 - Thomas Goirand <zigo@debian.org> python-bashate (0.2.0-1) unstable; urgency=medium * Initial release.

    Advertisement
    Advertisement