python-authkit_0.4.3-2_all.deb


Advertisement

Description

python-authkit - authentication and authorisation framework for Python WSGI applications

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: python-authkit
Package version: 0.4.3
Package release: 2
Package architecture: all
Package type: deb
Installed size: 559 B
Download size: 83.37 KB
Official Mirror: archive.ubuntu.com
AuthKit is a Python module that provides functionality for WSGI (web) applications to use authentication and authorisation. * Built for WSGI applications and middleware * Sophisticated and extensible permissions system * Built in support for HTTP basic, HTTP digest, form, cookie and OpenID authentication methods plus others. * Easily define users, passwords and roles * Designed to be totally extensible so you can use the components to integrate with a database, LDAP connection or your own custom system. * Plays nicely with the Pylons web framework.

Alternatives

    Download

    Source package: python-authkit

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-authkit deb package:
      # sudo apt-get install python-authkit

    Files

    • /usr/lib/python2.7/dist-packages/AuthKit-0.4.3.egg-info/PKG-INFO
    • /usr/lib/python2.7/dist-packages/AuthKit-0.4.3.egg-info/SOURCES.txt
    • /usr/lib/python2.7/dist-packages/AuthKit-0.4.3.egg-info/dependency_links.txt
    • /usr/lib/python2.7/dist-packages/AuthKit-0.4.3.egg-info/entry_points.txt
    • /usr/lib/python2.7/dist-packages/AuthKit-0.4.3.egg-info/not-zip-safe
    • /usr/lib/python2.7/dist-packages/AuthKit-0.4.3.egg-info/requires.txt
    • /usr/lib/python2.7/dist-packages/AuthKit-0.4.3.egg-info/top_level.txt
    • /usr/lib/python2.7/dist-packages/authkit/__init__.py
    • /usr/lib/python2.7/dist-packages/authkit/permissions.py
    • /usr/lib/python2.7/dist-packages/authkit/pylons_adaptors.py
    • /usr/lib/python2.7/dist-packages/authkit/authenticate/__init__.py
    • /usr/lib/python2.7/dist-packages/authkit/authenticate/basic.py
    • /usr/lib/python2.7/dist-packages/authkit/authenticate/cookie.py
    • /usr/lib/python2.7/dist-packages/authkit/authenticate/digest.py
    • /usr/lib/python2.7/dist-packages/authkit/authenticate/form.py
    • /usr/lib/python2.7/dist-packages/authkit/authenticate/forward.py
    • /usr/lib/python2.7/dist-packages/authkit/authenticate/multi.py
    • /usr/lib/python2.7/dist-packages/authkit/authenticate/open_id.py
    • /usr/lib/python2.7/dist-packages/authkit/authenticate/redirect.py
    • /usr/lib/python2.7/dist-packages/authkit/authenticate/sso/__init__.py
    • /usr/lib/python2.7/dist-packages/authkit/authenticate/sso/api.py
    • /usr/lib/python2.7/dist-packages/authkit/authenticate/sso/cas.py
    • /usr/lib/python2.7/dist-packages/authkit/authorize/__init__.py
    • /usr/lib/python2.7/dist-packages/authkit/authorize/powerpack_adaptors.py
    • /usr/lib/python2.7/dist-packages/authkit/authorize/pylons_adaptors.py
    • /usr/lib/python2.7/dist-packages/authkit/authorize/wsgi_adaptors.py
    • /usr/lib/python2.7/dist-packages/authkit/template/__init__.py
    • /usr/lib/python2.7/dist-packages/authkit/template/authenticate/setup.cfg
    • /usr/lib/python2.7/dist-packages/authkit/template/authenticate/setup.py_tmpl
    • /usr/lib/python2.7/dist-packages/authkit/template/authenticate/+package+/__init__.py_tmpl
    • /usr/lib/python2.7/dist-packages/authkit/template/authenticate/docs/license.txt_tmpl
    • /usr/lib/python2.7/dist-packages/authkit/template/authenticate/ez_setup/README.txt
    • /usr/lib/python2.7/dist-packages/authkit/template/authenticate/ez_setup/__init__.py
    • /usr/lib/python2.7/dist-packages/authkit/users/__init__.py
    • /usr/lib/python2.7/dist-packages/authkit/users/postgresql_driver.py
    • /usr/lib/python2.7/dist-packages/authkit/users/sqlalchemy_04_driver.py
    • /usr/lib/python2.7/dist-packages/authkit/users/sqlalchemy_driver/__init__.py
    • /usr/lib/python2.7/dist-packages/authkit/users/sqlalchemy_driver/sqlalchemy_03.py
    • /usr/lib/python2.7/dist-packages/authkit/users/sqlalchemy_driver/sqlalchemy_04.py
    • /usr/lib/python2.7/dist-packages/authkit/users/sqlalchemy_driver/sqlalchemy_044.py
    • /usr/lib/python2.7/dist-packages/authkit/users/sqlalchemy_driver/sqlalchemy_05.py
    • /usr/share/doc/python-authkit/README.Debian
    • /usr/share/doc/python-authkit/README.txt
    • /usr/share/doc/python-authkit/changelog.Debian.gz
    • /usr/share/doc/python-authkit/copyright
    • /usr/share/doc/python-authkit/docs/community.txt
    • /usr/share/doc/python-authkit/docs/download.txt
    • /usr/share/doc/python-authkit/docs/index.txt
    • /usr/share/doc/python-authkit/docs/manual.txt
    • /usr/share/doc/python-authkit/docs/pylons.txt
    • /usr/share/doc/python-authkit/examples/authorize.py
    • /usr/share/doc/python-authkit/examples/authorize2.py
    • /usr/share/doc/python-authkit/examples/config/digest.py
    • /usr/share/doc/python-authkit/examples/docs/basic.py
    • /usr/share/doc/python-authkit/examples/docs/digest.py
    • /usr/share/doc/python-authkit/examples/docs/form.py
    • /usr/share/doc/python-authkit/examples/docs/form2.py
    • /usr/share/doc/python-authkit/examples/docs/form_no_user_in_cookie.py
    • /usr/share/doc/python-authkit/examples/docs/forward.py
    • /usr/share/doc/python-authkit/examples/docs/multi.py
    • /usr/share/doc/python-authkit/examples/docs/multi2.py
    • /usr/share/doc/python-authkit/examples/docs/open_id.py
    • /usr/share/doc/python-authkit/examples/docs/open_id_sreg.py
    • /usr/share/doc/python-authkit/examples/docs/redirect.py
    • /usr/share/doc/python-authkit/examples/user/database/README.txt
    • /usr/share/doc/python-authkit/examples/user/database/app.py
    • /usr/share/doc/python-authkit/examples/user/database-model/README.txt
    • /usr/share/doc/python-authkit/examples/user/database-model/app.py
    • /usr/share/doc/python-authkit/examples/user/database-model/create.py
    • /usr/share/doc/python-authkit/examples/user/database-model/meta.py
    • /usr/share/doc/python-authkit/examples/user/database-model/model.py
    • /usr/share/lintian/overrides/python-authkit
    • /usr/share/pyshared/AuthKit-0.4.3.egg-info/PKG-INFO
    • /usr/share/pyshared/AuthKit-0.4.3.egg-info/SOURCES.txt
    • /usr/share/pyshared/AuthKit-0.4.3.egg-info/dependency_links.txt
    • /usr/share/pyshared/AuthKit-0.4.3.egg-info/entry_points.txt
    • /usr/share/pyshared/AuthKit-0.4.3.egg-info/not-zip-safe
    • /usr/share/pyshared/AuthKit-0.4.3.egg-info/requires.txt
    • /usr/share/pyshared/AuthKit-0.4.3.egg-info/top_level.txt
    • /usr/share/pyshared/authkit/__init__.py
    • /usr/share/pyshared/authkit/permissions.py
    • /usr/share/pyshared/authkit/pylons_adaptors.py
    • /usr/share/pyshared/authkit/authenticate/__init__.py
    • /usr/share/pyshared/authkit/authenticate/basic.py
    • /usr/share/pyshared/authkit/authenticate/cookie.py
    • /usr/share/pyshared/authkit/authenticate/digest.py
    • /usr/share/pyshared/authkit/authenticate/form.py
    • /usr/share/pyshared/authkit/authenticate/forward.py
    • /usr/share/pyshared/authkit/authenticate/multi.py
    • /usr/share/pyshared/authkit/authenticate/open_id.py
    • /usr/share/pyshared/authkit/authenticate/redirect.py
    • /usr/share/pyshared/authkit/authenticate/sso/__init__.py
    • /usr/share/pyshared/authkit/authenticate/sso/api.py
    • /usr/share/pyshared/authkit/authenticate/sso/cas.py
    • /usr/share/pyshared/authkit/authorize/__init__.py
    • /usr/share/pyshared/authkit/authorize/powerpack_adaptors.py
    • /usr/share/pyshared/authkit/authorize/pylons_adaptors.py
    • /usr/share/pyshared/authkit/authorize/wsgi_adaptors.py
    • /usr/share/pyshared/authkit/template/__init__.py
    • /usr/share/pyshared/authkit/template/authenticate/setup.cfg
    • /usr/share/pyshared/authkit/template/authenticate/setup.py_tmpl
    • /usr/share/pyshared/authkit/template/authenticate/+package+/__init__.py_tmpl
    • /usr/share/pyshared/authkit/template/authenticate/docs/license.txt_tmpl
    • /usr/share/pyshared/authkit/template/authenticate/ez_setup/README.txt
    • /usr/share/pyshared/authkit/template/authenticate/ez_setup/__init__.py
    • /usr/share/pyshared/authkit/users/__init__.py
    • /usr/share/pyshared/authkit/users/postgresql_driver.py
    • /usr/share/pyshared/authkit/users/sqlalchemy_04_driver.py
    • /usr/share/pyshared/authkit/users/sqlalchemy_driver/__init__.py
    • /usr/share/pyshared/authkit/users/sqlalchemy_driver/sqlalchemy_03.py
    • /usr/share/pyshared/authkit/users/sqlalchemy_driver/sqlalchemy_04.py
    • /usr/share/pyshared/authkit/users/sqlalchemy_driver/sqlalchemy_044.py
    • /usr/share/pyshared/authkit/users/sqlalchemy_driver/sqlalchemy_05.py

    Changelog

    2013-06-27 - Luca Falavigna <dktrkranz@debian.org> python-authkit (0.4.3-2) unstable; urgency=low * Team upload. [ Jakub Wilk ] * Use canonical URIs for Vcs-* fields. [ Luca Falavigna ] * Convert to dh_python2 (Closes: #616993).

    2009-01-02 - Debian Python Modules Team <python-modules-team@lists.alioth.debian.org> python-authkit (0.4.3-1) unstable; urgency=low [ Piotr O┼╝arowski ] * Vcs-Svn, Vcs-Browser and Homepage fields added * Add get-orig-source rule to debian/rules * Remove "Maintainer: " from Uploaders field * Typo fixed in long description * Update path in lintian-overrides/python-authkit * Add python-decorator and python-webob to Depends * Add python-mysqldb and python-sqlalchemy to Recommends [ Sandro Tosi ] * updated to new pypi simplier URL * debian/control - uniforming Vcs-Browser field * debian/control - switch Vcs-Browser field to viewsvn [ Jan Dittberner ] * new upstream version 0.4.3-1 * Patches to remove elementtree dependency - egginfo-elementtree.dpatch, - setuppy-elementtree.dpatch * Removed obsolete patches for python-openid version - egginfo-openid.dpatch - setuppy-openid.dpatch * Updated Standards-Version to 3.8.0 * Changed python-setuptools Build-Depends version to make lintian happy * add debian/README.source with dpatch instructions * add README.txt, docs and examples in debian/docs (Closes: #501054) * remove README.txt from dh_installdocs invocation and add excludes for pudge_template and syntax highlighting JavaScript * remove execute flag of example scripts

    2007-11-07 - Mikhail Gusarov <dottedmag@dottedmag.net> python-authkit (0.4.0~r139-0.1) unstable; urgency=low * NMU blessed by maintainer. * New upstream version (trunk, subverson revision 139) packaged. * python-openid 2.0 support: - python-yadis and python-urljr dependencies removed, both libraries are merged into new python-openid. - setuppy-openid.dpatch patch removed, no longer needed. - egginfo-openid.dpatch patch removed, no longer needed. - README.Debian removed as it contained only information about "python-openid <= 1.2" dependency in older authkit snapshots. * No longer manually move .egg-info directory: dh_pycentral does it automatically. * Homepage moved from description to debian/control field to make lintian happy.

    2007-07-17 - Christoph Haas <haas@debian.org> python-authkit (0.4.0~r95-1) unstable; urgency=low * New upstream version (trunk, subversion revision 95) packaged. Upstream version 0.3.0 is deprecated and the current trunk is suggested for use by the upstream developer.

    2007-04-20 - Christoph Haas <haas@debian.org> python-authkit (0.3.0pre5-4) unstable; urgency=low * Fixed debian/copyright to include the MIT license.

    2007-04-14 - Christoph Haas <haas@debian.org> python-authkit (0.3.0pre5-3) unstable; urgency=low * First upload to Debian unstable.

    2007-03-09 - Christoph Haas <haas@debian.org> python-authkit (0.3.0pre5-2) experimental; urgency=low * Removed debian/python-foo (accidentally got there when creating the package) * Dependency on shlibs removed

    2007-03-09 - Christoph Haas <haas@debian.org> python-authkit (0.3.0pre5-1) experimental; urgency=low * Initial release (Closes: #414182)

    Advertisement
    Advertisement