python-augeas_0.5.0-1_all.deb


Advertisement

Description

python-augeas - Python bindings for Augeas

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe amd64
Package name python-augeas
Package version 0.5.0
Package release 1
Package architecture all
Package type deb
Installed size 64 B
Download size 8.99 KB
Official Mirror archive.ubuntu.com
Augeas is a library and command line tool that focuses
on the most basic problem in handling Linux configurations
programmatically: editing actual configuration files in a
controlled manner.
This module provides a Python interface to the Augeas API.

Alternatives

Package Version Architecture Repository
python-augeas_0.5.0-1_all.deb 0.5.0 all Ubuntu Universe
python-augeas - - -

Requires

Name Value
libaugeas0 >= 0.7.2
python:any >= 2.7.5-5~
python:any << 2.8

Download

Type URL
Binary Package python-augeas_0.5.0-1_all.deb
Source Package python-augeas

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-augeas deb package:
    # sudo apt-get install python-augeas

Files

Path
/usr/lib/python2.7/dist-packages/augeas.py
/usr/lib/python2.7/dist-packages/python_augeas-0.5.0.egg-info
/usr/share/doc/python-augeas/README.txt
/usr/share/doc/python-augeas/changelog.Debian.gz
/usr/share/doc/python-augeas/copyright

Changelog

2015-07-05 - Federico Ceratto <federico@debian.org>
python-augeas (0.5.0-1) unstable; urgency=low
* New upstream release
* Enable Python3 build, switch to Pybuild (Closes: #777544)
* Switch to Debhelper 9
* Replace broken link with GitHub repo
* Bump Standards-Version to 3.9.6
* Set Vcs-Git and Vcs-Browser to canonical value
* Update copyright file format
2013-10-16 - Alessio Treglia <alessio@debian.org>
python-augeas (0.4.1-2) unstable; urgency=low
* collab-maint team upload.
* ACK NMU, thanks to Luca Falavigna for the good work. (Closes: #707895)
* Drop myself from the Uploaders field.
2013-05-12 - Luca Falavigna <dktrkranz@debian.org>
python-augeas (0.4.1-1.1) unstable; urgency=low
* Non-maintainer upload.
* Drop dependency on libpython2.6 (Closes: #707895).
2012-10-01 - Free Ekanayaka <freee@debian.org>
python-augeas (0.4.1-1) unstable; urgency=low
* New upstream release
* Depend on libpython2.6 and libpython2.7 (Closes: #654321)
2011-05-08 - Piotr Ożarowski <piotr@debian.org>
python-augeas (0.4.0-2.1) unstable; urgency=low
* Non-maintainer upload.
* Rebuild to add Python 2.7 support
2011-02-09 - Alessio Treglia <alessio@debian.org>
python-augeas (0.4.0-2) unstable; urgency=low
* Upload to unstable.
2011-01-12 - Alessio Treglia <alessio@debian.org>
python-augeas (0.4.0-1) experimental; urgency=low
* New upstream release.
* {Build-,}Depend on libaugeas0 >= 0.7.2.
* Build-depends on python-all (>= 2.6.5).
2010-08-19 - Alessio Treglia <alessio@debian.org>
python-augeas (0.3.0-2) unstable; urgency=low
* Add debian/gbp.conf file.
* Switch to format 3.0 (quilt).
* debian/control:
- Update my email address.
- Bump Standards.
- Add Vcs fields.
- Remove ${shlibs:Depends} macro.
* Use the form 'dh  --foo=bar' for compatibility with DH 8.
* Update debian/copyright file.
* Use XS-Python-Version field instead of debian/pyversions.
2009-12-11 - Alessio Treglia <quadrispro@ubuntu.com>
python-augeas (0.3.0-1) unstable; urgency=low
* New upstream release.
* Add myself to Uploaders field.
* Bump Standards up to 3.8.3.
* Switch to debhelper 7, drop cdbs.
* Bump debhelper to 7.3.7 due to the use of --buildsystem option.
2009-11-16 - Sandro Tosi <morph@debian.org>
python-augeas (0.2.0-1.1) unstable; urgency=low
* Non-maintainer upload.
* debian/control
- added libaugeas0 to Depends; thanks to Guido Günther for the report and to
Daniel Leidert for the patch; Closes: #504511
* Prepare for the upcoming Python 2.6 transition; thanks to Scott Kitterman
for the report; Closes: #552491
- debian/control
+ Build-depends on 'python (>= 2.5)' instead of python-dev (it's arch:all)
+ Depends on '${python:Depends}' instead of 'python (>= 2.5)'
+ drop 'python-ctypes' from Depends: it's py2.4 only (this pkg >= 2.5)
- debian/pyversions
+ allows Python from 2.5 onward

See Also

Package Description
python-authkit_0.4.3-2_all.deb authentication and authorisation framework for Python WSGI applications
python-authres_0.800-2build1_all.deb RFC 7001 Authentication Results Header manipulation for Python
python-autobahn_0.10.3+dfsg1-5_all.deb WebSocket client and server library, WAMP framework - Python 2.x
python-autopep8_0.9.1-2_all.deb tool that automatically formats Python code to conform to PEP 8
python-autopilot-tests_1.4.1+15.10.20150911-0ubuntu2_all.deb Tests for the autopilot functional test tool
python-autopilot-trace_1.4.1+15.10.20150911-0ubuntu2_amd64.deb Support for tracing in autopilot
python-autopilot-vis_1.4.1+15.10.20150911-0ubuntu2_all.deb The visualisation application for Autopilot
python-autopilot_1.4.1+15.10.20150911-0ubuntu2_all.deb Utility to write and run integration tests easily
python-avahi_0.6.32~rc+dfsg-1ubuntu2_amd64.deb Python utility package for Avahi
python-avc_0.8.3-1.1_all.deb live connection among widgets and application variables
python-avogadro_1.1.1-0ubuntu7_amd64.deb Molecular Graphics and Modelling System (Python module)
python-avro_1.8.0+dfsg-1_all.deb Apache Avro serialization system — Python 2 library
python-awsauth_0.1.5-1_all.deb AWS authentication for Amazon S3 for the python-requests module
python-axiom_0.7.5-1_all.deb Python object database
python-axolotl-curve25519_0.1-2build2_amd64.deb Python wrapper for curve25519 library with ed25519 signatures
Advertisement
Advertisement