python-argcomplete_0.8.1-1ubuntu2_all.deb


Advertisement

Description

python-argcomplete - bash tab completion for argparse

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe amd64
Package name python-argcomplete
Package version 0.8.1
Package release 1ubuntu2
Package architecture all
Package type deb
Installed size 96 B
Download size 21.45 KB
Official Mirror archive.ubuntu.com
Argcomplete provides easy, extensible command line tab completion of
arguments for your Python script.
It makes two assumptions:
* You're using bash as your shell
* You're using argparse to manage your command line arguments/options
Argcomplete is particularly useful if your program has lots of
options or subparsers, and if your program can dynamically suggest
completions for your argument/option values (for example, if the user
is browsing resources over the network).
This package provides the module for Python 2.x.

Alternatives

Package Version Architecture Repository
python-argcomplete_1.0.0-1~nd+1+nd16.04+1_all.deb 1.0.0 all NeuroDebian Main
python-argcomplete_1.0.0-1~nd+1+nd16.04+1_all.deb 1.0.0 all NeuroDebian Main
python-argcomplete_0.8.1-1ubuntu2_all.deb 0.8.1 all Ubuntu Universe
python-argcomplete - - -

Requires

Name Value
python:any >= 2.7.5-5~
python:any << 2.8

Download

Type URL
Binary Package python-argcomplete_0.8.1-1ubuntu2_all.deb
Source Package python-argcomplete

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-argcomplete deb package:
    # sudo apt-get install python-argcomplete

Files

Path
/usr/bin/activate-global-python-argcomplete
/usr/bin/python-argcomplete-check-easy-install-script
/usr/bin/register-python-argcomplete
/usr/lib/python2.7/dist-packages/argcomplete/__init__.py
/usr/lib/python2.7/dist-packages/argcomplete/completers.py
/usr/lib/python2.7/dist-packages/argcomplete/my_argparse.py
/usr/lib/python2.7/dist-packages/argcomplete/my_shlex.py
/usr/lib/python2.7/dist-packages/argcomplete-0.8.1.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/argcomplete-0.8.1.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/argcomplete-0.8.1.egg-info/not-zip-safe
/usr/lib/python2.7/dist-packages/argcomplete-0.8.1.egg-info/top_level.txt
/usr/lib/python2.7/dist-packages/argcomplete/bash_completion.d/python-argcomplete.sh
/usr/share/doc/python-argcomplete/changelog.Debian.gz
/usr/share/doc/python-argcomplete/copyright
/usr/share/man/man1/activate-global-python-argcomplete.1.gz
/usr/share/man/man1/python-argcomplete-check-easy-install-script.1.gz
/usr/share/man/man1/register-python-argcomplete.1.gz

Changelog

2016-02-10 - Didier Roche <didrocks@ubuntu.com>
python-argcomplete (0.8.1-1ubuntu2) xenial; urgency=medium
* Rebuild to ensure not picking python 3.4
2016-01-10 - Matthias Klose <doko@ubuntu.com>
python-argcomplete (0.8.1-1ubuntu1) xenial; urgency=medium
* Merge with Debian; remaining changes:
- Install python3 versions of the scripts.
2014-10-09 - Marco Nenciarini <mnencia@debian.org>
python-argcomplete (0.8.1-1) unstable; urgency=medium
[ Piotr O┼╝arowski ]
* New upstream release
- fixes install_requires (removes hadrcoded distribute; closes: #731825)
* Add python3-argcomplete binary package (closes: #731238)
* Switch dh build system to pybuild
2015-10-23 - Matthias Klose <doko@ubuntu.com>
python-argcomplete (0.8.1-0ubuntu2) xenial; urgency=medium
* No-change rebuild for python3 defaults change.
2014-07-31 - Didier Roche <didrocks@ubuntu.com>
python-argcomplete (0.8.1-0ubuntu1) utopic; urgency=medium
* New upstream release, adding python3 support
* Add python3 double build, package and install files
* Add python3 flavor of manpages and binary helpers
* Now generate helpers manpages during build directly and add man2help
dependency.
* Run the tests during build (python2 and 3). Skip one for now (already
skipped in python3) in debian/patches/skip-non-ascii-test.patch
2014-01-29 - Marco Nenciarini <mnencia@debian.org>
python-argcomplete (0.6.9-1) unstable; urgency=medium
* Imported Upstream version 0.6.9
* Bump standards-version to 3.9.5.0 (no changes)
2013-06-17 - Marco Nenciarini <mnencia@debian.org>
python-argcomplete (0.5.4-1) unstable; urgency=low
* Imported Upstream version 0.5.4
* Remove declare-argparse-dep patch (merged upstream)
* Canonicalize VCS-* field URI in debian/control
2013-01-09 - Marco Nenciarini <mnencia@debian.org>
python-argcomplete (0.3.3-1) unstable; urgency=low
* Initial release (Closes: #697608)

See Also

Package Description
python-argh_0.26.1-1_all.deb simple argparse wrapper (Python 2)
python-args_0.1.0-2_all.deb Command Arguments for Humans (Python 2)
python-argvalidate_0.9.0-2_all.deb simple argument validator library
python-ariapy_2.8.0+repack-1ubuntu2_amd64.deb C++ library for MobileRobots/ActivMedia robots (Python bindings)
python-arpy_1.1.1-2_all.deb library for accessing "ar" archives
python-arrow-doc_0.7.0-1_all.deb Python library to manipulate dates, times, timestamps: documentation
python-arrow_0.7.0-1_all.deb Python library to manipulate dates, times, and timestamps
python-ase-doc_3.9.1.4567-3_all.deb Atomic Simulation Environment (common documentation)
python-ase_3.9.1.4567-3_all.deb Atomic Simulation Environment (Python 2)
python-asterisk_0.5.3-1.1_all.deb Asterisk Manager API interface module for Python
python-astlib_0.8.0-3build1_amd64.deb General Python tools for astronomy
python-astor_0.5-1_all.deb Python AST manipulator
python-astroid_1.4.4-1_all.deb rebuild a new abstract syntax tree from Python's AST
python-astrometry_0.67+dfsg-1_amd64.deb Astrometry plate solver (Python package)
python-astroml-addons_0.2.2-1_amd64.deb Python Machine Learning library for astronomy (performance addons)
Advertisement
Advertisement