python-apsw_3.8.11.1-r1-1build1_amd64.deb


Advertisement

Description

python-apsw - another Python SQLite 3 wrapper

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: python-apsw
Package version: 3.8.11.1
Package release: r1-1build1
Package architecture: amd64
Package type: deb
Installed size: 347 B
Download size: 98.28 KB
Official Mirror: archive.ubuntu.com
APSW (Another Python SQLite Wrapper) is an SQLite 3 wrapper that provides the thinnest layer over SQLite 3 possible. Everything you can do from the C API to SQLite 3, you can do from Python. Although APSW's API looks vaguely similar to Python's DB-API, it is not compliant with that API and instead works the way SQLite 3 does.

Alternatives

Conflicts

  • python2.3-apsw
  • python2.4-apsw

Replaces

  • python2.3-apsw
  • python2.4-apsw

    Download

    Source package: python-apsw

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-apsw deb package:
      # sudo apt-get install python-apsw

    Files

    • /usr/lib/python2.7/dist-packages/apsw-3.8.11.1_r1.egg-info
    • /usr/lib/python2.7/dist-packages/apsw.x86_64-linux-gnu.so
    • /usr/share/doc/python-apsw/NEWS.Debian.gz
    • /usr/share/doc/python-apsw/changelog.Debian.gz
    • /usr/share/doc/python-apsw/copyright

    Changelog

    2016-01-18 - Matthias Klose <doko@ubuntu.com> python-apsw (3.8.11.1-r1-1build1) xenial; urgency=medium * No-change rebuild to drop python3.4 support.

    2015-09-17 - Joel Rosdahl <joel@debian.org> python-apsw (3.8.11.1-r1-1) unstable; urgency=medium [ Joel Rosdahl ] * New upstream version * Use debhelper compat level 9 * Update debian/watch to new upstream location [ Scott Kitterman ] * Move dh_python2/3 calls to after dh_install so dependency generation works (thanks to Piotr Ożarowski for figuring this part out) (closes: #799272) * Correct python:Depends to be python3:Depends so proper dependencies are generated for python3-apsw * Add build-depends on dh-python so current code base is used * Remove obsolete provides

    2015-06-21 - Joel Rosdahl <joel@debian.org> python-apsw (3.8.10.1-r1-1) unstable; urgency=medium * New upstream release 3.8.10.1-r1 * Require libsqlite3-dev >= 3.8.10 * Bumped Standards-Version to 3.9.6 (no changes)

    2014-09-08 - Joel Rosdahl <joel@debian.org> python-apsw (3.8.6-r1-1) unstable; urgency=medium * New upstream release 3.8.6-r1 * Require libsqlite3-dev >= 3.8.6

    2014-07-10 - Joel Rosdahl <joel@debian.org> python-apsw (3.8.5-r1-1) unstable; urgency=medium * New upstream release 3.8.5-r1 * Require libsqlite3-dev >= 3.8.5

    2014-02-07 - Joel Rosdahl <joel@debian.org> python-apsw (3.8.2-r1-2) unstable; urgency=medium * New upstream URL and license text * Handle /usr/share/doc/python-apsw-doc symlink upgrade (closes: #736303) * Move python3 debug extensions into python3-apsw-dbg (closes: #736775) * Remove Google Analytics footer * Build-depend on libsqlite3-dev 3.8.2

    2013-12-11 - Joel Rosdahl <joel@debian.org> python-apsw (3.8.2-r1-1) unstable; urgency=low * New upstream release 3.8.2-r1.

    2013-12-08 - Joel Rosdahl <joel@debian.org> python-apsw (3.8.1-r1-1) unstable; urgency=low * New upstream release 3.8.1-r1. * Bump Standards-Version to 3.9.5

    2013-06-18 - Joel Rosdahl <joel@debian.org> python-apsw (3.7.17-r1-1) unstable; urgency=low [Joel Rosdahl] * New upstream release 3.7.17-r1. [ Nikolaus Rath ] * Also build Python 3 package (closes: #706992) * Tighten build depends on libsqlite3-dev (closes: #710049)

    2013-03-31 - Joel Rosdahl <joel@debian.org> python-apsw (3.7.16.1-r1-1) unstable; urgency=low * New upstream release 3.7.16.1-r1

    Advertisement
    Advertisement