python-apipkg_1.0-1.1build1_all.deb


Advertisement

Description

python-apipkg - namespace control and lazy-import mechanism for Python

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: python-apipkg
Package version: 1.0
Package release: 1.1build1
Package architecture: all
Package type: deb
Installed size: 54 B
Download size: 6.47 KB
Official Mirror: archive.ubuntu.com
With apipkg you can control the exported namespace of a Python package and greatly reduce the number of imports for your users. It is a small pure Python module that works on virtually all Python versions, including CPython2.3 to Python3.1, Jython and PyPy. It co-operates well with Python's help() system, custom importers (PEP302) and common command line completion tools.

Alternatives

Provides

  • python2.7-apipkg

    Download

    Source package: apipkg

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-apipkg deb package:
      # sudo apt-get install python-apipkg

    Files

    • /usr/lib/python2.7/dist-packages/apipkg-1.0.egg-info
    • /usr/lib/python2.7/dist-packages/apipkg.py
    • /usr/share/doc/python-apipkg/README.txt
    • /usr/share/doc/python-apipkg/changelog.Debian.gz
    • /usr/share/doc/python-apipkg/copyright
    • /usr/share/pyshared/apipkg-1.0.egg-info
    • /usr/share/pyshared/apipkg.py

    Changelog

    2011-12-31 - Matthias Klose <doko@ubuntu.com> apipkg (1.0-1.1build1) precise; urgency=low * Rebuild to drop python2.6 dependencies.

    2011-04-16 - Piotr O┼╝arowski <piotr@debian.org> apipkg (1.0-1.1) unstable; urgency=low * Non-maintainer upload (just a rebuild to add Python 2.7 and dropPython 2.5 support)

    2011-02-26 - Adam Schmalhofer <Adam.Schmalhofer@gmx.de> apipkg (1.0-1) unstable; urgency=low * Imported Upstream version 1.0 * python-support => dh_python2 * Bumped Standards-Version

    2010-09-29 - Adam Schmalhofer <Adam.Schmalhofer@gmx.de> apipkg (1.0~b6-5) unstable; urgency=low * Rebuilt with now current Python versions (Closes: #597924)

    2010-02-07 - Adam Schmalhofer <Adam.Schmalhofer@gmx.de> apipkg (1.0~b6-4) unstable; urgency=low * Include README.txt

    2010-02-07 - Adam Schmalhofer <Adam.Schmalhofer@gmx.de> apipkg (1.0~b6-3) unstable; urgency=low * Standards-Version bumped to 3.8.4

    2010-01-27 - Adam Schmalhofer <Adam.Schmalhofer@gmx.de> apipkg (1.0~b6-2) unstable; urgency=low * Added proper debian/copyright - thanks to Chris Lamb * s/python/Python in package description - thanks to Chris Lamb

    2010-01-25 - Adam Schmalhofer <Adam.Schmalhofer@gmx.de> apipkg (1.0~b6-1) unstable; urgency=low * Initial release (Closes: #566854)

    Advertisement
    Advertisement