python-adodb_2.10-2_all.deb


Advertisement

Description

python-adodb - A database abstraction library for python

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: python-adodb
Package version: 2.10
Package release: 2
Package architecture: all
Package type: deb
Installed size: 104 B
Download size: 20.22 KB
Official Mirror: archive.ubuntu.com
ADOdb is a database abstraction library (modelled on Microsoft's database API's). ADOdb was originally developed for PHP, and ported to Python. The Python version implements a subset of the PHP version.

Alternatives

    Download

    Source package: python-adodb

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-adodb deb package:
      # sudo apt-get install python-adodb

    Files

    • /usr/lib/python2.7/dist-packages/adodb-2.10.egg-info
    • /usr/lib/python2.7/dist-packages/adodb/__init__.py
    • /usr/lib/python2.7/dist-packages/adodb/adodb.py
    • /usr/lib/python2.7/dist-packages/adodb/adodb_access.py
    • /usr/lib/python2.7/dist-packages/adodb/adodb_mssql.py
    • /usr/lib/python2.7/dist-packages/adodb/adodb_mxodbc.py
    • /usr/lib/python2.7/dist-packages/adodb/adodb_mxoracle.py
    • /usr/lib/python2.7/dist-packages/adodb/adodb_mysql.py
    • /usr/lib/python2.7/dist-packages/adodb/adodb_oci8.py
    • /usr/lib/python2.7/dist-packages/adodb/adodb_odbc.py
    • /usr/lib/python2.7/dist-packages/adodb/adodb_odbc_mssql.py
    • /usr/lib/python2.7/dist-packages/adodb/adodb_postgres.py
    • /usr/lib/python2.7/dist-packages/adodb/adodb_pyodbc.py
    • /usr/lib/python2.7/dist-packages/adodb/adodb_sqlite.py
    • /usr/lib/python2.7/dist-packages/adodb/adodb_vfp.py
    • /usr/share/doc/python-adodb/adodb-py-docs.htm
    • /usr/share/doc/python-adodb/changelog.Debian.gz
    • /usr/share/doc/python-adodb/copyright

    Changelog

    2015-08-26 - Stefano Rivera <stefanor@debian.org> python-adodb (2.10-2) unstable; urgency=medium * QA Upload (Orphaned in #792393) + Unset maintainer and uploaders. * Replace python-support with dh_python2. (Closes: #785976) + Replace debian/pyversions with X-Python-Versions. + B-D on dh-python. + Drop unnecessary use of ${python:Provides} * Drop ancient Conflicts/Replaces, not necessary for several releases. * Switch to minimal dh (and compat 9). * Bump Standards-Version to 3.9.6, no other changes needed. * Source format 3.0 (quilt)

    2012-08-22 - gregor herrmann <gregoa@debian.org> python-adodb (2.10-1.1) unstable; urgency=low * Non-maintainer upload. * Fix "broken binary-indep target": fix binary-arch / binary-indep targets in debian/rules; patch from Evgeni Golov, thanks. (Closes: #684024) * Fix python-support handling in debian/rules in order not to install python-bytecode (ftp-master auto-reject reason); patch from Jakub Wilk, thanks.

    2008-07-30 - David Gil <dgil@telefonica.net> python-adodb (2.10-1) unstable; urgency=low * New upstream release: + Added support for pyodbc odbc extension. Switched from mxodbc to using pyodbc for vfp, access and mssql drivers + Added minimal support for MetaColumns in odbc drivers * Rename source package from adodb to python-adodb * debian/control: Updated python-support build-depend version to >= 0.6 * Bump Standards-Version to 3.8.0: + debian/control: Added Homepage field * debian/{rules,compat}: Removed DH_COMPAT environment variable in debian/rules, created a debian/compat file instead

    2007-05-21 - David Gil <dgil@telefonica.net> python-adodb (2.02b-1) unstable; urgency=low * New upstream release: + Fixes a bug in 2.02. Close() did not release db connection properly (Closes: #425372)

    2007-05-21 - David Gil <dgil@telefonica.net> python-adodb (2.01-3) unstable; urgency=low * debian/control: Updated dependencies for debhelper and python-support * debian/rules: Removed use of dh_python and pycompat

    2006-06-29 - David Gil <dgil@telefonica.net> python-adodb (2.01-2) unstable; urgency=low * Convert the package to use the new python policy (Closes: #373519) * Really use python-pysqlite2 in Recommends: field (Closes: #363907) * Add extra space before Homepage at package description * Removed debian/TODO file

    2006-05-11 - David Gil <dgil@telefonica.net> python-adodb (2.01-1) unstable; urgency=low * New upstream release. * Replaced python-sqlite with python-pysqlite2 in dependencies (Closes: #363907) * Bump Standards-Version to 3.7.2 (no policy-related changes needed).

    2006-02-01 - David Gil <dgil@telefonica.net> python-adodb (2.00-1) unstable; urgency=low * New upstream release + Added sqlite support debian/control: added python-sqlite to Recommends: field + Improved installation with setup.py README.Debian: dropped, not needed due to upstream changes * Use debhelper compat level 5 and update build-dependencies accordingly

    2005-08-08 - David Gil <dgil@telefonica.net> python-adodb (1.13-4) unstable; urgency=low * debian/control: Use Build-Depends instead of Build-Depends-Indep. The package uses dh_clean in the "clean" target of debian/rules, so it needs debhelper in Build-Depends: field. (Thanks to Joerg Jaspert for the notice).

    2005-07-21 - David Gil <dgil@telefonica.net> python-adodb (1.13-3) unstable; urgency=low * debian/control: No architecture-dependent packages are built, so used Build-Depends-Indep instead of Build-Depends. (fixed lintian's build-depends-without-arch-dep report). * Changed my email address.

    Advertisement
    Advertisement