python-adios_1.9.0-7build2_amd64.deb


Advertisement

Description

python-adios - Python interface to the ADIOS IO system

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: python-adios
Package version: 1.9.0
Package release: 7build2
Package architecture: amd64
Package type: deb
Installed size: 1.62 KB
Download size: 395.50 KB
Official Mirror: archive.ubuntu.com
This is a Python2 interface to ADIOS. The Adaptable IO System (ADIOS) provides a simple, flexible way for scientists to describe the data in their code that may need to be written, read, or processed outside of the running simulation. By providing an external to the code XML file describing the various elements, their types, and how you wish to process them this run, the routines in the host code (either Fortran or C) can transparently change how they process the data.

Alternatives

Provides

  • python2.7-adios

Replaces

  • libadios-bin << 1.8.0-2
  • libadios-dev << 1.8.0-2

    Download

    Source package: adios

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-adios deb package:
      # sudo apt-get install python-adios

    Files

    • /usr/lib/python2.7/dist-packages/adios.x86_64-linux-gnu.so
    • /usr/lib/python2.7/dist-packages/adios_mpi.x86_64-linux-gnu.so
    • /usr/share/doc/python-adios/changelog.Debian.gz
    • /usr/share/doc/python-adios/copyright

    Changelog

    2016-02-15 - Matthias Klose <doko@ubuntu.com> adios (1.9.0-7build2) xenial; urgency=medium * No change-rebuild for openmpi on s390x.

    2016-02-07 - Matthias Klose <doko@ubuntu.com> adios (1.9.0-7build1) xenial; urgency=medium * No-change rebuild for ncurses6 transition.

    2016-02-04 - Alastair McKinstry <mckinstry@debian.org> adios (1.9.0-7) unstable; urgency=medium * Fix for openmpi1.10 transition. Closes: #813724. * Move to Standards-Version: 3.9.7 * Add lintian overrides for false-alerts on tmpl scripts

    2016-01-01 - Alastair McKinstry <mckinstry@debian.org> adios (1.9.0-6) unstable; urgency=medium * Don't include '-lcr' on x32, 68k either. * Use mpif90 instead of mpif77 for MPIFC. (Fix FTBFS on sparc)

    2015-11-04 - Alastair McKinstry <mckinstry@debian.org> adios (1.9.0-5) unstable; urgency=medium * Fix typo in build rules for s390x. * Don't include '-lcr' for MPI builds on hppa

    2015-11-01 - Alastair McKinstry <mckinstry@debian.org> adios (1.9.0-4) unstable; urgency=medium * Fix MPI_LIBS for s390x build

    2015-10-29 - Alastair McKinstry <mckinstry@debian.org> adios (1.9.0-3) unstable; urgency=medium * Remove mpi-workaround.patch, breaks build on non-mpich archs

    2015-10-29 - Alastair McKinstry <mckinstry@debian.org> adios (1.9.0-2) unstable; urgency=medium * Build against all mpi versions again. * Link adios_mpi.so python packages against mpi libs * delete old binaries from examples

    2015-10-27 - Alastair McKinstry <mckinstry@debian.org> adios (1.9.0-1) experimental; urgency=medium * New upstream release * Changes needed for python3 - adapt pyx scripts * Temporarily only build for mpich as bug in openmpi * Re-enable tests on bigendian systems for checking * Add patch to fix version number.

    2015-07-31 - Alastair McKinstry <mckinstry@debian.org> adios (1.8.0-5) unstable; urgency=medium * Stay on netcdf-dev only in unstable before netcdf-fortran transition. Closes: #790230.

    Advertisement
    Advertisement