pyqt4.qsci-dev_2.9.1+dfsg-4build1_all.deb


Advertisement

Description

pyqt4.qsci-dev - Development files for Python Qscintilla2 (Qt4)

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe amd64
Package name pyqt4.qsci-dev
Package version 2.9.1+dfsg
Package release 4build1
Package architecture all
Package type deb
Installed size 216 B
Download size 23.86 KB
Official Mirror archive.ubuntu.com
This package contains the source SIP files from which the Python bindings for
Qscintilla2 (Qt4) are created. They are needed for building PyQt4 bindindgs
for Qscintilla2 as well as creating bindings for own widgets written in C++.

Alternatives

Package Version Architecture Repository
pyqt4.qsci-dev_2.9.2+dfsg-3build1~~xenialoverlay1~1_all.deb 2.9.2+dfsg all Kubuntu Backports
pyqt4.qsci-dev_2.9.2+dfsg-3build1~~xenialoverlay1~1_all.deb 2.9.2+dfsg all Kubuntu Backports
pyqt4.qsci-dev_2.9.1+dfsg-4build1_all.deb 2.9.1+dfsg all Ubuntu Universe
pyqt4.qsci-dev - - -

Requires

Name Value
python-qt4-dev -
python-sip-dev -

Download

Type URL
Binary Package pyqt4.qsci-dev_2.9.1+dfsg-4build1_all.deb
Source Package qscintilla2

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install pyqt4.qsci-dev deb package:
    # sudo apt-get install pyqt4.qsci-dev

Files

Path
/usr/share/doc/pyqt4.qsci-dev/changelog.Debian.gz
/usr/share/doc/pyqt4.qsci-dev/copyright
/usr/share/sip/PyQt4/Qsci/qsciabstractapis.sip
/usr/share/sip/PyQt4/Qsci/qsciapis.sip
/usr/share/sip/PyQt4/Qsci/qscicommand.sip
/usr/share/sip/PyQt4/Qsci/qscicommandset.sip
/usr/share/sip/PyQt4/Qsci/qscidocument.sip
/usr/share/sip/PyQt4/Qsci/qscilexer.sip
/usr/share/sip/PyQt4/Qsci/qscilexeravs.sip
/usr/share/sip/PyQt4/Qsci/qscilexerbash.sip
/usr/share/sip/PyQt4/Qsci/qscilexerbatch.sip
/usr/share/sip/PyQt4/Qsci/qscilexercmake.sip
/usr/share/sip/PyQt4/Qsci/qscilexercoffeescript.sip
/usr/share/sip/PyQt4/Qsci/qscilexercpp.sip
/usr/share/sip/PyQt4/Qsci/qscilexercsharp.sip
/usr/share/sip/PyQt4/Qsci/qscilexercss.sip
/usr/share/sip/PyQt4/Qsci/qscilexercustom.sip
/usr/share/sip/PyQt4/Qsci/qscilexerd.sip
/usr/share/sip/PyQt4/Qsci/qscilexerdiff.sip
/usr/share/sip/PyQt4/Qsci/qscilexerfortran.sip
/usr/share/sip/PyQt4/Qsci/qscilexerfortran77.sip
/usr/share/sip/PyQt4/Qsci/qscilexerhtml.sip
/usr/share/sip/PyQt4/Qsci/qscilexeridl.sip
/usr/share/sip/PyQt4/Qsci/qscilexerjava.sip
/usr/share/sip/PyQt4/Qsci/qscilexerjavascript.sip
/usr/share/sip/PyQt4/Qsci/qscilexerlua.sip
/usr/share/sip/PyQt4/Qsci/qscilexermakefile.sip
/usr/share/sip/PyQt4/Qsci/qscilexermatlab.sip
/usr/share/sip/PyQt4/Qsci/qscilexeroctave.sip
/usr/share/sip/PyQt4/Qsci/qscilexerpascal.sip
/usr/share/sip/PyQt4/Qsci/qscilexerperl.sip
/usr/share/sip/PyQt4/Qsci/qscilexerpo.sip
/usr/share/sip/PyQt4/Qsci/qscilexerpostscript.sip
/usr/share/sip/PyQt4/Qsci/qscilexerpov.sip
/usr/share/sip/PyQt4/Qsci/qscilexerproperties.sip
/usr/share/sip/PyQt4/Qsci/qscilexerpython.sip
/usr/share/sip/PyQt4/Qsci/qscilexerruby.sip
/usr/share/sip/PyQt4/Qsci/qscilexerspice.sip
/usr/share/sip/PyQt4/Qsci/qscilexersql.sip
/usr/share/sip/PyQt4/Qsci/qscilexertcl.sip
/usr/share/sip/PyQt4/Qsci/qscilexertex.sip
/usr/share/sip/PyQt4/Qsci/qscilexerverilog.sip
/usr/share/sip/PyQt4/Qsci/qscilexervhdl.sip
/usr/share/sip/PyQt4/Qsci/qscilexerxml.sip
/usr/share/sip/PyQt4/Qsci/qscilexeryaml.sip
/usr/share/sip/PyQt4/Qsci/qscimacro.sip
/usr/share/sip/PyQt4/Qsci/qscimod4.sip
/usr/share/sip/PyQt4/Qsci/qscimod5.sip
/usr/share/sip/PyQt4/Qsci/qscimodcommon.sip
/usr/share/sip/PyQt4/Qsci/qsciprinter.sip
/usr/share/sip/PyQt4/Qsci/qsciscintilla.sip
/usr/share/sip/PyQt4/Qsci/qsciscintillabase.sip
/usr/share/sip/PyQt4/Qsci/qscistyle.sip
/usr/share/sip/PyQt4/Qsci/qscistyledtext.sip

Changelog

2016-01-19 - Matthias Klose <doko@ubuntu.com>
qscintilla2 (2.9.1+dfsg-4build1) xenial; urgency=medium
* No-change rebuild to drop python3.4 support.
2016-01-10 - Scott Kitterman <scott@kitterman.com>
qscintilla2 (2.9.1+dfsg-4) unstable; urgency=medium
* Add new binary packages python-pyqt5.qsci and python-pyqt5.qsci-dbg so
QScintilla2 can be used with Python (2) and Qt5 to enable QGIS to be
updated to Qt5
- Add new packages to debian/control
- Add python-pyqt5 and python-pyqt5-dbg to build-depends
- Update debian/rules to do Qt5 builds for both python and python3
- Add debian/python-pyqt5.qsci.install
2015-10-30 - Scott Kitterman <scott@kitterman.com>
qscintilla2 (2.9.1+dfsg-3) unstable; urgency=medium
* rm the mkspecs dir from libqt5scintilla2-12v5 in debian/rules so the prf
file doesn't end up installed in two packages
* Version libqt5scintilla2-dev Breaks/Replaces on libqt5scintilla2-12v5
to make fixed packages installable
2015-10-29 - Scott Kitterman <scott@kitterman.com>
qscintilla2 (2.9.1+dfsg-2) unstable; urgency=medium
* Update symbols files from buildlogs
* Disable dpkg-gensymbols check level set to 0
* Add libqt5scintilla2-dev Breaks/Replaces libqt5scintilla2-12v5 due to
qscintilla2.prf moving between the packages (Closes: #803419)
2015-10-29 - Scott Kitterman <scott@kitterman.com>
qscintilla2 (2.9.1+dfsg-1) unstable; urgency=medium
[ Scott Kitterman ]
* New upstream release (Closes: #803142)
* Update debian/rules to account for Qt5 prf file being installed in usr/lib
instead of usr/share by the upstream build system
* Temporarily set dpkg-gensymbols check level to 0 to ensure we
capture symbols changes for all libs
[ SVN-Git Migration ]
* Migrate packaging to git with git-dpm
[ Michael Cree ]
* Update symbols files for Alpha
2015-09-28 - Scott Kitterman <scott@kitterman.com>
qscintilla2 (2.9+dfsg-9) unstable; urgency=medium
* Update symbols files from buildlogs
2015-08-16 - Scott Kitterman <scott@kitterman.com>
qscintilla2 (2.9+dfsg-8) unstable; urgency=medium
* Upload to unstable
* Update libqt5scintilla2 symbols file for hurd-i386 from build-logs
2015-08-14 - Scott Kitterman <scott@kitterman.com>
qscintilla2 (2.9+dfsg-7) experimental; urgency=medium
* Update symbols files from build logs
* Revert DPKG_GENSYMBOLS_CHECK_LEVEL=0
2015-08-11 - Scott Kitterman <scott@kitterman.com>
qscintilla2 (2.9+dfsg-6) experimental; urgency=medium
* Update for g++5 transition (See #791257)
- Bump library packages to libq{t5}scintilla2-12v5 for transition
- Update debian/control, including conflicts/replaces for previous libs
* Temporarily export DPKG_GENSYMBOLS_CHECK_LEVEL=0 to collect symbols file
changes for both libraries
* cp instead of mv QScintilla2.api in debian/rules so build can be re-run
after a failure for testing
* Drop -dbg tests from autopkgtests for now since that part of the test
fails and such falures will mask failures due to sip issues, which is the
main value of the test
2015-06-29 - Scott Kitterman <scott@kitterman.com>
qscintilla2 (2.9+dfsg-5) unstable; urgency=medium
* Update symbols files from buildd build logs and try again
(Closes: #790420)
* Update libqt5scintilla2-l10n Suggests to libqt5scintilla2-12

See Also

Package Description
pyqt5-dev-tools_5.5.1+dfsg-3ubuntu4_amd64.deb Development tools for PyQt5
pyqt5-dev_5.5.1+dfsg-3ubuntu4_all.deb Development files for PyQt5
pyqt5-doc_5.5.1+dfsg-3ubuntu4_all.deb Documentation for PyQt5
pyqt5-examples_5.5.1+dfsg-3ubuntu4_all.deb Examples and demos for PyQt5
pyqt5.qsci-dev_2.9.1+dfsg-4build1_all.deb Development files for Python Qscintilla2 (Qt5)
pyracerz_0.2-8_all.deb multiplayer top view 2D racing game
pyragua_0.2.5-6_all.deb Very lightweight Python editor
pyrenamer_0.6.0-1.2_all.deb mass file renamer written in PyGTK
pyrex-mode_0.9.8.5-2.1ubuntu1_all.deb emacs-lisp pyrex-mode for pyrex
pyrit-opencl_0.4.0-1_amd64.deb OpenCL extension module for Pyrit
pyrit_0.4.0-5_amd64.deb GPGPU-driven WPA/WPA2-PSK key cracker
pyrite-publisher_2.1.1-11_amd64.deb Convert html and text documents to palm DOC format
pyro-doc_3.14-4_all.deb documentation for Pyro
pyro-examples_3.14-4_all.deb examples for Pyro
pyro-gui_3.14-4_all.deb graphical tool for Pyro
Advertisement
Advertisement