pyqi_0.3.2+dfsg-1_all.deb


Advertisement

Description

pyqi - Python framework for wrapping general commands in multiple interfaces

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe amd64
Package name pyqi
Package version 0.3.2+dfsg
Package release 1
Package architecture all
Package type deb
Installed size 464 B
Download size 67.64 KB
Official Mirror archive.ubuntu.com
pyqi (canonically pronounced pie chee) is a Python framework designed to
support wrapping general commands in multiple types of interfaces, including
at the command line, HTML, and API levels.

Alternatives

Package Version Architecture Repository
pyqi_0.3.2+dfsg-1_all.deb 0.3.2+dfsg all Ubuntu Universe
pyqi - - -

Requires

Name Value
python << 2.8
python >= 2.7
sphinx-common >= 1.2.2+dfsg

Download

Type URL
Binary Package pyqi_0.3.2+dfsg-1_all.deb
Source Package pyqi

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install pyqi deb package:
    # sudo apt-get install pyqi

Files

Path
/usr/bin/pyqi
/usr/lib/python2.7/dist-packages/pyqi/__init__.py
/usr/lib/python2.7/dist-packages/pyqi/functional.py
/usr/lib/python2.7/dist-packages/pyqi/util.py
/usr/lib/python2.7/dist-packages/pyqi-0.3.2.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/pyqi-0.3.2.egg-info/SOURCES.txt
/usr/lib/python2.7/dist-packages/pyqi-0.3.2.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/pyqi-0.3.2.egg-info/requires.txt
/usr/lib/python2.7/dist-packages/pyqi-0.3.2.egg-info/top_level.txt
/usr/lib/python2.7/dist-packages/pyqi/commands/__init__.py
/usr/lib/python2.7/dist-packages/pyqi/commands/code_header_generator.py
/usr/lib/python2.7/dist-packages/pyqi/commands/make_bash_completion.py
/usr/lib/python2.7/dist-packages/pyqi/commands/make_command.py
/usr/lib/python2.7/dist-packages/pyqi/commands/make_optparse.py
/usr/lib/python2.7/dist-packages/pyqi/commands/make_release.py
/usr/lib/python2.7/dist-packages/pyqi/commands/serve_html_interface.py
/usr/lib/python2.7/dist-packages/pyqi/core/__init__.py
/usr/lib/python2.7/dist-packages/pyqi/core/command.py
/usr/lib/python2.7/dist-packages/pyqi/core/container.py
/usr/lib/python2.7/dist-packages/pyqi/core/exception.py
/usr/lib/python2.7/dist-packages/pyqi/core/factory.py
/usr/lib/python2.7/dist-packages/pyqi/core/interface.py
/usr/lib/python2.7/dist-packages/pyqi/core/log.py
/usr/lib/python2.7/dist-packages/pyqi/core/parallel.py
/usr/lib/python2.7/dist-packages/pyqi/core/interfaces/__init__.py
/usr/lib/python2.7/dist-packages/pyqi/core/interfaces/html/__init__.py
/usr/lib/python2.7/dist-packages/pyqi/core/interfaces/html/input_handler.py
/usr/lib/python2.7/dist-packages/pyqi/core/interfaces/html/output_handler.py
/usr/lib/python2.7/dist-packages/pyqi/core/interfaces/optparse/__init__.py
/usr/lib/python2.7/dist-packages/pyqi/core/interfaces/optparse/input_handler.py
/usr/lib/python2.7/dist-packages/pyqi/core/interfaces/optparse/output_handler.py
/usr/lib/python2.7/dist-packages/pyqi/interfaces/__init__.py
/usr/lib/python2.7/dist-packages/pyqi/interfaces/html/__init__.py
/usr/lib/python2.7/dist-packages/pyqi/interfaces/html/config/__init__.py
/usr/lib/python2.7/dist-packages/pyqi/interfaces/html/config/make_bash_completion.py
/usr/lib/python2.7/dist-packages/pyqi/interfaces/html/config/make_command.py
/usr/lib/python2.7/dist-packages/pyqi/interfaces/html/config/make_optparse.py
/usr/lib/python2.7/dist-packages/pyqi/interfaces/optparse/__init__.py
/usr/lib/python2.7/dist-packages/pyqi/interfaces/optparse/input_handler.py
/usr/lib/python2.7/dist-packages/pyqi/interfaces/optparse/output_handler.py
/usr/lib/python2.7/dist-packages/pyqi/interfaces/optparse/config/__init__.py
/usr/lib/python2.7/dist-packages/pyqi/interfaces/optparse/config/make_bash_completion.py
/usr/lib/python2.7/dist-packages/pyqi/interfaces/optparse/config/make_command.py
/usr/lib/python2.7/dist-packages/pyqi/interfaces/optparse/config/make_optparse.py
/usr/lib/python2.7/dist-packages/pyqi/interfaces/optparse/config/make_release.py
/usr/lib/python2.7/dist-packages/pyqi/interfaces/optparse/config/serve_html_interface.py
/usr/share/doc-base/pyqi
/usr/share/doc/pyqi/changelog.Debian.gz
/usr/share/doc/pyqi/copyright
/usr/share/doc/pyqi/html/index.html
/usr/share/doc/pyqi/html/pyqidoc.hhc
/usr/share/doc/pyqi/html/pyqidoc.hhk
/usr/share/doc/pyqi/html/pyqidoc.hhp
/usr/share/doc/pyqi/html/pyqidoc.stp
/usr/share/doc/pyqi/html/_static/ajax-loader.gif
/usr/share/doc/pyqi/html/_static/alert_info_32.png
/usr/share/doc/pyqi/html/_static/alert_warning_32.png
/usr/share/doc/pyqi/html/_static/basic.css
/usr/share/doc/pyqi/html/_static/bg-page.png
/usr/share/doc/pyqi/html/_static/bullet_orange.png
/usr/share/doc/pyqi/html/_static/comment-bright.png
/usr/share/doc/pyqi/html/_static/comment-close.png
/usr/share/doc/pyqi/html/_static/comment.png
/usr/share/doc/pyqi/html/_static/doctools.js
/usr/share/doc/pyqi/html/_static/down-pressed.png
/usr/share/doc/pyqi/html/_static/down.png
/usr/share/doc/pyqi/html/_static/file.png
/usr/share/doc/pyqi/html/_static/haiku.css
/usr/share/doc/pyqi/html/_static/jquery.js
/usr/share/doc/pyqi/html/_static/minus.png
/usr/share/doc/pyqi/html/_static/plus.png
/usr/share/doc/pyqi/html/_static/pygments.css
/usr/share/doc/pyqi/html/_static/searchtools.js
/usr/share/doc/pyqi/html/_static/underscore.js
/usr/share/doc/pyqi/html/_static/up-pressed.png
/usr/share/doc/pyqi/html/_static/up.png
/usr/share/doc/pyqi/html/_static/websupport.js
/usr/share/doc/pyqi/html/guidelines/index.html
/usr/share/doc/pyqi/html/guidelines/optparse.html
/usr/share/doc/pyqi/html/install/index.html
/usr/share/doc/pyqi/html/tutorials/defining_new_commands.html
/usr/share/doc/pyqi/html/tutorials/defining_new_interfaces.html
/usr/share/doc/pyqi/html/tutorials/defining_your_command_driver.html
/usr/share/doc/pyqi/html/tutorials/index.html
/usr/share/doc/pyqi/html/tutorials/organizing_your_repository.html
/usr/share/man/man1/pyqi.1.gz

Changelog

2014-05-21 - Andreas Tille <tille@debian.org>
pyqi (0.3.2+dfsg-1) unstable; urgency=medium
* New upstream version
2014-03-27 - Andreas Tille <tille@debian.org>
pyqi (0.3.1+dfsg-1) unstable; urgency=medium
* New upstream version
* Fixed watch file
* cme fix dpkg-control
* Exclude binary chunks from doc creation (and egg-info once we are
removing useless stuff)
* Create html documentation and install it
2013-11-09 - Andreas Tille <tille@debian.org>
pyqi (0.2.0-2) unstable; urgency=low
* Drop centence with funky unicode from long description.
Closes: #729199
2013-10-15 - Andreas Tille <tille@debian.org>
pyqi (0.2.0-1) unstable; urgency=low
* Initial release for Debian (Closes: #726386)
* debian/control:
- taking over into Debian Med team maintenance
- Vcs fields
- cme fix dpkg-control
- drop explicit python dependency which is automatically
resolved from variable
- Arch: all
* debian/copyright: cme fix dpkg-copyright
2013-09-24 - Tim Booth <tbooth@ceh.ac.uk>
pyqi (0.2.0-0biolinux1) precise; urgency=low
* Initial release for BL.

See Also

Package Description
pyqso_0.2-1_all.deb logging tool for amateur radio operators
pyqt4-dev-tools_4.11.4+dfsg-1build4_amd64.deb Development tools for PyQt4
pyqt4.qsci-dev_2.9.1+dfsg-4build1_all.deb Development files for Python Qscintilla2 (Qt4)
pyqt5-dev-tools_5.5.1+dfsg-3ubuntu4_amd64.deb Development tools for PyQt5
pyqt5-dev_5.5.1+dfsg-3ubuntu4_all.deb Development files for PyQt5
pyqt5-doc_5.5.1+dfsg-3ubuntu4_all.deb Documentation for PyQt5
pyqt5-examples_5.5.1+dfsg-3ubuntu4_all.deb Examples and demos for PyQt5
pyqt5.qsci-dev_2.9.1+dfsg-4build1_all.deb Development files for Python Qscintilla2 (Qt5)
pyracerz_0.2-8_all.deb multiplayer top view 2D racing game
pyragua_0.2.5-6_all.deb Very lightweight Python editor
pyrenamer_0.6.0-1.2_all.deb mass file renamer written in PyGTK
pyrex-mode_0.9.8.5-2.1ubuntu1_all.deb emacs-lisp pyrex-mode for pyrex
pyrit-opencl_0.4.0-1_amd64.deb OpenCL extension module for Pyrit
pyrit_0.4.0-5_amd64.deb GPGPU-driven WPA/WPA2-PSK key cracker
pyrite-publisher_2.1.1-11_amd64.deb Convert html and text documents to palm DOC format
Advertisement
Advertisement