pype_2.9.4-2_all.deb


Advertisement

Description

pype - Python programmers editor

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: pype
Package version: 2.9.4
Package release: 2
Package architecture: all
Package type: deb
Installed size: 878 B
Download size: 191.53 KB
Official Mirror: archive.ubuntu.com
PyPE (Python Programmers Editor) is a lightweight but powerful editor. Tools for the new and seasoned user alike are included out of the box, including syntax coloring, multiple open documents with tabs, per-document browsable source trees, and many others.

Alternatives

    Download

    Binary package: pype_2.9.4-2_all.deb
    Source package: pype

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install pype deb package:
      # sudo apt-get install pype

    Files

    • /usr/bin/pype
    • /usr/share/applications/pype.desktop
    • /usr/share/doc/pype/changelog.Debian.gz
    • /usr/share/doc/pype/copyright
    • /usr/share/doc/pype/readme.html
    • /usr/share/doc/pype/readme.txt.gz
    • /usr/share/doc/pype/todo.txt.gz
    • /usr/share/lintian/overrides/pype
    • /usr/share/man/man1/pype.1.gz
    • /usr/share/pixmaps/pype.xpm
    • /usr/share/pype/StyleSetter.py
    • /usr/share/pype/__version__.py
    • /usr/share/pype/configuration.py
    • /usr/share/pype/pype.py
    • /usr/share/pype/sample_alphabet.txt
    • /usr/share/pype/sample_dictionary.txt
    • /usr/share/pype/stc-styles.rc.cfg
    • /usr/share/pype/test_parser.py
    • /usr/share/pype/icons/blank.ico
    • /usr/share/pype/icons/green.png
    • /usr/share/pype/icons/py.ico
    • /usr/share/pype/icons/pype.ico
    • /usr/share/pype/icons/red.png
    • /usr/share/pype/icons/yellow.png
    • /usr/share/pype/macros/samples/macro_1152752910_55071.py
    • /usr/share/pype/macros/samples/macro_1152753207_27435.py
    • /usr/share/pype/macros/samples/macro_1152753257_22116.py
    • /usr/share/pype/macros/samples/macro_1152753515_1067.py
    • /usr/share/pype/macros/samples/readme.txt
    • /usr/share/pype/plugins/__init__.py
    • /usr/share/pype/plugins/browser.py
    • /usr/share/pype/plugins/codetree.py
    • /usr/share/pype/plugins/context_sizer.py
    • /usr/share/pype/plugins/documents.py
    • /usr/share/pype/plugins/exparse.py
    • /usr/share/pype/plugins/filehistory.py
    • /usr/share/pype/plugins/filtertable.py
    • /usr/share/pype/plugins/findbar.py
    • /usr/share/pype/plugins/findinfiles.py
    • /usr/share/pype/plugins/help.py
    • /usr/share/pype/plugins/horizontalbrowser.py
    • /usr/share/pype/plugins/interpreter.py
    • /usr/share/pype/plugins/keydialog.py
    • /usr/share/pype/plugins/lineabstraction.py
    • /usr/share/pype/plugins/logger.py
    • /usr/share/pype/plugins/lru.py
    • /usr/share/pype/plugins/macro.py
    • /usr/share/pype/plugins/methodhelper.py
    • /usr/share/pype/plugins/mylistmix.py
    • /usr/share/pype/plugins/parsers.py
    • /usr/share/pype/plugins/popup.py
    • /usr/share/pype/plugins/pubsub.py
    • /usr/share/pype/plugins/sched.py
    • /usr/share/pype/plugins/scheduler.py
    • /usr/share/pype/plugins/shell.py
    • /usr/share/pype/plugins/single_instance.py
    • /usr/share/pype/plugins/sourcetags.py
    • /usr/share/pype/plugins/spellcheck.py
    • /usr/share/pype/plugins/tagger.py
    • /usr/share/pype/plugins/textrepr.py
    • /usr/share/pype/plugins/todo.py
    • /usr/share/pype/plugins/triggerdialog.py
    • /usr/share/pype/plugins/window_management.py
    • /usr/share/pype/plugins/workspace.py
    • /usr/share/python/runtime.d/pype.rtupdate

    Changelog

    2014-09-11 - Andreas Noteng <andreas@noteng.no> pype (2.9.4-2) unstable; urgency=low * Bump Standards-Version (no change) [Jakub Wilk] * Use canonical URIs for Vcs-* fields. [Olly Betts] * Update for wxPython 3.0 (Closes: #758957): - New patch: wxpython3.0.patch

    2013-04-29 - Andreas Noteng <andreas@noteng.no> pype (2.9.4-1) unstable; urgency=low * New upstream release * Bump Standards-Version to 3.9.4 - Changed versioned build dependency debhelper to 8.1.0 * Add a get-orig-source rule to download and repack

    2012-05-03 - Andreas Noteng <andreas@noteng.no> pype (2.9.1-4) unstable; urgency=low * Switch from python-support to dh_python2 * Bump standards-version to 3.9.3 - Upgrade debian/copyright to version 1.0 * Fix FTBFS when building twice in a row by adding dh_clean to the clean target and deleting all .pyc's (closes: #671144) * Lintian override: possible-documentation-but-no-doc-base-registration because the html file is an internal PyPE help file * Add missing Depends python-wxversion * Don't include two copies of readme.html * Bump compatibility level to 7, to make dh_installchangelogs automatically find and install the upstream changelog * Drop the /usr/bin shell script and use a link instead * Make the shebang work by stripping the UTF8 BOM character and DOS line endings. [Jakub Wilk] * Add Vcs-* fields.

    2011-02-03 - Andreas Noteng <andreas@noteng.no> pype (2.9.1-3) unstable; urgency=low * Update Depends: from python-wxgtk2.6 to python-wxgtk2.8 * Add Depends: ${python:Depends} (closes: #611586)

    2010-10-17 - Andreas Noteng <andreas@noteng.no> pype (2.9.1-2) unstable; urgency=low * command-shell.patch - Fix broken command shell, from upstream svn repository. (closes: #600227) * iterpreter.py_warning.patch - Fix warning when opening a command shell.

    2010-10-02 - Andreas Noteng <andreas@noteng.no> pype (2.9.1-1) unstable; urgency=low * New upstream version (closes: #598661) * New maintainer. (Orphaned package) (closes: #579372) * Changed to machine readable debian/copyright * Bumped standards version to 3.9.1 - Updated menu categories - All control files and changelog encoded in UTF-8 * Switched from python-central to python-support

    2006-07-21 - Franz Pletz <fpletz@franz-pletz.org> pype (2.5-2) unstable; urgency=low * New maintainer. (Approved by Matthias) * debian/menu: - Replaced reference to spe with pype. - Make reference to new XPM icon. * debian/control: - Build-Depend on python et al. - Removed Build-Depend von python-wxgtk2.6. - Install debian/pype.xpm. * Added debian/pycompat. * debian/copyright: Updated FSF address. * debian/compat: Bumped to 5 as debian/control depends on it. * Wrote manpage.

    2006-07-01 - Matthias Klose <doko@debian.org> pype (2.5-1) unstable; urgency=low * New upstream version. * Convert to updated Python policy. * Orphan the package. * Add workaround for icon loading bug (closes: #327054).

    2006-01-22 - Matthias Klose <doko@debian.org> pype (2.2.2-1) unstable; urgency=low * Upload to unstable.

    2006-01-22 - Matthias Klose <doko@ubuntu.com> pype (2.2.2-0ubuntu1) dapper; urgency=low * New upstream version. - Fixing segfaults with current wxwidgets2.6 version. Ubuntu #3028.

    Advertisement
    Advertisement