pynast_1.2.2-1_all.deb


Advertisement

Description

pynast - alignment of short DNA sequences

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe amd64
Package name pynast
Package version 1.2.2
Package release 1
Package architecture all
Package type deb
Installed size 323 B
Download size 74.80 KB
Official Mirror archive.ubuntu.com
The package provices a reimplementation of the Nearest Alignment
Space Termination tool in Python. It was prepared for next generation
sequencers.
Given a set of sequences and a template alignment, PyNAST will align the
input sequences against the template alignment, and return a multiple
sequence alignment which contains the same number of positions (or
columns) as the template alignment. This facilitates the analysis of new
sequences in the context of existing alignments, and additional data
derived from existing alignments such as phylogenetic trees. Because
any protein or nucleic acid sequences and template alignments can be
provided, PyNAST is not limited to the analysis of 16s rDNA sequences.

Alternatives

Package Version Architecture Repository
pynast_1.2.2-1_all.deb 1.2.2 all Ubuntu Universe
pynast - - -

Requires

Name Value
libjs-jquery -
libjs-underscore -
python << 2.8
python >= 2.7

Provides

Name Value
python-pynast -

Conflicts

Name Value
python-pynast -

Replaces

Name Value
python-pynast -

Download

Type URL
Binary Package pynast_1.2.2-1_all.deb
Source Package pynast

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install pynast deb package:
    # sudo apt-get install pynast

Files

Path
/usr/bin/pynast
/usr/lib/python2.7/dist-packages/pynast-1.2.2.egg-info
/usr/lib/python2.7/dist-packages/pynast/__init__.py
/usr/lib/python2.7/dist-packages/pynast/logger.py
/usr/lib/python2.7/dist-packages/pynast/util.py
/usr/lib/python2.7/dist-packages/pynast/pycogent_backports/__init__.py
/usr/lib/python2.7/dist-packages/pynast/pycogent_backports/uclust.py
/usr/share/doc-base/pynast
/usr/share/doc/pynast/README.Debian
/usr/share/doc/pynast/README.md
/usr/share/doc/pynast/README.test
/usr/share/doc/pynast/changelog.Debian.gz
/usr/share/doc/pynast/copyright
/usr/share/doc/pynast/run-unit-test
/usr/share/doc/pynast/html/index.html
/usr/share/doc/pynast/html/install.html
/usr/share/doc/pynast/html/install_gui.html
/usr/share/doc/pynast/html/objects.inv
/usr/share/doc/pynast/html/search.html
/usr/share/doc/pynast/html/searchindex.js
/usr/share/doc/pynast/html/_sources/index.txt
/usr/share/doc/pynast/html/_sources/install.txt
/usr/share/doc/pynast/html/_sources/install_gui.txt
/usr/share/doc/pynast/html/_static/ajax-loader.gif
/usr/share/doc/pynast/html/_static/basic.css
/usr/share/doc/pynast/html/_static/comment-bright.png
/usr/share/doc/pynast/html/_static/comment-close.png
/usr/share/doc/pynast/html/_static/comment.png
/usr/share/doc/pynast/html/_static/default.css
/usr/share/doc/pynast/html/_static/doctools.js
/usr/share/doc/pynast/html/_static/down-pressed.png
/usr/share/doc/pynast/html/_static/down.png
/usr/share/doc/pynast/html/_static/file.png
/usr/share/doc/pynast/html/_static/jquery.js
/usr/share/doc/pynast/html/_static/minus.png
/usr/share/doc/pynast/html/_static/plus.png
/usr/share/doc/pynast/html/_static/pygments.css
/usr/share/doc/pynast/html/_static/searchtools.js
/usr/share/doc/pynast/html/_static/sidebar.js
/usr/share/doc/pynast/html/_static/underscore.js
/usr/share/doc/pynast/html/_static/up-pressed.png
/usr/share/doc/pynast/html/_static/up.png
/usr/share/doc/pynast/html/_static/websupport.js
/usr/share/doc/pynast/tests/all_tests.py
/usr/share/doc/pynast/tests/test_logger.py
/usr/share/doc/pynast/tests/test_util.py.gz
/usr/share/doc/pynast/tests/test_pycogent_backports/test_uclust.py.gz
/usr/share/man/man1/pynast.1.gz

Changelog

2014-08-11 - Andreas Tille <tille@debian.org>
pynast (1.2.2-1) unstable; urgency=medium
* New upsteam version now on Github (adapted d/watch)
* debian/copyright: License change from GPL to BSD
* rename source package from python-pynast to pynast
* cme fix dpkg-control
* debian/patches/do_not_install_privacy_breaching_scripts.patch: Do not
install privacy breaking scripts
* debian/rules: run unit tests
* debian/control:
- Build-Depends + Recommend packages needed in unit tests
- Recommends: python-mpi4py
* debian/patches/avoid_python-mpi4py_missing_warning.patch: Circumvent
missing python-mpi4py at build time
* Add autopkgtest
2013-06-17 - Andreas Tille <tille@debian.org>
python-pynast (1.2-1) unstable; urgency=low
* Upload to Debian
2013-06-11 - Tim Booth <tbooth@ceh.ac.uk>
python-pynast (1.2-0biolinux1) precise; urgency=low
* New upstream
* New upstream location - changed watchfile
2013-05-20 - Andreas Tille <tille@debian.org>
python-pynast (1.1-4) unstable; urgency=low
[ Charles Plessy ]
* Renamed debian/upstream-metadata.yaml to debian/upstream.
* Corrected VCS URLs (debian/control).
[ Andreas Tille ]
* debian/upstream:
- Moved DOI/PMID to References section
- Valid BibTeX authors field
* debian/control:
- Section: optional
- Standards-Version: 3.9.4 (no changes needed)
- Debhelper 9 (also in compat)
- removed XS-Autobuild because package is in main
- Drop Build-Depends: python-central
Closes:  #708889
2011-11-29 - Andreas Tille <tille@debian.org>
python-pynast (1.1-3) unstable; urgency=low
[ Steffen Moeller ]
* Rendering Tim's fixes available for Debian
* Moving pynast from contrib to main. The dependency cogent
got its non-freeness resolved.
* Changing name from python-pynast to pynast.
[ Andreas Tille ]
* debian/control:
- Added myself and Tim Booth <tbooth@ceh.ac.uk> to Uploaders
- Fixed Vcs fields
- Removed duplicated ${misc:Depends}
- Removed unneeded ${shlibs:Depends}
- Depends: libjs-jquery, libjs-underscore
- Moved citation information from long description to
upstream-metadata.yaml
- Moved information about previous versions from long description
to README.Debian
- Provides/Replaces/Conflicts: python-pynast to enable smooth
upgrades after renaming the package
* debian/copyright: DEP5
* Dephelper 8 (control+compat)
* debian/links: Link packages JavaScript libraries
* debian/rules: remove incomplete links to JavaScript libraries
* debian/doc-base: created docbase file
* debian/pynast.1: escape hyphen character
* debian/upstream-metadata.yaml: Citation information
* debian/README.Debian: Replaced outdated and useless content by
some information about previous upstream versions (previosely
mentioned in long description)
2011-08-26 - Tim Booth <tbooth@ceh.ac.uk>
python-pynast (1.1-2ubuntu4) lucid; urgency=low
* Fix Lintian warning on docs, clean up build file
* Allow building with either python2 or python-central 
* Renamed main package to pynast
2011-08-26 - Tim Booth <tbooth@ceh.ac.uk>
python-pynast (1.1-2ubuntu3) lucid; urgency=low
* Rebuild for Lucid, lowered dependencies 
2011-08-25 - Steffen Moeller <moeller@debian.org>
python-pynast (1.1-2) unstable; urgency=low
* Transition to dh7 and dh_python2
* Adjusted uploaders, first upload to unstable
* Documentation built with sphinx
* Added man page
2010-07-25 - Sri Girish Srinivasa Murthy <srigirish@evolbio.mpg.de>
python-pynast (1.1-1) experimental; urgency=low
* Initial release (Closes: #587189)

See Also

Package Description
pyneighborhood_0.5.1-2_all.deb PyGTK2 SAMBA browser
pynslcd_0.9.6-3_all.deb daemon for NSS and PAM lookups via LDAP - Python version
pyntor_0.6-4.1_all.deb flexible and componentized presentation program
pyosmium-doc_2.6.0-1_all.deb Osmium library bindings for Python - Documentation
pyotherside-tests_1.4.0-2_amd64.deb Asynchronous Python 3 Bindings for Qt 5 (tests)
pyp_2.12-1_all.deb sed/awk-like tool with Python language
pypar2_1.4-7_all.deb graphical frontend for the par2 utility
pype_2.9.4-2_all.deb Python programmers editor
pypi2deb_1.20151008_all.deb PyPI to Debian converter
pypibrowser_1.5-2.1_all.deb graphical interface for browsing the Python Package Index
pyppd_1.0.2-2_all.deb CUPS PostScript Printer Driver's compressor and generator
pyprompter_0.9.1-1.1ubuntu2_all.deb intelligent predictive wxPython text editor
pypump-shell_0.6-1_all.deb interface to the pump.io APIs (pypump-shell program)
pypy-appdirs_1.4.0-2_all.deb determining appropriate platform-specific directories (PyPy)
pypy-attr_15.2.0-1_all.deb Attributes without boilerplate (PyPy)
Advertisement
Advertisement