pygopherd_2.0.18.3+nmu4ubuntu1_all.deb


Advertisement

Description

pygopherd - Modular Multiprotocol Gopher/HTTP/WAP Server in Python

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: pygopherd
Package version: 2.0.18.3+nmu4ubuntu1
Package release:
Package architecture: all
Package type: deb
Installed size: 499 B
Download size: 167.66 KB
Official Mirror: archive.ubuntu.com
This is an all-new, modern Gopher server. It can serve documents with Gopher+, standard Gopher (RFC1436), HTTP, and WAP -- all on the same port. Pygopherd features a modular extension system as well as loadable scripts and much more. It contains full support for UMN gopherd systems -- including .Links, .names, .cap, searches, etc. Pygopherd also supports Bucktooth features such as gophermap files and executables. In addition to all this, there are Pygopherd's own extra features. All features are fully customizable and can be enabled or disabled by editing /etc/pygopherd/pygopherd.conf. This version of PyGopherd introduces WAP support.

Alternatives

Provides

  • gopher-server

    Download

    Source package: pygopherd

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install pygopherd deb package:
      # sudo apt-get install pygopherd

    Files

    • /etc/init.d/pygopherd
    • /etc/pygopherd/pygopherd.conf
    • /usr/lib/python2.7/dist-packages/pygopherd-2.0.18.egg-info
    • /usr/lib/python2.7/dist-packages/pygopherd/GopherExceptions.py
    • /usr/lib/python2.7/dist-packages/pygopherd/GopherExceptionsTest.py
    • /usr/lib/python2.7/dist-packages/pygopherd/__init__.py
    • /usr/lib/python2.7/dist-packages/pygopherd/fileext.py
    • /usr/lib/python2.7/dist-packages/pygopherd/fileextTest.py
    • /usr/lib/python2.7/dist-packages/pygopherd/gopherentry.py
    • /usr/lib/python2.7/dist-packages/pygopherd/gopherentryTest.py
    • /usr/lib/python2.7/dist-packages/pygopherd/initialization.py
    • /usr/lib/python2.7/dist-packages/pygopherd/initializationTest.py
    • /usr/lib/python2.7/dist-packages/pygopherd/logger.py
    • /usr/lib/python2.7/dist-packages/pygopherd/loggerTest.py
    • /usr/lib/python2.7/dist-packages/pygopherd/pipe.py
    • /usr/lib/python2.7/dist-packages/pygopherd/pipeTest.py
    • /usr/lib/python2.7/dist-packages/pygopherd/sighandlers.py
    • /usr/lib/python2.7/dist-packages/pygopherd/testutil.py
    • /usr/lib/python2.7/dist-packages/pygopherd/version.py
    • /usr/lib/python2.7/dist-packages/pygopherd/zipfile.py
    • /usr/lib/python2.7/dist-packages/pygopherd/handlers/HandlerMultiplexer.py
    • /usr/lib/python2.7/dist-packages/pygopherd/handlers/UMN.py
    • /usr/lib/python2.7/dist-packages/pygopherd/handlers/ZIP.py
    • /usr/lib/python2.7/dist-packages/pygopherd/handlers/__init__.py
    • /usr/lib/python2.7/dist-packages/pygopherd/handlers/base.py
    • /usr/lib/python2.7/dist-packages/pygopherd/handlers/dir.py
    • /usr/lib/python2.7/dist-packages/pygopherd/handlers/file.py
    • /usr/lib/python2.7/dist-packages/pygopherd/handlers/gophermap.py
    • /usr/lib/python2.7/dist-packages/pygopherd/handlers/html.py
    • /usr/lib/python2.7/dist-packages/pygopherd/handlers/mbox.py
    • /usr/lib/python2.7/dist-packages/pygopherd/handlers/pyg.py
    • /usr/lib/python2.7/dist-packages/pygopherd/handlers/scriptexec.py
    • /usr/lib/python2.7/dist-packages/pygopherd/handlers/tal.py
    • /usr/lib/python2.7/dist-packages/pygopherd/handlers/url.py
    • /usr/lib/python2.7/dist-packages/pygopherd/handlers/virtual.py
    • /usr/lib/python2.7/dist-packages/pygopherd/protocols/ProtocolMultiplexer.py
    • /usr/lib/python2.7/dist-packages/pygopherd/protocols/ProtocolMultiplexerTest.py
    • /usr/lib/python2.7/dist-packages/pygopherd/protocols/__init__.py
    • /usr/lib/python2.7/dist-packages/pygopherd/protocols/base.py
    • /usr/lib/python2.7/dist-packages/pygopherd/protocols/baseTest.py
    • /usr/lib/python2.7/dist-packages/pygopherd/protocols/enhanced.py
    • /usr/lib/python2.7/dist-packages/pygopherd/protocols/gopherp.py
    • /usr/lib/python2.7/dist-packages/pygopherd/protocols/http.py
    • /usr/lib/python2.7/dist-packages/pygopherd/protocols/rfc1436.py
    • /usr/lib/python2.7/dist-packages/pygopherd/protocols/rfc1436Test.py
    • /usr/lib/python2.7/dist-packages/pygopherd/protocols/wap.py
    • /usr/sbin/pygopherd
    • /usr/share/doc/pygopherd/README
    • /usr/share/doc/pygopherd/changelog.gz
    • /usr/share/doc/pygopherd/copyright
    • /usr/share/doc/pygopherd/pygopherd.html
    • /usr/share/doc/pygopherd/pygopherd.pdf.gz
    • /usr/share/doc/pygopherd/pygopherd.ps.gz
    • /usr/share/doc/pygopherd/pygopherd.txt.gz
    • /usr/share/doc/pygopherd/examples/gophermap
    • /usr/share/doc/pygopherd/examples/talsample.html.tal
    • /usr/share/man/man8/pygopherd.8.gz
    • /usr/share/pygopherd/gophermap

    Changelog

    2016-04-08 - Logan Rosen <logan@ubuntu.com> pygopherd (2.0.18.3+nmu4ubuntu1) xenial; urgency=medium * debian/rules: - Remove legacy DH_COMPAT export. - Use dh_prep instead of dh_clean -k. - Add recommended build-arch and build-indep targets. - Remove example doc-base file. - Don't allow $(MAKE) clean to ignore errors. * debian/compat: Indicate compatibility level of 9. * debian/control: - Build-depend on debhelper (>= 9) and dh-python. - Move python to Build-Depends since clean needs it. - Depend on ${misc:Depends}. * debian/conffiles: Remove, since debhelper automatically adds conffiles in /etc. * debian/copyright: - Remove "(s)" from "Upstream Author(s)" to satisfy Lintian. - Replace old FSF address with new one.

    2014-12-08 - Cameron Norman <camerontnorman@gmail.com> pygopherd (2.0.18.3+nmu4) unstable; urgency=medium * Non-maintainer upload. * Copy gophermap from /usr/share, not /usr/share/doc (Closes: #771501)

    2013-06-28 - Andrea Colangelo <warp10@ubuntu.com> pygopherd (2.0.18.3+nmu3) unstable; urgency=low * Non-maintainer upload. * Convert to dh_python2. (Closes: #616966)

    2009-10-19 - Kumar Appaiah <akumar@debian.org> pygopherd (2.0.18.3+nmu2) unstable; urgency=low * Non-maintainer upload. * Build-Depend on python >= 2.5.4 for install-layout=deb.

    2009-10-17 - Bastian Venthur <venthur@debian.org> pygopherd (2.0.18.3+nmu1) unstable; urgency=low * Non-maintainer upload. * Fix "manipulates site-packages/ directly, failing with Python 2.6" Applied and uploaded Kumar's patch, thanks dude! (Closes: #547835)

    2008-08-08 - John Goerzen <jgoerzen@complete.org> pygopherd (2.0.18.3) unstable; urgency=low * Now remove build directory in clean target.

    2008-08-05 - John Goerzen <jgoerzen@complete.org> pygopherd (2.0.18.2) unstable; urgency=medium * Correct typo in debian/rules. Really get RFC out of Debian source package this time. Closes: #475376.

    2008-05-01 - John Goerzen <jgoerzen@complete.org> pygopherd (2.0.18.1) unstable; urgency=low * Remove RFC from Debian source package. Closes: #475376.

    2008-04-10 - John Goerzen <jgoerzen@complete.org> pygopherd (2.0.18) unstable; urgency=low * Move #DEBHELPER# section to end of postinst so that adduser gets run first. Fixes a bug introduced in 2.0.17. Closes: #475247. * Removed weird stuff from source tree * Acknowledge NMU. Closes: #469619.

    2008-04-04 - Petter Reinholdtsen <pere@debian.org> pygopherd (2.0.17-0.1) unstable; urgency=low * Non-maintainer upload to solve release goal. * Add LSB dependency header to init.d scripts (Closes: #469619).

    Advertisement
    Advertisement