puppet-lint_1.1.0-1_all.deb


Advertisement

Description

puppet-lint - check puppet manifests for style guide conformity

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: puppet-lint
Package version: 1.1.0
Package release: 1
Package architecture: all
Package type: deb
Installed size: 180 B
Download size: 26.05 KB
Official Mirror: archive.ubuntu.com
Checks your Puppet manifests against the Puppet Labs style guide and alerts you to any discrepancies. This program checks spacing, indentation, whitespace, quoting, conditionals and classes.

Alternatives

    Download

    Source package: puppet-lint

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install puppet-lint deb package:
      # sudo apt-get install puppet-lint

    Files

    • /usr/bin/puppet-lint
    • /usr/lib/ruby/vendor_ruby/puppet-lint.rb
    • /usr/lib/ruby/vendor_ruby/puppet-lint/bin.rb
    • /usr/lib/ruby/vendor_ruby/puppet-lint/checkplugin.rb
    • /usr/lib/ruby/vendor_ruby/puppet-lint/checks.rb
    • /usr/lib/ruby/vendor_ruby/puppet-lint/configuration.rb
    • /usr/lib/ruby/vendor_ruby/puppet-lint/data.rb
    • /usr/lib/ruby/vendor_ruby/puppet-lint/lexer.rb
    • /usr/lib/ruby/vendor_ruby/puppet-lint/monkeypatches.rb
    • /usr/lib/ruby/vendor_ruby/puppet-lint/optparser.rb
    • /usr/lib/ruby/vendor_ruby/puppet-lint/plugins.rb
    • /usr/lib/ruby/vendor_ruby/puppet-lint/version.rb
    • /usr/lib/ruby/vendor_ruby/puppet-lint/lexer/token.rb
    • /usr/lib/ruby/vendor_ruby/puppet-lint/monkeypatches/string_percent.rb
    • /usr/lib/ruby/vendor_ruby/puppet-lint/monkeypatches/string_prepend.rb
    • /usr/lib/ruby/vendor_ruby/puppet-lint/plugins/check_classes.rb
    • /usr/lib/ruby/vendor_ruby/puppet-lint/plugins/check_comments.rb
    • /usr/lib/ruby/vendor_ruby/puppet-lint/plugins/check_conditionals.rb
    • /usr/lib/ruby/vendor_ruby/puppet-lint/plugins/check_documentation.rb
    • /usr/lib/ruby/vendor_ruby/puppet-lint/plugins/check_nodes.rb
    • /usr/lib/ruby/vendor_ruby/puppet-lint/plugins/check_resources.rb
    • /usr/lib/ruby/vendor_ruby/puppet-lint/plugins/check_strings.rb
    • /usr/lib/ruby/vendor_ruby/puppet-lint/plugins/check_variables.rb
    • /usr/lib/ruby/vendor_ruby/puppet-lint/plugins/check_whitespace.rb
    • /usr/lib/ruby/vendor_ruby/puppet-lint/tasks/puppet-lint.rb
    • /usr/share/doc/puppet-lint/README.md.gz
    • /usr/share/doc/puppet-lint/changelog.Debian.gz
    • /usr/share/doc/puppet-lint/copyright
    • /usr/share/man/man1/puppet-lint.1.gz
    • /usr/share/rubygems-integration/all/specifications/puppet-lint-1.1.0.gemspec

    Changelog

    2014-10-24 - Stig Sandbeck Mathisen <ssm@debian.org> puppet-lint (1.1.0-1) unstable; urgency=medium * Imported upstream release 1.1.0-1 * Update Vcs-Browser URL * Declare compliance with Debian policy 3.9.6

    2014-08-21 - Stig Sandbeck Mathisen <ssm@debian.org> puppet-lint (1.0.1-1) unstable; urgency=medium * Imported upstream release 1.0.1

    2014-08-20 - Stig Sandbeck Mathisen <ssm@debian.org> puppet-lint (1.0.0-1) unstable; urgency=medium * Imported upstream release 1.0.0 (Closes: #758584) * Declare compliance with Debian Policy version 3.9.5 * Add DEP-8 tests

    2013-05-09 - Stig Sandbeck Mathisen <ssm@debian.org> puppet-lint (0.3.2-2) unstable; urgency=low * Upload to unstable

    2013-01-02 - Micah Anderson <micah@debian.org> puppet-lint (0.3.2-1) experimental; urgency=low [ Micah Andeson ] * New upstream release * Remove puppet-common from Depends, internal parser is used instead

    2012-09-04 - Stig Sandbeck Mathisen <ssm@debian.org> puppet-lint (0.2.1-1) experimental; urgency=low * Imported upstream version 0.2.1 * Remove patch "no-require-rubygems"

    2012-03-31 - Stig Sandbeck Mathisen <ssm@debian.org> puppet-lint (0.1.13-1) unstable; urgency=low * Imported Upstream version 0.1.13

    2012-03-15 - Stig Sandbeck Mathisen <ssm@debian.org> puppet-lint (0.1.12-1) unstable; urgency=low * New upstream release

    2012-01-26 - Stig Sandbeck Mathisen <ssm@debian.org> puppet-lint (0.1.11-1) unstable; urgency=low * New upstream relase * Refresh patch "no-require-rubygems"

    2011-10-08 - Stig Sandbeck Mathisen <ssm@debian.org> puppet-lint (0.1.6-1) unstable; urgency=low * New upstream release

    Advertisement
    Advertisement