puf_1.0.0-7_amd64.deb


Advertisement

Description

puf - Parallel URL fetcher

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe amd64
Package name puf
Package version 1.0.0
Package release 7
Package architecture amd64
Package type deb
Installed size 148 B
Download size 49.99 KB
Official Mirror archive.ubuntu.com
puf is a download tool for UNIX-like systems. You may use it to download
single files or to mirror entire servers. It is similar to GNU wget
(and has a partly compatible command line), but has the ability to do
many downloads in parallel. This is very interesting, if you have a
high-bandwidth internet connection.

Alternatives

Package Version Architecture Repository
puf_1.0.0-7_i386.deb 1.0.0 i386 Ubuntu Universe
puf - - -

Requires

Name Value
libc6 >= 2.11

Download

Type URL
Binary Package puf_1.0.0-7_amd64.deb
Source Package puf

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install puf deb package:
    # sudo apt-get install puf

Files

Path
/usr/bin/puf
/usr/share/doc/puf/README.gz
/usr/share/doc/puf/TODO
/usr/share/doc/puf/changelog.Debian.gz
/usr/share/doc/puf/copyright
/usr/share/man/man1/puf.1.gz

Changelog

2011-03-04 - Marco Nenciarini <mnencia@debian.org>
puf (1.0.0-7) unstable; urgency=low
[ Kai Wasserbäch ]
* debian/rules:
- Add --parallel to dh invocation.
- Updated for debhelper 8 compatibility.
- Only use the sequence from dh-autoreconf, also updates
config.{sub,guess}. (Closes: #613983)
* debian/control:
- Bumped Standards-Version to 3.9.1, no further changes needed.
- Changed my e-mail address.
- Bumped B-D on debhelper.
* debian/source/local-options: Make sure patches get unapplied again.
* debian/compat: Now "8".
2010-06-29 - Marco Nenciarini <mnencia@debian.org>
puf (1.0.0-6) unstable; urgency=low
[ Kai Wasserbäch ]
* Use new dh-autoreconf in conjunction with autotools-dev in favour of custom
rules:
- debian/control:
+ dh-autoreconf: Added Build-Depends.
+ autotools-dev: Added Build-Depends with "(>= 20100122.1)", because of
the dh sequence.
+ auto{make,conf}: Removed Build-Depends.
+ Bumped Build-Depends on debhelper to >= 7.3.16~ for sequence support.
- debian/rules: Replace everything with "dh --with
autotools_dev,autoreconf $@".
* debian/patches:
- 0003-Fix-gcc-4.1-optimization-issue.patch: Updated to address compiler
warnings.
- 0006-Fix-compiler-warnings.patch: Added to address remaining warnings
with GCC 4.5.
* debian/control: Bumped Standards-Version to 3.9.0, no further changes
needed.
2010-04-21 - Marco Nenciarini <mnencia@debian.org>
puf (1.0.0-5) unstable; urgency=low
[ Kai Wasserbäch ]
* debian/rules: converted to debhelper 7 format. Fixes
debian-rules-ignores-make-clean-error.
* debian/control:
- Bump Standards-Version to 3.8.4, no further changes needed. Fixes
ancient-standards-version.
- Added Homepage field. (Closes: #494814)
- Added ${misc:Depends}, fixes debhelper-but-no-misc-depends.
- Added Build-Depends on autoconf and automake.
* Convert the package to source format "3.0 (quilt)".
* debian/copyright: Fix Lintian warnings copyright-without-copyright-notice
and copyright-refers-to-versionless-license-file.
* debian/patches/0004-Fix-hyphen-used-as-minus-sign-reported-by-Lintian.patch:
Added. Fixes hyphen-used-as-minus-sign as reported by Lintian.
[ Marco Nenciarini ]
* debian/rules: run autoreconf at build time. Fixes
outdated-autotools-helper-file and Closes: #535740
* debian/control: add Vcs-* fields.
* Add Kai Wasserbäch to Uploader field.
2007-02-17 - Marco Nenciarini <mnencia@debian.org>
puf (1.0.0-4) unstable; urgency=low
* Decleared all global static variables as volatile to fix gcc-4.1
optimization issue (Closes: #411069)
2006-10-11 - Marco Nenciarini <mnencia@debian.org>
puf (1.0.0-3) unstable; urgency=low
* debian/control: Bump Standards-Version to 3.7.2.2; no changes
required
* Remove the unnecessary -lnsl library reference from Makefiles to
clean up unnecessary library dependency. Thanks to Christian
Aichinger for his neat checklib system!
2006-02-05 - Marco Nenciarini <mnencia@debian.org>
puf (1.0.0-2) unstable; urgency=low
* src/fetch.c: Corrected double free in function ls_iterate_rm
2006-01-23 - Marco Nenciarini <mnencia@debian.org>
puf (1.0.0-1) unstable; urgency=low
* New upstream release
* Updated watch file to use the qa.debian.org redirector
2006-01-23 - Marco Nenciarini <mnencia@debian.org>
puf (0.93.2a-3) unstable; urgency=low
* New maintainer.
* debian/control: Bump Standards-Version to 3.6.2.0; no changes
required
* Use debian/compat instead of DH_COMPAT=n in debian/rules.
* Update debhelper compatibility level to 5.
* debian/copyright: Updated FSF address
* debian/docs: Removed useless NEWS file.
* Updated config.sub/config.guess (Closes: #342439)
* Added watch file.
2004-10-09 - Mike Markley <mike@markley.org>
puf (0.93.2a-2) unstable; urgency=low
* Apply gcc-3.4 patch from Andreas Jochens (Closes: #259611)
2003-03-18 - Mike Markley <mike@markley.org>
puf (0.93.2a-1) unstable; urgency=low
* New upstream version.

See Also

Package Description
pugixml-doc_1.7-2_all.deb Light-weight C++ XML processing library (documentation)
pulseaudio-esound-compat_8.0-0ubuntu3_amd64.deb PulseAudio ESD compatibility layer
pulseaudio-module-droid_8.0-0ubuntu3_amd64.deb Android Audio HAL module for PulseAudio sound server
pulseaudio-module-gconf_8.0-0ubuntu3_amd64.deb GConf module for PulseAudio sound server
pulseaudio-module-jack_8.0-0ubuntu3_amd64.deb jackd modules for PulseAudio sound server
pulseaudio-module-lirc_8.0-0ubuntu3_amd64.deb lirc module for PulseAudio sound server
pulseaudio-module-raop_8.0-0ubuntu3_amd64.deb RAOP module for PulseAudio sound server
pulseaudio-module-trust-store_8.0-0ubuntu3_amd64.deb trust-store module for PulseAudio sound server
pulseaudio-module-zeroconf_8.0-0ubuntu3_amd64.deb Zeroconf module for PulseAudio sound server
pulseview_0.2.0-1.1_amd64.deb sigrok logic analyzer, oscilloscope, and MSO GUI
pump_0.8.24-7_amd64.deb BOOTP and DHCP client for automatic IP configuration
pumpa_0.9.2-1_amd64.deb simple desktop client for pump.io, the distributed social network
puppet-common_3.8.5-2_all.deb configuration management system
puppet-el_3.8.5-2_all.deb syntax highlighting for puppet manifests in emacs
puppet-lint_1.1.0-1_all.deb check puppet manifests for style guide conformity
Advertisement
Advertisement