psychtoolbox-3-lib_3.0.12.20160126.dfsg1-1ubuntu1_amd64.deb


Advertisement

Description

psychtoolbox-3-lib - toolbox for vision research -- arch-specific parts

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: psychtoolbox-3-lib
Package version: 3.0.12.20160126.dfsg1
Package release: 1ubuntu1
Package architecture: amd64
Package type: deb
Installed size: 190 B
Download size: 36.04 KB
Official Mirror: archive.ubuntu.com
Psychophysics Toolbox Version 3 (PTB-3) is a free set of Matlab and GNU/Octave functions for vision research. It makes it easy to synthesize and show accurately controlled visual and auditory stimuli and interact with the observer. The Psychophysics Toolbox interfaces between Matlab or Octave and the computer hardware. The Psychtoolbox's core routines provide access to the display frame buffer and color lookup table, allow synchronization with the vertical retrace, support millisecond timing, allow access to OpenGL commands, and facilitate the collection of observer responses. Ancillary routines support common needs like color space transformations and the QUEST threshold seeking algorithm. This package contains additional binaries (tools/dynamic libraries) used by both Octave and Matlab frontends.

    Download

    Source package: psychtoolbox-3

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install psychtoolbox-3-lib deb package:
      # sudo apt-get install psychtoolbox-3-lib

    Files

    • /usr/lib/psychtoolbox-3/PsychBasic/PsychPlugins/libptbdrawtext_ftgl.so.1
    • /usr/share/doc/psychtoolbox-3-lib/changelog.Debian.gz
    • /usr/share/doc/psychtoolbox-3-lib/copyright
    • /usr/share/psychtoolbox-3/PsychBasic/PsychPlugins/libptbdrawtext_ftgl.so.1

    Changelog

    2016-02-01 - Steve Langasek <steve.langasek@ubuntu.com> psychtoolbox-3 (3.0.12.20160126.dfsg1-1ubuntu1) xenial; urgency=low * Merge from Debian unstable. Remaining changes: - modify the portaudio Makefile and build-depend on autotools-dev to support new arches.

    2016-01-26 - Yaroslav Halchenko <debian@onerussian.com> psychtoolbox-3 (3.0.12.20160126.dfsg1-1) unstable; urgency=medium * Fresh upstream release * debian/dfsg-upstream - adjusted to exclude many new 3rd party library (oculus SDK, etc) which either need to be packaged separately or just not compatible with DFSG

    2015-11-01 - Steve Langasek <steve.langasek@ubuntu.com> psychtoolbox-3 (3.0.12.20150725.dfgs1-2ubuntu1) xenial; urgency=low * Merge from Debian unstable. Remaining changes: - modify the portaudio Makefile and build-depend on autotools-dev to support new arches.

    2015-09-30 - Yaroslav Halchenko <debian@onerussian.com> psychtoolbox-3 (3.0.12.20150725.dfgs1-2) unstable; urgency=medium * debian/rules - export gstreamer-1.0 cflags to make g++ find headers under /usr/lib/ARCH - remove core files which might get dumped * debian/octave-psychtoolbox-3.lintian-overrides - allow embedding GLEW

    2015-07-27 - Yaroslav Halchenko <debian@onerussian.com> psychtoolbox-3 (3.0.12.20150725.dfgs1-1) unstable; urgency=medium * New upstream beta release - updated optional deb_use_system_GLEW for upstream inclusion of -lX11-xcb -lxcb -lxcb-dri3 * debian/control - new build-depends: libxcb1-dev, libx11-xcb-dev, libxcb-dri3-dev

    2015-05-21 - Yaroslav Halchenko <debian@onerussian.com> psychtoolbox-3 (3.0.12.20150419.dfgs1-1) unstable; urgency=medium * New upstream beta release - deals with tripple buffer on intel cards without requiring xorg.conf tuneup * debian/patches/deb_use_system_GLEW - refreshed * debian/copyright - updated years - shortened name for SGI license and listed it for glu_edit.h * upload to unstable - should provide needed dependency on newer gstreamer 1.0 (Closes: #785869) * debian/upstream -> debian/upstream/metadata migration * debian/control - boosted policy to 3.9.6

    2015-03-20 - Yaroslav Halchenko <debian@onerussian.com> psychtoolbox-3 (3.0.12.20150316.dfsg-1) experimental; urgency=medium * New upstream release

    2015-01-26 - Yaroslav Halchenko <debian@onerussian.com> psychtoolbox-3 (3.0.12.20141228.dfsg2-1) experimental; urgency=medium * New upstream release * debian/dfsg-upstream - remove also binary builds of drivers - do not remove copy of glew -- >= 1.11.0 needed for backport builds * debian/rules - patch to use system GLEW only if it is >= 1.11.0 * debian/control - limit builds to lsb-base (>= 4.1+Debian8), so we build in NeuroDebian for Debian >= 7.0 (wheezy), Ubuntu >= 14.04 (trusty)

    2014-10-27 - Yaroslav Halchenko <debian@onerussian.com> psychtoolbox-3 (3.0.12.20141019.dfsg1-1) UNRELEASED; urgency=medium * New upstream release - requires gstreamer 1.0 (debian/control adjusted)

    2015-08-15 - Steve Langasek <steve.langasek@ubuntu.com> psychtoolbox-3 (3.0.11.20140816.dfsg1-1ubuntu4) wily; urgency=medium * No-change rebuild against liboctave3

    Advertisement
    Advertisement