pssh_2.3.1-1_all.deb


Advertisement

Description

pssh - Parallel versions of SSH-based tools

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: pssh
Package version: 2.3.1
Package release: 1
Package architecture: all
Package type: deb
Installed size: 132 B
Download size: 28.31 KB
Official Mirror: archive.ubuntu.com
pssh provides a number of commands for executing against a group of computers, using SSH. It's most useful for operating on clusters of homogenously-configured hosts. The package contains: - Parallel ssh (parallel-ssh, upstream calls it pssh), executes commands on multiple hosts in parallel - Parallel scp (parallel-scp, upstream calls it pscp), copies files to multiple remote hosts in parallel - Parallel rsync (parallel-rsync, upstream calls it prsync), efficiently copies files to multiple hosts in parallel - Parallel nuke (parallel-nuke, upstream calls it pnuke), kills processes on multiple remote hosts in parallel - Parallel slurp (parallel-slurp, upstream calls it pslurp), copies files from multiple remote hosts to a central host in parallel These tools are good for controlling large collections of nodes, where faster alternatives such as gexec and pcp are not available.

Alternatives

    Download

    Binary package: pssh_2.3.1-1_all.deb
    Source package: pssh

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install pssh deb package:
      # sudo apt-get install pssh

    Files

    • /usr/bin/parallel-nuke
    • /usr/bin/parallel-rsync
    • /usr/bin/parallel-scp
    • /usr/bin/parallel-slurp
    • /usr/bin/parallel-ssh
    • /usr/lib/pssh/pssh-askpass
    • /usr/lib/python2.7/dist-packages/pssh-2.3.1.egg-info
    • /usr/lib/python2.7/dist-packages/psshlib/__init__.py
    • /usr/lib/python2.7/dist-packages/psshlib/askpass_client.py
    • /usr/lib/python2.7/dist-packages/psshlib/askpass_server.py
    • /usr/lib/python2.7/dist-packages/psshlib/cli.py
    • /usr/lib/python2.7/dist-packages/psshlib/color.py
    • /usr/lib/python2.7/dist-packages/psshlib/manager.py
    • /usr/lib/python2.7/dist-packages/psshlib/psshutil.py
    • /usr/lib/python2.7/dist-packages/psshlib/task.py
    • /usr/lib/python2.7/dist-packages/psshlib/version.py
    • /usr/share/doc/pssh/README.Debian
    • /usr/share/doc/pssh/changelog.Debian.gz
    • /usr/share/doc/pssh/copyright
    • /usr/share/man/man1/parallel-nuke.1.gz
    • /usr/share/man/man1/parallel-rsync.1.gz
    • /usr/share/man/man1/parallel-scp.1.gz
    • /usr/share/man/man1/parallel-slurp.1.gz
    • /usr/share/man/man1/parallel-ssh.1.gz

    Changelog

    2014-05-12 - Andrew Pollock <apollock@debian.org> pssh (2.3.1-1) unstable; urgency=low * New upstream release * debian/watch: updated to use contribution from bartm * debian/control: bumped Standards-Version (no changes) * debian/{control,rules}: switch from dh_pysupport to dh_python2 * debian/control: added dependency on openssh-client (closes: #721151)

    2012-01-07 - Andrew Pollock <apollock@debian.org> pssh (2.2.2-1) unstable; urgency=low * New upstream release * debian/watch: update for current upstream location * debian/control: bumped Standards-Version * debian/rules: added build-arch and build-indep targets

    2010-03-06 - Andrew Pollock <apollock@debian.org> pssh (2.1.1-1) unstable; urgency=low * New upstream release (closes: #570609) * debian/watch: updated for new upstream location * debian/control: bumped Standards-Version (no changes) * debian/rules: move pssh-askpass to /usr/lib/pssh

    2009-11-25 - Andrew Pollock <apollock@debian.org> pssh (2.0-2) unstable; urgency=low * debian/rules: add --prefix=/usr to build to fix FTBFS with Python 2.6 (closes #557958)

    2009-11-03 - Andrew Pollock <apollock@debian.org> pssh (2.0-1) unstable; urgency=low * New upstream release * debian/copyright: updated for new upstream * debian/control: updated for new upstream * removed patches for installed programs, they now dynamically emit their names in the usage messages * debian/control: removed build-dependency on quilt * debian/docs: removed, upstream no longer ships a TODO file

    2009-10-21 - Andrew Pollock <apollock@debian.org> pssh (1.4.3-2) unstable; urgency=low * debian/rules: don't ship upstream's BUGS file (closes: #547298) * debian/control: bumped Standards-Version (no changes) * debian/control: add quilt to build dependencies * patch all installed programs so usage messages refer to the names used in debian to avoid file conflicts with the putty package (closes: #526801) * copied quilt's README.source to debian/README.source * debian/rules: include all of the upstream documentation * Added manpages contributed by Tatsuki Sugiura <sugi@nemui.org> (closes: #471602)

    2008-10-28 - Andrew Pollock <apollock@debian.org> pssh (1.4.3-1) unstable; urgency=low * New upstream release

    2008-10-04 - Andrew Pollock <apollock@debian.org> pssh (1.4.2-1) unstable; urgency=low * New upstream release

    2008-08-25 - Andrew Pollock <apollock@debian.org> pssh (1.4.0-1) unstable; urgency=low * New upstream release

    2008-07-13 - Andrew Pollock <apollock@debian.org> pssh (1.3.2-1) unstable; urgency=low * New upstream release * debian/control: bumped Standards-Version (no changes)

    Advertisement
    Advertisement