proxychains_3.1-7_all.deb


Advertisement

Description

proxychains - proxy chains - redirect connections through proxy servers

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: proxychains
Package version: 3.1
Package release: 7
Package architecture: all
Package type: deb
Installed size: 27 B
Download size: 5.45 KB
Official Mirror: archive.ubuntu.com
Proxy chains force any tcp connection made by any given tcp client to follow through proxy (or proxy chain). It is a kind of proxifier. It acts like sockscap / premeo / eborder driver ( intercepts TCP calls ) This version supports SOCKS4, SOCKS5 and HTTP CONNECT proxy servers. Different proxy types can be mixed in the same chain. Features * Access Internet from behind restrictive firewall. * Source IP masquerade. * SSH tunneling and forwarding. * Dynamic LAN-to-LAN VPN channel. * Servers and daemons friendly (works fine with sendmail MTA). http://proxychains.sourceforge.net

Alternatives

    Download

    Binary package: proxychains_3.1-7_all.deb
    Source package: proxychains

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install proxychains deb package:
      # sudo apt-get install proxychains

    Files

    • /etc/proxychains.conf
    • /usr/bin/proxychains
    • /usr/share/doc/proxychains/AUTHORS
    • /usr/share/doc/proxychains/README
    • /usr/share/doc/proxychains/README.Debian
    • /usr/share/doc/proxychains/TODO
    • /usr/share/doc/proxychains/changelog.Debian.gz
    • /usr/share/doc/proxychains/copyright
    • /usr/share/man/man1/proxychains.1.gz

    Changelog

    2016-02-23 - Daniel Echeverry <epsilon77@gmail.com> proxychains (3.1-7) unstable; urgency=medium * Fix FTBS when built dpkg-buildpackage -a Closes: #806097 + debian/rules + Add -arch variants of the dh_auto_* + Add hardening flags * Bump standard versions 3.9.7 (no changes) * Add libproxychains3.symbols file * Update debian/libproxychains3.install file + Install proxyresolv from here instead d/rules * Remove libproxychains3.dirs file * debian/control + Remove autotools-dev in B-D * debian/copyright + Extend copyright holder years * debian/rules + Remove override_dh_auto_install + Because now isn't necessary

    2013-05-25 - Daniel Echeverry <epsilon77@gmail.com> proxychains (3.1-6) unstable; urgency=low * Fix FTBFS with eglibc-2.17. Closes: #701413 + Add 600-ftbfs-getnameinfo.patch patch * Bump standard versions 3.9.4 (no changes)

    2012-12-25 - Aron Xu <aron@debian.org> proxychains (3.1-5) unstable; urgency=low * Enabling Multi-Arch for the package. * debian/rules: add calls to DEB_HOST_MULTIARCH, calling dh_autoreconf * debian/control: add Multi-Arch fields * debian/libproxychains*.install: update location for Multi-Arch * Move etc/proxychains.conf to binary package proxychains

    2012-09-14 - Daniel Echeverry <epsilon77@gmail.com> proxychains (3.1-4) unstable; urgency=low * New maintainer. Closes: #674776 * debian/control + Bumped standard versions 3.9.3 + Update to DEP5 copyright format 1.0. + Set myself as Maintainer + Set Aron Xu as Uploaders + Change debhelper to 9 in B-D + Remove quilt in B-D + Add dh-autoreconf in B-D * debian/compat + Switch compat level to 9 * debian/patches + Add description to the patches + Add 400_fix_spelling_mistake.diff + Fix spelling mistake. Closes: #683805 + Add 500_allow_user_specify_DNS.diff + allow user to specify DNS server in proxyresolv. Closes: #603239 + Thanks to The Don Lachlan for the patch * Switch to dpkg-source 3.0 (quilt) format * Fix spelling error in manpage (lintian) * Remove README.source + Because is not necessary * Add README.Debian * debian/libproxychains-dev.install + Remove .a and .la files (lintian) * debian/rules + Use autoreconf

    2010-04-27 - Eugene V. Lyubimkin <jackyf@debian.org> proxychains (3.1-3) unstable; urgency=low * debian/control: - Placed Recommends on 'dnsutils' to shared library package, not the development one. Thanks to ckoeni@gmail.com. (Closes: #579329) - Updated my mail address. - Bumped Standards-Version to 3.8.4, no changes needed.

    2009-05-29 - Eugene V. Lyubimkin <jackyf.devel@gmail.com> proxychains (3.1-2) unstable; urgency=low * Upload to unstable.

    Advertisement
    Advertisement