proxsmtp_1.10-2.1_amd64.deb


Advertisement

Description

proxsmtp - multi purpose SMTP Proxy

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: proxsmtp
Package version: 1.10
Package release: 2.1
Package architecture: amd64
Package type: deb
Installed size: 120 B
Download size: 31.86 KB
Official Mirror: archive.ubuntu.com
ProxSMTP is a flexible tool that allows you to reject, change or log email based on arbitrary critera. It accepts SMTP connections and forwards the SMTP commands and responses to another SMTP server. The 'DATA' email body is intercepted and filtered before forwarding. You need to be able to write the filtering scripts that integrate it with your particular needs. If you're looking for something that does virus filtering, take a look at ClamSMTP which behaves similarly and uses a similar code base. You do not need a local mail-transport-agent installed, since this server can forward to a remote one.

Alternatives

    Download

    Source package: proxsmtp

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install proxsmtp deb package:
      # sudo apt-get install proxsmtp

    Files

    • /etc/init.d/proxsmtp
    • /usr/sbin/proxsmtpd
    • /usr/share/doc/proxsmtp/README.Debian
    • /usr/share/doc/proxsmtp/changelog.Debian.gz
    • /usr/share/doc/proxsmtp/copyright
    • /usr/share/doc/proxsmtp/examples/proxsmtpd.conf
    • /usr/share/man/man5/proxsmtpd.conf.5.gz
    • /usr/share/man/man8/proxsmtpd.8.gz

    Changelog

    2014-06-06 - Chen Baozi <baozich@gmail.com> proxsmtp (1.10-2.1) unstable; urgency=low * Non-maintainer upload. * Use dh-autoreconf in build to support new architectures (Closes: #727949)

    2012-12-07 - Frank Lichtenheld <djpig@debian.org> proxsmtp (1.10-2) unstable; urgency=low * QA upload. * Change maintainer to QA group. * Bump debhelper compat level to 9 to get dpkg-buildflags support. * Fix potential buffer overflow identified by compiler. Does not look exploitable to me.

    2011-11-03 - Pierre Habouzit <madcoder@debian.org> proxsmtp (1.10-1) unstable; urgency=low * New upstream release. * Rebuilding the package closes: 643260.

    2011-03-19 - Pierre Habouzit <madcoder@debian.org> proxsmtp (1.9-1) unstable; urgency=low * New upstream release: + detect netfilter header properly (Closes: LP#694463). + Bump standards versions to 3.9.1. * Packaging updates: + Switch to source format v3 (quilt): + rename README.packaging as README.source. + Move to debhelper 8. * Add missing $remote_fs in proper LSB Headers (thanks lintian). * add libcap-dev to build-depends to enable capabilities features.

    2009-11-08 - Pierre Habouzit <madcoder@debian.org> proxsmtp (1.8-1) unstable; urgency=low * New upstream release (Upstream repacked with the .svn cruft removed). * Migrate away from cdbs to dh7. * Create /var/run/proxsmtp from the init script rather than the .deb.

    2007-01-02 - Pierre Habouzit <madcoder@debian.org> proxsmtp (1.6-1) unstable; urgency=low * New upstream release [ Packaging ] * bump Standards-Version to 3.7.2. * make the init script lsb-friendly.

    2006-01-14 - Pierre Habouzit <madcoder@debian.org> proxsmtp (1.3-1) unstable; urgency=medium * New upstream release. * Urgency set to medium since the new release addresses a lot of potentially critical problems in a mail queue.

    2005-07-11 - Pierre Habouzit <madcoder@debian.org> proxsmtp (1.2.1-1) unstable; urgency=low * Initial Release (closes: #317751).

    Advertisement
    Advertisement