prolog-el_1.25-2_all.deb


Advertisement

Description

prolog-el - Emacs major mode for editing Prolog code

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: prolog-el
Package version: 1.25
Package release: 2
Package architecture: all
Package type: deb
Installed size: 230 B
Download size: 36.25 KB
Official Mirror: archive.ubuntu.com
This is a replacement for the standard emacs prolog mode. It comes with all the features you would expect, including syntax highlighting, auto indent, and full interaction with an inferior Prolog process. This mode supports in principle any Prolog system, though it is primarily maintained for SWI Prolog. It also has some special tweaks for GNU Prolog and SICStus Prolog, and explicitly supports Prolog's close relatives Eclipse and Mercury.

Alternatives

Requires

    Download

    Binary package: prolog-el_1.25-2_all.deb
    Source package: prolog-el

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install prolog-el deb package:
      # sudo apt-get install prolog-el

    Files

    • /etc/emacs/site-start.d/50prolog-el.el
    • /usr/lib/emacsen-common/packages/install/prolog-el
    • /usr/lib/emacsen-common/packages/remove/prolog-el
    • /usr/share/doc/prolog-el/README.Debian
    • /usr/share/doc/prolog-el/changelog.Debian.gz
    • /usr/share/doc/prolog-el/copyright
    • /usr/share/emacs/site-lisp/prolog-el/prolog.el

    Changelog

    2014-07-08 - Philipp Benner <philipp@debian.org> prolog-el (1.25-2) unstable; urgency=low * Removed dependency on emacs23 (Closes: #754035). * Standards version 3.9.5. * Updated Vcs fields.

    2013-05-01 - Philipp Benner <philipp@debian.org> prolog-el (1.25-1) unstable; urgency=low * New upstream version.

    2013-01-27 - Philipp Benner <philipp@debian.org> prolog-el (1.24-2) unstable; urgency=low * debian/prolog-el.emacsen-startup: Removed source-dir from load-path (Closes: #689190). * Standards version 3.9.4.

    2012-09-29 - Philipp Benner <philipp@debian.org> prolog-el (1.24-1) unstable; urgency=low * New upstream version.

    2012-03-12 - Philipp Benner <philipp@debian.org> prolog-el (1.23-1) unstable; urgency=low * New upstream version.

    2012-03-11 - Philipp Benner <philipp@debian.org> prolog-el (1.22-4) unstable; urgency=low * debian/prolog-el.emacsen-install: Create symlink with -f (Closes: #663443).

    2012-03-04 - Philipp Benner <philipp@debian.org> prolog-el (1.22-3) unstable; urgency=low * debian/control: standards version 3.9.3. * prolog-el.emacsen-install: use debian-pkg-add-load-path-item (Closes: #653245). * prolog-el.emacsen-install: create symlinks in elc directory to source files (Closes: #653247).

    2011-11-13 - Philipp Benner <philipp@debian.org> prolog-el (1.22-2) unstable; urgency=low * debian/control: depends on emacs23, standards version 3.9.2. * debian/rules: added missing recommended targets.

    2009-10-31 - Philipp Benner <philipp@debian.org> prolog-el (1.22-1) unstable; urgency=low * New upstream release.

    2009-10-01 - Philipp Benner <philipp@debian.org> prolog-el (1.21-1) unstable; urgency=low * New upstream release.

    Advertisement
    Advertisement