proftpd-mod-pgsql_1.3.5a-1build1_amd64.deb


Advertisement

Description

proftpd-mod-pgsql - Versatile, virtual-hosting FTP daemon - PostgreSQL module

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: proftpd-mod-pgsql
Package version: 1.3.5a
Package release: 1build1
Package architecture: amd64
Package type: deb
Installed size: 491 B
Download size: 12.28 KB
Official Mirror: archive.ubuntu.com
ProFTPD is a powerful modular FTP/SFTP/FTPS server. This File Transfer Protocol daemon supports also hidden directories, virtual hosts, and per-directory ".ftpaccess" files. It uses a single main configuration file, with a syntax similar to Apache. Because of the advanced design, anonymous-FTP directories can have an arbitrary internal structure (bin, lib, etc, and special files are not needed). Advanced features such as multiple password files and upload/download ratios are also supported. This package provides PostgreSQL based authentication.

Alternatives

    Download

    Source package: proftpd-dfsg

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install proftpd-mod-pgsql deb package:
      # sudo apt-get install proftpd-mod-pgsql

    Files

    • /usr/lib/proftpd/mod_sql_postgres.so
    • /usr/share/doc/proftpd-mod-pgsql/NEWS.Debian.gz
    • /usr/share/doc/proftpd-mod-pgsql/changelog.Debian.gz
    • /usr/share/doc/proftpd-mod-pgsql/copyright

    Changelog

    2016-04-05 - Robie Basak <robie.basak@ubuntu.com> proftpd-dfsg (1.3.5a-1build1) xenial; urgency=medium * Rebuild against libmysqlclient20.

    2016-01-27 - Francesco Paolo Lovergine <frankie@debian.org> proftpd-dfsg (1.3.5a-1) unstable; urgency=medium * New upstream release. Patch CVE-2015-3306 merged. * Patches refreshed.

    2015-04-23 - Francesco Paolo Lovergine <frankie@debian.org> proftpd-dfsg (1.3.5-2) unstable; urgency=high * proftpd-dev: Depend on libtool-bin: merged NMU, thanks Doko. (closes: #761795) * Add CVE-2015-3306 patch. Unauthenticated copying of files via SITE CPFR/CPTO allowed by mod_copy. (closes: #782781)

    2014-06-13 - Francesco Paolo Lovergine <frankie@debian.org> proftpd-dfsg (1.3.5-1) unstable; urgency=medium * New upstream release. Patch 4044 merged.

    2014-04-29 - Francesco Paolo Lovergine <frankie@debian.org> proftpd-dfsg (1.3.5~rc4-3) unstable; urgency=medium * Fixed postinst for invalid usermod call. * New patch added to fix upstream bug #4044. This fix now allows using a proper reload instead of a restart in the init script. (closes: #594449, #675081) * The previous change for the start-stop-daemon appears invalid, so changed a bit timings to possibly allow proper stops under heavy loads.

    2014-02-06 - Francesco Paolo Lovergine <frankie@debian.org> proftpd-dfsg (1.3.5~rc4-2) unstable; urgency=medium * Now using /run instead of /var/run for state directory. (closes: #699798) * Revised debconf config to explicitly set default. (closes: #707689) * Revised (again) --retry flag for start-stop-daemon in order to fix long delays in stopping the daemon. (closes: #675081, #721201)

    2014-01-30 - Francesco Paolo Lovergine <frankie@debian.org> proftpd-dfsg (1.3.5~rc4-1) unstable; urgency=low * New upstream pre-release, with fix for CVE-2013-4359 aka proftpd#3973. (closes: #723179) * Included fix by Andreas Beckmann: - Cleanup Breaks+Replaces. - Add proftpd-mod-geoip.preinst script to delete the old buggy postrm script on upgrades from wheezy. Otherwise the buggy postrm script would delete some files from the newly unpacked package. (closes: #699647) * Refreshed patchset.

    2014-01-26 - Andreas Beckmann <anbe@debian.org> proftpd-dfsg (1.3.5~rc3-2.2) unstable; urgency=medium * Non-maintainer upload. * Cleanup Breaks+Replaces. * Add proftpd-mod-geoip.preinst script to delete the old buggy postrm script on upgrades from wheezy. Otherwise the buggy postrm script would delete some files from the newly unpacked package. (Closes: #699647)

    2013-10-05 - Salvatore Bonaccorso <carnil@debian.org> proftpd-dfsg (1.3.5~rc3-2.1) unstable; urgency=low * Non-maintainer upload. * Add CVE-2013-4359.patch patch. CVE-2013-4359: Fix invalid pool authentication in mod_sftp/mod_sftp_pam during kbdint authentication leading to DoS conditions. (Closes: #723179) * Correct Breaks and Replaces on proftpd-mod-geoip package. The old proftpd-mod-geoip addon module is now obsoleted by core proftpd. Adjusted the Breaks/Replaces to 1.3.5~rc1-1 which introduced the geoip module in proftpd core. Thanks to Andreas Beckmann <anbe@debian.org> (Closes: #699647)

    2013-07-03 - Francesco Paolo Lovergine <frankie@debian.org> proftpd-dfsg (1.3.5~rc3-2) unstable; urgency=low * Added version for dependency on memcached, for completeness. (closes: #699514) * The old proftpd-mod-geoip addon module is now onbsoleted by core proftpd, so required Breaks/Replaces are provided to avoid piuparts breakages. (closes: #699647) * Modified modules.conf template to suggest the geoip module.

    Advertisement
    Advertisement