procserv_2.6.0-1_amd64.deb


Advertisement

Description

procserv - Process server with telnet console and log access

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: procserv
Package version: 2.6.0
Package release: 1
Package architecture: amd64
Package type: deb
Installed size: 209 B
Download size: 133.51 KB
Official Mirror: archive.ubuntu.com
procServ is a wrapper that starts an arbitrary command as a child process in the background, connecting its standard input and output to a TCP port for telnet access. It supports logging, child restart (manual or automatic on exit), and more. procServ does not have the rich feature set of the screen utility, but is intended to provide running a command in a system service style, in a small, robust way. Handling multiple users, authorization, authentication, central logging is done best on a higher level, using a package like conserver. For security reasons, procServ only accepts connections from localhost.

Alternatives

    Download

    Source package: procserv

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install procserv deb package:
      # sudo apt-get install procserv

    Files

    • /usr/bin/procServ
    • /usr/share/doc/procserv/AUTHORS
    • /usr/share/doc/procserv/NEWS.gz
    • /usr/share/doc/procserv/README
    • /usr/share/doc/procserv/changelog.Debian.gz
    • /usr/share/doc/procserv/copyright
    • /usr/share/doc/procserv/procServ.html
    • /usr/share/doc/procserv/procServ.pdf.gz
    • /usr/share/doc/procserv/procServ.txt.gz
    • /usr/share/man/man1/procServ.1.gz

    Changelog

    2012-04-13 - Ralph Lange <Ralph.Lange@gmx.de> procserv (2.6.0-1) unstable; urgency=low * new upstream version * control: bumped Standards-Version to 3.9.3 with no changes, fixed debhelper dependency, added libtelnet dependency * copyright: changed to machine readable format, added libtelnet info * rules: switched to using overrides

    2010-03-24 - Ralph Lange <Ralph.Lange@bessy.de> procserv (2.5.1-1) unstable; urgency=low * new upstream version * copyright: corrected years * control: bumped Standards-Version to 3.8.4 with no changes * rules: changed from CDBS based rules to plain debhelper+dh

    2010-01-04 - Ralph Lange <Ralph.Lange@bessy.de> procserv (2.5.0-5) unstable; urgency=low * rules: build package in "." (default) to prevent CDBS from generating strange warnings and running the configure script twice * control: added Vcs-* entries pointing to the collab-maint repository * Added a watch file pointing to the SourceForge download

    2009-12-31 - Ralph Lange <Ralph.Lange@bessy.de> procserv (2.5.0-4) unstable; urgency=low * control: package now Suggests: telnet * removed .hg* stuff from package build

    2009-12-30 - Ralph Lange <Ralph.Lange@bessy.de> procserv (2.5.0-3) unstable; urgency=low * control: added ${misc:Depends} for debhelper

    2009-12-29 - Ralph Lange <Ralph.Lange@bessy.de> procserv (2.5.0-2) unstable; urgency=low * control: removed unused Depends, changed Section and Priority, updated Description * rules: simplified by adding extra argument to configure to change doc location

    2009-12-15 - Michael Davidsaver <mdavidsaver@bnl.gov> procserv (2.5.0-1) unstable; urgency=low * New Upstream Version

    2009-10-21 - Michael Davidsaver <mdavidsaver@bnl.gov> procserv (2.4.1-1) unstable; urgency=low * version bump

    2009-08-28 - Michael Davidsaver <mdavidsaver@bnl.gov> procserv (2.4.0-1) unstable; urgency=low * Initial release

    Advertisement
    Advertisement