prips_0.9.9-1_amd64.deb


Advertisement

Description

prips - tool that prints the IP addresses in a given range

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: prips
Package version: 0.9.9
Package release: 1
Package architecture: amd64
Package type: deb
Installed size: 68 B
Download size: 11.19 KB
Official Mirror: archive.ubuntu.com
prips can be used to print all of the IP addresses in a given range. This allows the enhancement of tools only work on one host at a time (e.g. whois).

Alternatives

Requires

    Download

    Binary package: prips_0.9.9-1_amd64.deb
    Source package: prips

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install prips deb package:
      # sudo apt-get install prips

    Files

    • /usr/bin/prips
    • /usr/share/doc/prips/CONTRIBUTORS
    • /usr/share/doc/prips/README
    • /usr/share/doc/prips/changelog.Debian.gz
    • /usr/share/doc/prips/copyright
    • /usr/share/man/man1/prips.1.gz

    Changelog

    2011-03-10 - Peter Pentchev <roam@ringlet.net> prips (0.9.9-1) unstable; urgency=low * New upstream release to fix a possible infinite loop in getopt() on systems where char is unsigned.

    2011-03-01 - Peter Pentchev <roam@ringlet.net> prips (0.9.8-1) unstable; urgency=low * New upstream release. * Reword the short and long descriptions. * Refresh the copyright file: - note the new upstream copyright years - update to the latest DEP 5 candidate format - bump the year on my debian/* copyright notice * Upload to unstable.

    2010-12-25 - Peter Pentchev <roam@ringlet.net> prips (0.9.7-2) experimental; urgency=low * Switch to Git and point the Vcs-* fields to Gitorious. * Bump Standards-Version to 3.9.1 with no changes. * Switch to bzip2 compression for the Debian tarball. * Use hardening-includes instead of hardening-wrapper so that the hardening flags are visible in CFLAGS and LDFLAGS. * Bump the debhelper compatibility level to 8 with no changes.

    2010-06-30 - tony mancill <tmancill@debian.org> prips (0.9.7-1) unstable; urgency=low [ Peter Pentchev ] * Bump Standards-Version to 3.9.0 with no changes. * Convert to the 3.0 (quilt) source format with no changes. * Use dpkg-buildflags from dpkg-dev 1.15.7 to obtain the default values for CFLAGS, CPPFLAGS, and LDFLAGS. * New upstream release: - actually honor CPPFLAGS and LDFLAGS :) * Update the copyright file: - reflect the Makefile and main.c copyright years bump - update to the latest revision of the DEP 5 format - bump the year on my debian/* copyright notice - break out the GPL-2+ blurb into a separate section * Shorten the Vcs-Browser URL. [ tony mancill ] * Set DM-Upload-Allowed in debian/control so Peter can upload as a DM. * Add myself to Uploaders: field.

    2009-04-04 - Peter Pentchev <roam@ringlet.net> prips (0.9.6-1) unstable; urgency=low * New upstream release.

    2009-03-27 - Peter Pentchev <roam@ringlet.net> prips (0.9.5-1) unstable; urgency=low * New maintainer. Closes: #519379 * Fix the date format of the 0.9.4-3 changelog entry. Closes: #497429 * Move the debhelper compatibility version to debian/compat. * Add a watch file. * Add the Homepage, Vcs-Svn, and Vcs-Browser control fields. * Convert the copyright file to the machine-parseable format and add some copyright notices for the Debian packaging. * Bump the debhelper compatibility level to 7: - add ${misc:Depends} to the binary package * Bump Standards-Version to 3.8.1: - the new version honors our CFLAGS, thus honoring DEB_BUILD_OPTIONS * Use dh_install to install the prips binary. * Minimize the rules file using debhelper 7's dh(1) utility. * New upstream version - actually, I adopted the package: - remove all the Debian patches - some of them were integrated upstream, and the cidr_lp64 one was overtaken by the uint32_t change - remove the manpage - integrated upstream, rewritten as mdoc(7) and fleshed out a bit - remove README.Debian - the upstream has a manpage now :) * Use build hardening by default, disabled by the "nohardening" option. * Use the -Werror compiler flag if the "werror" option is present.

    2007-07-01 - Robert S. Edmonds <edmonds@debian.org> prips (0.9.4-3.1) unstable; urgency=low * Non-maintainer upload. * Fix CIDR calculations on LP64 architectures, closes: #401709.

    2003-08-23 - Juan Alvarez <jalvarez@fluidsignal.com> prips (0.9.4-3) unstable; urgency=low * Fix multiline string. Closes: #195017 * Patches are now applied with dpatch. * Install the new manpage from dpatch. * Leave the Makefile clean and install the binaries from debian/rules. * Update Standards-Version to 3.6.0

    2002-02-25 - Juan Alvarez <jalvarez@fluidsignal.com> prips (0.9.4-2) unstable; urgency=low * Change description according to the suggestions of Christian Kurz <shorty@debian.org>. Closes: #135527 * Change Juan Rafael Alvarez Correa to Juan Alvarez in all the files.

    Advertisement
    Advertisement