printer-driver-escpr_1.6.3-2_amd64.deb


Advertisement

Description

printer-driver-escpr - printer driver for Epson Inkjet that use ESC/P-R

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: printer-driver-escpr
Package version: 1.6.3
Package release: 2
Package architecture: amd64
Package type: deb
Installed size: 445 B
Download size: 247.30 KB
Official Mirror: archive.ubuntu.com
ESC/P-R is a common language for selected Epson printers that supports every media type, paper size and associated printing mode available on those printers. It is suited especially for consumer electronics devices and embedded equipments. ESC/P-R allows many kinds of devices to connect and communicate with Epson inkjet printers, expanding possibilities for use with medical equipment, measuring equipment, electronic whiteboards, and at home with home electronics and game machines. This package contains the CUPS filter driver and the compressed PPDs for the supported printers.

Alternatives

Replaces

  • epson-escpr << 1.1.0-1~

    Download

    Source package: epson-inkjet-printer-escpr

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install printer-driver-escpr deb package:
      # sudo apt-get install printer-driver-escpr

    Files

    • /usr/lib/cups/driver/escpr
    • /usr/lib/cups/filter/epson-escpr
    • /usr/lib/cups/filter/epson-escpr-wrapper
    • /usr/lib/printer-driver-escpr/libescpr.so.1
    • /usr/lib/printer-driver-escpr/libescpr.so.1.0.0
    • /usr/share/cups/ppd-updaters/printer-driver-escpr.ppd-updater
    • /usr/share/doc/printer-driver-escpr/changelog.Debian.gz
    • /usr/share/doc/printer-driver-escpr/copyright

    Changelog

    2016-02-23 - Didier Raboud <odyx@debian.org> epson-inkjet-printer-escpr (1.6.3-2) unstable; urgency=medium [ Logan Rosen ] * Add patch to include xfifo.h in src/filter.c to fix implicit function declaration

    2016-02-17 - Didier Raboud <odyx@debian.org> epson-inkjet-printer-escpr (1.6.3-1) unstable; urgency=medium * New 1.6.3 upstream release - Supported new models - For some models, we changed the ppd description, "*DefaultMediaType" from PLAIN_DRAFT to PLAIN_NORMAL - For some models, we added PLAIN_NORMAL and ENV_NORMAL as media type - Added ppd files of following models - PM-400 Series - L805 Series - WF-6530 Series - EP-10VA Series - PX-M860F - PX-S860 - WP-M4011 Series - WP-M4015 Series - WP-M4095 Series - WP-M4521 Series - WP-M4525 Series - WP-M4595 Series - Speeding up of multiple page printing * Refresh copyright file * Try harder to merge upstream versions with a debian/ directory

    2015-09-26 - Didier Raboud <odyx@debian.org> epson-inkjet-printer-escpr (1.5.2-1) unstable; urgency=medium * New 1.5.2 upstream release - Added ppd files of following models - EP-808A Series - EP-978A3 Series - PF-81 Series - ET-2500 Series - ET-2550 Series - ET-4500 Series - ET-4550 Series - Supported following options - Brightness - Contrast - Saturation - Updated ESC/P-R library to version 5.4 * Update get-orig-source target to be more tolerant

    2015-07-09 - Didier Raboud <odyx@debian.org> epson-inkjet-printer-escpr (1.4.5-1) unstable; urgency=medium * New 1.4.5 upstream version - Added ppd files of following model series: L565, L566, L810, L850, WF-M5690, WF-M5190, PF-70, PX-M350F, and PX-S350 - Fixed a problem when using "Rear Feed Slot" as InputSlot - Added Postcard size for model series: WF-100 and PX-S05 * Bump Standards-Version to 3.9.6 without changes needed * Add gbp.conf * Remove patch that was an upstream backport

    2014-11-26 - Didier Raboud <odyx@debian.org> epson-inkjet-printer-escpr (1.4.1-2) unstable; urgency=medium * Backport the 1.4.4 change: - Fixed a problem when using "Rear Feed Slot" as InputSlot (Closes: #755408)

    2014-07-28 - Didier Raboud <odyx@debian.org> epson-inkjet-printer-escpr (1.4.1-1) unstable; urgency=medium * New 1.4.1 upstream version * Add autopkgtest suite

    2014-03-21 - Didier Raboud <odyx@debian.org> epson-inkjet-printer-escpr (1.4.0-1) unstable; urgency=medium * New 1.4.0 upstream version (Closes: #742264) - Fixed a duplex printing bug which is reversed Long Edge and Short Edge

    2014-03-05 - Didier Raboud <odyx@debian.org> epson-inkjet-printer-escpr (1.3.0-2) unstable; urgency=medium * Move the repository from collab-maint to printing; update the VCS-* fields accordingly

    2013-11-29 - Didier Raboud <odyx@debian.org> epson-inkjet-printer-escpr (1.3.0-1) unstable; urgency=low * New 1.3.0 upstream version * Bump Standards-Version to 3.9.5 without changes needed * Drop epson-escpr transitional package which reached stable

    2013-11-01 - Didier Raboud <odyx@debian.org> epson-inkjet-printer-escpr (1.2.3-3) unstable; urgency=low * Rebuild against pyppd >= 1.0.1-2~

    Advertisement
    Advertisement