predict_2.2.3-4build1_amd64.deb


Advertisement

Description

predict - Satellite Tracking Program with Optional Voice Output

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: predict
Package version: 2.2.3
Package release: 4build1
Package architecture: amd64
Package type: deb
Installed size: 1.86 KB
Download size: 732.04 KB
Official Mirror: archive.ubuntu.com
This is a satellite tracking program. It is probably mostly of interest to users of amateur satellites, but includes support for optionally announcing azimuth and elevation to help in manual antenna pointing, or optical observation of satellites. The upstream predict sources include a front-end called 'map', which is called predict-map in the Debian package. The 'ntp' package is suggested because accurate satellite tracking depends on precise knowledge of ground station time and location.

Alternatives

    Download

    Source package: predict

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install predict deb package:
      # sudo apt-get install predict

    Files

    • /etc/fodtrack.conf
    • /usr/bin/earthtrack
    • /usr/bin/fodtrack
    • /usr/bin/geosat
    • /usr/bin/kep_reload
    • /usr/bin/moontracker
    • /usr/bin/predict
    • /usr/bin/predict-g1yyh
    • /usr/lib/predict/alarm.wav
    • /usr/lib/predict/approaching.wav
    • /usr/lib/predict/azimuth.wav
    • /usr/lib/predict/eclipse.wav
    • /usr/lib/predict/eight.wav
    • /usr/lib/predict/eighteen.wav
    • /usr/lib/predict/eighty.wav
    • /usr/lib/predict/elevation.wav
    • /usr/lib/predict/eleven.wav
    • /usr/lib/predict/fifteen.wav
    • /usr/lib/predict/fifty.wav
    • /usr/lib/predict/five.wav
    • /usr/lib/predict/forty.wav
    • /usr/lib/predict/four.wav
    • /usr/lib/predict/fourteen.wav
    • /usr/lib/predict/hundred.wav
    • /usr/lib/predict/intro.wav
    • /usr/lib/predict/los.wav
    • /usr/lib/predict/nine.wav
    • /usr/lib/predict/nineteen.wav
    • /usr/lib/predict/ninety.wav
    • /usr/lib/predict/one.wav
    • /usr/lib/predict/receding.wav
    • /usr/lib/predict/seven.wav
    • /usr/lib/predict/seventeen.wav
    • /usr/lib/predict/seventy.wav
    • /usr/lib/predict/six.wav
    • /usr/lib/predict/sixteen.wav
    • /usr/lib/predict/sixty.wav
    • /usr/lib/predict/sunlight.wav
    • /usr/lib/predict/ten.wav
    • /usr/lib/predict/thirteen.wav
    • /usr/lib/predict/thirty.wav
    • /usr/lib/predict/three.wav
    • /usr/lib/predict/twelve.wav
    • /usr/lib/predict/twenty.wav
    • /usr/lib/predict/two.wav
    • /usr/lib/predict/visible.wav
    • /usr/lib/predict/vocalizer
    • /usr/lib/predict/zero.wav
    • /usr/lib/predict/default/predict.db
    • /usr/lib/predict/default/predict.qth
    • /usr/lib/predict/default/predict.tle
    • /usr/share/doc/predict/CREDITS
    • /usr/share/doc/predict/HISTORY
    • /usr/share/doc/predict/NEWS.gz
    • /usr/share/doc/predict/README
    • /usr/share/doc/predict/README.Debian
    • /usr/share/doc/predict/README.geosat
    • /usr/share/doc/predict/changelog.Debian.gz
    • /usr/share/doc/predict/copyright
    • /usr/share/doc/predict/kepupdate
    • /usr/share/man/man1/earthtrack.1.gz
    • /usr/share/man/man1/geosat.1.gz
    • /usr/share/man/man1/kep_reload.1.gz
    • /usr/share/man/man1/moontracker.1.gz
    • /usr/share/man/man1/predict-g1yyh.1.gz
    • /usr/share/man/man1/predict.1.gz
    • /usr/share/man/man5/fodtrack.conf.5.gz
    • /usr/share/man/man8/fodtrack.8.gz

    Changelog

    2016-02-07 - Matthias Klose <doko@ubuntu.com> predict (2.2.3-4build1) xenial; urgency=medium * No-change rebuild for ncurses6 transition.

    2013-09-29 - Bdale Garbee <bdale@gag.com> predict (2.2.3-4) unstable; urgency=low * fix FTBFS through application of blunt force to gsat's Makefile.am, closes: #713687

    2011-12-06 - gregor herrmann <gregoa@debian.org> predict (2.2.3-3.1) unstable; urgency=low * Non-maintainer upload. * Fix "ftbfs with gold or ld --no-add-needed": add patch from Ubuntu / John T. Nogatch (move -lm to the end of the lines in debian/rules). Change the order of some more cc invocations. (Closes: #615766, LP: #770815)

    2010-05-27 - A. Maitland Bottoms <bottoms@debian.org> predict (2.2.3-3) unstable; urgency=low * Update for libforms2 (Closes: #583174) * debian/compat set to 7. * Bump Standards Version to 3.8.4. * man page is OK, don't include predict.txt.gz (Closes: #429049) * Include patches from Ubuntu (Closes: #576087, #576365) * debian/patched/140_fix-buffer-overflow.diff: Fix buffer overflow on launching with -s (patch from Norvald H. Ryeng) * debian/patches/141_buffer_overflow.diff: Fix a buffer overflow that makes predict-g1yyh crash when printing predictions (p, v, s, n and o commands). Patch courtesy of Norvald H. Ryeng * debian/patches/180_reworked_gui.diff: resizes and repositions widgets after GTK2 changes. Patch courtesy of Norvald H. Ryeng

    2009-11-15 - A. Maitland Bottoms <bottoms@debian.org> predict (2.2.3-2) unstable; urgency=low * Acknowledge NMU - Barry deFreese's change to quilt and general bug fixing (Closes: #429055, #437790, #515432) * build gsat with current config.sub and config.guess files * Lintian fixes, minimize .diff size

    2009-03-12 - Barry deFreese <bdefreese@debian.org> predict (2.2.3-1.1) unstable; urgency=low * Non-maintainer upload. * Add quilt patch system. + Move existing inline changes to quilt. * Build with Gtk2. (Closes: #515432). * Install defaults in proper location. (Closes: #429055). + Thanks to Timo Lindfors for the fix. * Don't strip on build. (Closes: #437790). + Thanks to Timo Lindfors for the fix. * Make clean not ignore errors. * Bump debhelper build-dep to >> 5.0.0. * Move DH_COMPAT from rules to debian/compat and set to 5. * Bump Standards Version to 3.8.3.

    2006-08-05 - A. Maitland Bottoms <bottoms@debian.org> predict (2.2.3-1) unstable; urgency=low * New upstream release * New predict-g1yyh is predict-2.2.1jh4.c * Acknowledge NMU, fix X build, update standards version * mention predict-map in description (Closes: #379731)

    2006-07-31 - Margarita Manterola <marga@debian.org> predict (2.2.2-6.1) unstable; urgency=low * Non-Maintainer Upload to fix Failure to Build From Source due to a change in the location of forms.h. Thanks to Luca Bruno for the patch. (Closes: #379495).

    2005-09-11 - A. Maitland Bottoms <bottoms@debian.org> predict (2.2.2-6) unstable; urgency=low * Correct errno use in gsat application (Closes: #326399) * Define _XOPEN_SOURCE for correctly using Unix98 pty support function ptsname() in fodtrack utility (Closes: #326396)

    2005-04-02 - A. Maitland Bottoms <bottoms@debian.org> predict (2.2.2-5) unstable; urgency=low * earthtrack uses the full option name -projection to invoke xplanet necessary since xplanet 1.1.2 no longer uses -proj

    Advertisement
    Advertisement