prboom-plus_2.5.1.5~svn4462+dfsg1-1_amd64.deb


Advertisement

Description

prboom-plus - enhanced clone of the classic first-person shooter Doom

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe amd64
Package name prboom-plus
Package version 2.5.1.5~svn4462+dfsg1
Package release 1
Package architecture amd64
Package type deb
Installed size 1.78 KB
Download size 696.14 KB
Official Mirror archive.ubuntu.com
PrBoom+ is an enhanced source port of the classic 3D first-person
shooter game Doom, first released by id Software in 1993. It uses
the Simple Direct Media layer (SDL) library and features an optional
OpenGL renderer. It is based on PrBoom, MBF and LxDoom, which in turn
are based on TeamTNT's Boom, a freely available port of Doom for DOS.
In addition to PrBoom's features, PrBoom+ offers uncapped framerate,
variable gamespeed, re-record, walkcam, chasecam, full mouselook,
FOV, and other features without loss of compatibility with the
original Doom.
PrBoom+ requires game data to run. Free game data is available in the
freedoom package. Commercial game data can be packaged using
game-data-packager. PrBoom+ supports all flavors of Doom, including
The Ultimate Doom, Doom 2 and Final Doom as well as Chex(R) Quest, HACX,
FreeDoom and FreeDM.

Alternatives

Package Version Architecture Repository
prboom-plus_2.5.1.5~svn4462+dfsg1-1_i386.deb 2.5.1.5~svn4462+dfsg1 i386 Ubuntu Universe
prboom-plus - - -

Requires

Name Value
libc6 >= 2.15
libdumb1 -
libfluidsynth1 -
libgl1 -
libgl1-mesa-glx -
libglu1 -
libglu1-mesa -
libmad0 >= 0.15.1b-3
libpcre3 -
libpng12-0 >= 1.2.13-4
libportmidi0 -
libsdl-image1.2 >= 1.2.10
libsdl-mixer1.2 -
libsdl-net1.2 -
libsdl1.2debian >= 1.2.11
libvorbisfile3 >= 1.1.2

Provides

Name Value
boom-engine -
doom-engine -

Replaces

Name Value
prboom << 2:2.5.1.4~svn4425+dfsg1-2~

Download

Type URL
Binary Package prboom-plus_2.5.1.5~svn4462+dfsg1-1_amd64.deb
Source Package prboom-plus

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install prboom-plus deb package:
    # sudo apt-get install prboom-plus

Files

Path
/usr/games/prboom-plus
/usr/share/applications/prboom-plus.desktop
/usr/share/bash-completion/completions/prboom-plus
/usr/share/doc-base/prboom-plus
/usr/share/doc/prboom-plus/AUTHORS.gz
/usr/share/doc/prboom-plus/MBF.txt.gz
/usr/share/doc/prboom-plus/MBFFAQ.txt.gz
/usr/share/doc/prboom-plus/README.compat
/usr/share/doc/prboom-plus/README.demos
/usr/share/doc/prboom-plus/README.gz
/usr/share/doc/prboom-plus/TODO.gz
/usr/share/doc/prboom-plus/boom.txt.gz
/usr/share/doc/prboom-plus/changelog.Debian.gz
/usr/share/doc/prboom-plus/copyright
/usr/share/doc/prboom-plus/prboom-plus-history.html
/usr/share/doc/prboom-plus/prboom-plus-history.txt.gz
/usr/share/doc/prboom-plus/prboom-plus-usage.txt.gz
/usr/share/games/doom/prboom-plus.wad
/usr/share/icons/hicolor/scalable/apps/prboom-plus.svg
/usr/share/man/man5/prboom-plus.cfg.5.gz
/usr/share/man/man6/prboom-plus.6.gz

Changelog

2016-01-24 - Fabian Greffrath <fabian@debian.org>
prboom-plus (2:2.5.1.5~svn4462+dfsg1-1) unstable; urgency=medium
* Imported Upstream version 2.5.1.5~svn4462+dfsg1
+ This includes the 2.5.1.4 upstream release (r4459).
* Restrict Build-Depends on libportmidi-dev to [linux-any].
* Refresh patches.
2015-11-30 - Fabian Greffrath <fabian@debian.org>
prboom-plus (2:2.5.1.4~svn4457+dfsg1-1) unstable; urgency=medium
* Imported Upstream version 2.5.1.4~svn4457+dfsg1
2015-10-28 - Fabian Greffrath <fabian@debian.org>
prboom-plus (2:2.5.1.4~svn4454+dfsg1-1) unstable; urgency=medium
* Imported Upstream version 2.5.1.4~svn4454+dfsg1
* Install bash-completion snippet.
* Remove debian/patches/remove_google_adsense.patch,
applied upstream.
2015-09-29 - Fabian Greffrath <fabian@debian.org>
prboom-plus (2:2.5.1.4~svn4444+dfsg1-1) unstable; urgency=medium
* Imported Upstream version 2.5.1.4~svn4444+dfsg1
* Replace obsolete upstream version number with the
Debian packaging version number.
* Install prboom-plus.desktop file and SVG icon provided by upstream.
* Drop Debian menu file and icons in PNG and XPM format.
2015-09-21 - Fabian Greffrath <fabian@debian.org>
prboom-plus (2:2.5.1.4~svn4433+dfsg1-1) unstable; urgency=medium
* New upstream SVN snapshot.
* Do not suggest soundfonts at all, leave this to libsdl-mixer1.2.
* Register as a handler for the application/x-doom-wad MIME type.
2015-08-27 - Fabian Greffrath <fabian@debian.org>
prboom-plus (2:2.5.1.4~svn4429+dfsg1-1) unstable; urgency=medium
* New upstream SVN snapshot.
* Update Uploaders field with my Debian account.
2015-05-07 - Fabian Greffrath <fabian+debian@greffrath.com>
prboom-plus (2:2.5.1.4~svn4425+dfsg1-2) unstable; urgency=medium
* Remove the transitional "prboom" package, add Breaks and Replaces
to "prboom-plus" accordingly.
* Remove virtual packages from Recommends, mention FreeDoom and
FreeDM in the extended package description.
* Turn debian/README.source into an actual shell script, turn the package
name into a variable.
* Update source location URI and Debian packaging copyright years in
debian/copyright.
* Remove menu entry for playing prboom-plus on a VC from
debian/prboom-plus.menu.
* Only install alternatives upon "abort-upgrade" or "configure" in
debian/prboom-plus.postinst/prerm and add some more cosmetic fixes.
* Remove obsolete forced xz compression of the Debian package.
2015-04-30 - Fabian Greffrath <fabian+debian@greffrath.com>
prboom-plus (2:2.5.1.4~svn4425+dfsg1-1) unstable; urgency=medium
* New upstream SVN snapshot.
* Remove CPP timestamps to make builds reproducible.
* Remove unused "Files:" paragraph from debian/copyright.
* Add doc-base registration.
* Bump Standards-Version to 3.9.6.
* Condense Debian-specific changes to the default configuration
into a single patch.
2014-10-23 - Fabian Greffrath <fabian+debian@greffrath.com>
prboom-plus (2:2.5.1.4~svn4403+dfsg1-1) unstable; urgency=medium
* New upstream SVN snapshot
from new upstream SVN repository.
2014-05-08 - Fabian Greffrath <fabian+debian@greffrath.com>
prboom-plus (2:2.5.1.4~svn4384+dfsg1-1) unstable; urgency=medium
[ Fabian Greffrath ]
* New upstream SVN snapshot.
[ Vincent Cheng ]
* Update to Standards version 3.9.5, no changes required.

See Also

Package Description
prctl_1.6-1_amd64.deb Process control operations
predict-gsat_2.2.3-4build1_amd64.deb Graphical Satellite Tracking Client Program
predict_2.2.3-4build1_amd64.deb Satellite Tracking Program with Optional Voice Output
predictnls_1.0.20-2_all.deb prediction and analysis of protein nuclear localization signals
predictprotein_1.1.07-1_all.deb suite of protein sequence analysis tools
prelink_0.0.20130503-1.1_amd64.deb ELF prelinking utility to speed up dynamic linking
preload_0.6.4-2_amd64.deb adaptive readahead daemon
prelude-correlator_1.0.0-1.1_all.deb Security Information Management System [ Correlator ]
prelude-lml_1.0.0-5.3ubuntu2_amd64.deb Security Information Management System [ Log Agent ]
prelude-manager_1.0.1-5.1ubuntu3_amd64.deb Security Information Management System [ Manager ]
prelude-notify_0.9.1-1.1_all.deb Security Information Management System [ Desktop Notifier ]
premake4_4.3+repack1-2_amd64.deb cross-platform build script generator
prepaid-manager-applet_0.0.3.1-1_all.deb Check and top up the balance of GSM mobile prepaid SIM cards
prepair-data_0.7-4build1_all.deb polygon repair tool -- example data
prepair_0.7-4build1_amd64.deb polygon repair tool
Advertisement
Advertisement