postgresql-hll_2.7-2.1_amd64.deb


Advertisement

Description

postgresql-hll - HyperLogLog extension for PostgreSQL

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe amd64
Package name postgresql-hll
Package version 2.7
Package release 2.1
Package architecture amd64
Package type deb
Installed size 121 B
Download size 28.04 KB
Official Mirror archive.ubuntu.com
This Postgres module introduces a new data type `hll` which is a HyperLogLog
data structure. HyperLogLog is a **fixed-size**, set-like structure used for
distinct value counting with tunable precision. For example, in 1280 bytes
`hll` can estimate the count of tens of billions of distinct values with only a
few percent error.
In addition to the algorithm proposed in the original paper, this
implementation is augmented to improve its accuracy and memory use without
sacrificing much speed.
The full description can be found at
https://github.com/aggregateknowledge/postgresql-hll/blob/master/README.markdown

Alternatives

Package Version Architecture Repository
postgresql-hll_2.7-2.1_i386.deb 2.7 i386 Ubuntu Universe
postgresql-hll - - -

Requires

Name Value
libc6 >= 2.14

Download

Type URL
Binary Package postgresql-hll_2.7-2.1_amd64.deb
Source Package postgresql-hll

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install postgresql-hll deb package:
    # sudo apt-get install postgresql-hll

Files

Path
/usr/lib/postgresql/9.4/lib/hll.so
/usr/share/doc/postgresql-hll/README.markdown.gz
/usr/share/doc/postgresql-hll/changelog.Debian.gz
/usr/share/doc/postgresql-hll/copyright
/usr/share/postgresql/9.4/extension/hll--1.0.sql
/usr/share/postgresql/9.4/extension/hll.control

Changelog

2014-10-30 - YunQiang Su <syq@debian.org>
postgresql-hll (2.7-2.1) unstable; urgency=low
* Non-maintainer upload.
* Don't include postgresql-common makefile (Closes: 738376)
* Add inline with _forceinline.
* Use source format 3.
2013-04-13 - Cyril Bouthors <cyril@bouthors.org>
postgresql-hll (2.7-2) unstable; urgency=low
* Removed useless sentence in the package description (Closes: #705300).
Thanks to Jonas Smedegaard for pointing this out.
2013-02-21 - Cyril Bouthors <cyril@bouthors.org>
postgresql-hll (2.7-1) unstable; urgency=low
* Initial release (Closes: #701101).

See Also

Package Description
postgresql-mysql-fdw-doc_2.1.2-1build1_all.deb documentation for mysql-fdw
postgresql-plperl-9.5_9.5.2-1_amd64.deb PL/Perl procedural language for PostgreSQL 9.5
postgresql-plpython-9.5_9.5.2-1_amd64.deb PL/Python procedural language for PostgreSQL 9.5
postgresql-plpython3-9.5_9.5.2-1_amd64.deb PL/Python 3 procedural language for PostgreSQL 9.5
postgresql-pltcl-9.5_9.5.2-1_amd64.deb PL/Tcl procedural language for PostgreSQL 9.5
postgresql-server-dev-9.5_9.5.2-1_amd64.deb development files for PostgreSQL 9.5 server-side programming
postgresql-server-dev-all_173_all.deb extension build tool for multiple PostgreSQL versions
postgrey_1.35-1_all.deb greylisting implementation for Postfix
postmark_1.53-1_amd64.deb File system benchmark from NetApp
postnews_0.6.1-1_all.deb Post Usenet articles via NNTP from the command line
postr_0.13.1-1_all.deb upload photos to Flickr
postsrsd_1.2-1_amd64.deb Sender Rewriting Scheme (SRS) lookup table for Postfix
potool_0.16-2_amd64.deb program to aid manipulation of gettext po files
potrace_1.13-2_amd64.deb utility to transform bitmaps into vector graphics
pound_2.6-6.1_amd64.deb reverse proxy, load balancer and HTTPS front-end for Web servers
Advertisement
Advertisement