postgresql-9.5-prefix_1.2.4-1_amd64.deb


Advertisement

Description

postgresql-9.5-prefix - Prefix Range module for PostgreSQL

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: postgresql-9.5-prefix
Package version: 1.2.4
Package release: 1
Package architecture: amd64
Package type: deb
Installed size: 68 B
Download size: 17.60 KB
Official Mirror: archive.ubuntu.com
This PostgreSQL module provides the prefix_range datatype, allowing to index searches such as finding the longest prefix matching a telephone number, having prefixes in a table and telephone number as a parameter: select * from prefixes where prefix @> '0100091234'; The prefix column has to be of type prefix_range, and any text field can get indexed by the provided GiST opclass.

Alternatives

    Download

    Source package: prefix

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install postgresql-9.5-prefix deb package:
      # sudo apt-get install postgresql-9.5-prefix

    Files

    • /usr/lib/postgresql/9.5/lib/prefix.so
    • /usr/share/doc/postgresql-9.5-prefix/README.md.gz
    • /usr/share/doc/postgresql-9.5-prefix/TESTS.md.gz
    • /usr/share/doc/postgresql-9.5-prefix/changelog.Debian.gz
    • /usr/share/doc/postgresql-9.5-prefix/copyright
    • /usr/share/postgresql/9.5/extension/prefix--1.1--1.2.0.sql
    • /usr/share/postgresql/9.5/extension/prefix--1.2.0.sql
    • /usr/share/postgresql/9.5/extension/prefix--unpackaged--1.2.0.sql
    • /usr/share/postgresql/9.5/extension/prefix.control

    Changelog

    2016-01-09 - Christoph Berg <myon@debian.org> prefix (1.2.4-1) unstable; urgency=medium * New upstream version with 9.5 support.

    2014-07-27 - Christoph Berg <myon@debian.org> prefix (1.2.3-3) unstable; urgency=medium * Upload to unstable for 9.4.

    2014-07-05 - Christoph Berg <myon@debian.org> prefix (1.2.3-2) experimental; urgency=medium * B-D on pg-common 158 to build against 9.3 and 9.4. * Remove needs-root restriction from tests.

    2014-06-15 - Christoph Berg <myon@debian.org> prefix (1.2.3-1) unstable; urgency=medium * Update expected/explain_1.out (9.0 variant) for the latest changes. * Use pg_buildext installcheck. * Set team as maintainer.

    2014-01-26 - Christoph Berg <myon@debian.org> prefix (1.2.2-1) unstable; urgency=medium * New upstream release + Allows building on 9.4+. + Regression test updates. * Add make to the test dependencies.

    2013-02-26 - Christoph Berg <myon@debian.org> prefix (1.2.1-1) unstable; urgency=low * debian/rules: Use "pg_buildext loop". * Use "all" in debian/pgversions and B-D on pg-server-dev >= 148. * Add regression tests and run them using autopkgtest. * Add watch file. * Add myself to Uploaders.

    2012-10-15 - Dimitri Fontaine <dim@tapoueh.org> prefix (1.2.0-1) experimental; urgency=low [ Dimitri Fontaine ] * Fix GiST consisten function in non-leaf nodes (Closes: #690160) * Refactors as a real PostgreSQL Extension * Add explicit compatibility with PostgreSQL 9.2 and 9.3devel [ Christoph Berg ] * Add Vcs headers * Upload to experimental

    2010-03-12 - Dimitri Fontaine <dim@tapoueh.org> prefix (1.1.1-1) unstable; urgency=low * Test against 9.0 and 9.1 * Package now supports 8.3 8.4 9.0 and 9.1 out of the box (Closes: #639479) * Fix README to ORDER BY length DESC * Fix a bug in intersect code, so that 123 & 123[4-5] is 123[4-5]

    2010-01-11 - Dimitri Fontaine <dim@tapoueh.org> prefix (1.1.0-2) unstable; urgency=low * Support pgversions and pgxs_debian_control (Closes: #559610)

    2009-11-30 - Dimitri Fontaine <dim@tapoueh.org> prefix (1.1.0-1) unstable; urgency=high * Fix Btree opclass for supporting sub-ranges

    Advertisement
    Advertisement