polyglot_2.0.1+git20140926-1_amd64.deb


Advertisement

Description

polyglot - chess engine protocol adaptor, connects UCI engines to xboard

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: polyglot
Package version: 2.0.1+git20140926
Package release: 1
Package architecture: amd64
Package type: deb
Installed size: 264 B
Download size: 107.87 KB
Official Mirror: archive.ubuntu.com
Common chess frontends have a winboard/xboard input interface, modern chess engines speak the UCI "universal chess interface" protocol. This protocol adaptor makes it possible to use standard chess frontends, like xboard or scid with UCI speaking engines and play chess against them.

Alternatives

Requires

    Download

    Source package: polyglot

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install polyglot deb package:
      # sudo apt-get install polyglot

    Files

    • /usr/games/polyglot
    • /usr/share/doc-base/polyglot-book
    • /usr/share/doc/polyglot/README.Debian
    • /usr/share/doc/polyglot/README.gz
    • /usr/share/doc/polyglot/README1.3.gz
    • /usr/share/doc/polyglot/README1.4.gz
    • /usr/share/doc/polyglot/README1.4w
    • /usr/share/doc/polyglot/README1.4w10UCI
    • /usr/share/doc/polyglot/book_format.html
    • /usr/share/doc/polyglot/changelog.Debian.gz
    • /usr/share/doc/polyglot/copyright
    • /usr/share/doc/polyglot/examples/fruit_book_linux.ini
    • /usr/share/doc/polyglot/examples/toga2.ini
    • /usr/share/man/man6/polyglot.6.gz

    Changelog

    2014-09-26 - Oliver Korff <ok@xynyx.de> polyglot (2.0.1+git20140926-1) unstable; urgency=medium * New upstream version - Syzygy EGTs Support - book learning - A lot of UCI Changes * Adjusted copyright - The sources are now maintained by H.G. Muller of xboard * Thanks to Sebastian Pipping for pointing me to the sources * Compat level 9 to import hardening flags * Update to Standards Version 3.9.5

    2011-10-14 - Oliver Korff <ok@xynyx.de> polyglot (1.4.67b-1) unstable; urgency=low * New upstream version with: - Disable "book learning". Polyglot saves learning information but does not use it itself, probably for a reason. I believe the booklearning concept of Polyglot is fundamentally broken.

    2011-05-13 - Oliver Korff <ok@xynyx.de> polyglot (1.4.66b-1) unstable; urgency=low * New upstream version with: - Bugfix: dump-book with -color black generated the file book_white.txt * Set standards version to 3.9.2 in control with no changes.

    2011-02-11 - Oliver Korff <ok@xynyx.de> polyglot (1.4.64b-2) unstable; urgency=low * After the release nothing stands against uploading to unstable anymore.

    2011-02-10 - Oliver Korff <ok@xynyx.de> polyglot (1.4.64b-1) experimental; urgency=low * New upstream version * Main upstream news: Support for egtpath gaviota, all other changes seem to be bugfixes. See manpage for usage.

    2010-10-09 - Oliver Korff <ok@xynyx.de> polyglot (1.4.61b-1) experimental; urgency=low * Switch to new source format 3.0 (quilt), this is because I have to deal with an upstream debian/ directory. * This package now comes with a new and clean rules file * New upstream version with: - Bugfixes and - The result string after an illegal move now shows the actual attempted move. * Update to Standards-Version 3.9.1

    2010-05-20 - Oliver Korff <ok@xynyx.de> polyglot (1.4.58b-1) unstable; urgency=low * New upstream version, with: Implementation of BookDepth in UCI mode, small corrections to the manpage and a first attempt at killing engines that do not react to "quit".

    2010-01-16 - Oliver Korff <ok@xynyx.de> polyglot (1.4.56b-1) unstable; urgency=low * New upstream version, fixes a bug on linux with a not existing engine command

    2009-12-08 - Oliver Korff <ok@xynyx.de> polyglot (1.4.55b-1) unstable; urgency=low * New upstream version * Adjusted doc-base format, added index and ID field * Update to standards version 3.8.3 * The sourcecode was repackaged to get rid of the upstream debian directory, It is included as debian-orig.tar.gz * The example files have been removed from the upstream sources, so I added a toga2.ini. They have been MS-Win specific anyway. * http://alpha.uhasselt.be is the new upstream site for some time now, so I added a watchfile

    2009-08-21 - Oliver Korff <ok@xynyx.de> polyglot (1.4.36b-2) unstable; urgency=low * The FEN evaluation was not working. Michel Van Den Bergh sent a patch for epd.c

    Advertisement
    Advertisement