pnopaste_1.5-3_all.deb


Advertisement

Description

pnopaste - Pastebin with syntax highlighting

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: pnopaste
Package version: 1.5
Package release: 3
Package architecture: all
Package type: deb
Installed size: 94 B
Download size: 15.58 KB
Official Mirror: archive.ubuntu.com
Perl Nopaste is a Pastebin written in Perl using MySQL as backend. It features syntax highlighting for more than 120 languages, badword and IP address blacklists with hit counter, expiration date on postings, raw download of posted files, automatic multilanguage support and more.

Alternatives

    Download

    Binary package: pnopaste_1.5-3_all.deb
    Source package: pnopaste

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install pnopaste deb package:
      # sudo apt-get install pnopaste

    Files

    • /etc/apache2/conf-available/pnopaste.conf
    • /etc/cron.d/pnopaste
    • /etc/pnopaste/SQL_Access.pm
    • /etc/pnopaste/Syntax_Languages.pm
    • /usr/share/dbconfig-common/data/pnopaste/install/mysql
    • /usr/share/doc/pnopaste/changelog.Debian.gz
    • /usr/share/doc/pnopaste/copyright
    • /usr/share/lintian/overrides/pnopaste
    • /usr/share/pnopaste/conf
    • /usr/share/pnopaste/index.pl
    • /usr/share/pnopaste/bin/expired_delete.pl
    • /usr/share/pnopaste/lang/DE.pm
    • /usr/share/pnopaste/lang/DK.pm
    • /usr/share/pnopaste/lang/EN.pm
    • /usr/share/pnopaste/lang/FR.pm
    • /usr/share/pnopaste/lib/.htaccess
    • /usr/share/pnopaste/lib/Benchmark.pm
    • /usr/share/pnopaste/lib/Code.pm
    • /usr/share/pnopaste/lib/Database.pm
    • /usr/share/pnopaste/lib/Expire.pm
    • /usr/share/pnopaste/lib/Format.pm
    • /usr/share/pnopaste/lib/HTML.pm
    • /usr/share/pnopaste/lib/Highlighting.pm
    • /usr/share/pnopaste/lib/Hits.pm
    • /usr/share/pnopaste/lib/Language.pm
    • /usr/share/pnopaste/lib/Security.pm
    • /usr/share/pnopaste/lib/Skin.pm
    • /usr/share/pnopaste/lib/Version.pm
    • /usr/share/pnopaste/skins/default.css
    • /usr/share/pnopaste/skins/lightblue.css
    • /usr/share/pnopaste/skins/highlight/engine.css
    • /usr/share/pnopaste/templates/.htaccess
    • /usr/share/pnopaste/templates/footer.tmpl
    • /usr/share/pnopaste/templates/header.tmpl
    • /usr/share/pnopaste/templates/list_addform.tmpl
    • /usr/share/pnopaste/templates/list_confirm.tmpl
    • /usr/share/pnopaste/templates/list_table_author.tmpl
    • /usr/share/pnopaste/templates/list_table_code.tmpl
    • /usr/share/pnopaste/templates/list_table_desc.tmpl

    Changelog

    2015-07-29 - Patrick Matthäi <pmatthaei@debian.org> pnopaste (1.5-3) unstable; urgency=medium * Bump Standards-Version to 3.9.6 (no changes needed). * Add dependency on libcgi-pm-perl. * Update to DEP5 debian/copyright format. * Overwrite lintian warning about missing GPG signature. * Overwrrite false positive command-with-path-in-maintainer-script lintian warning.

    2013-11-08 - Patrick Matthäi <pmatthaei@debian.org> pnopaste (1.5-2) unstable; urgency=low * Add db_stop to postinst. Closes: #728241 * Bump Standards-Version to 3.9.5 (no changes needed). * Don't explicitly request xz compression - dpkg 1.17 does this by default.

    2013-10-25 - Patrick Matthäi <pmatthaei@debian.org> pnopaste (1.5-1) unstable; urgency=low * New upstream release. - Remove merged patch 03-empty-geoip-answer. - Remove merged patch 04-amp-escape. - Remove merged patch 05-apache2-deprecated-auth-config. * Depend on correct virtual package httpd. Closes: #726523 * Update debian/copyright. * Enable Apache cgid module.

    2013-09-05 - Patrick Matthäi <pmatthaei@debian.org> pnopaste (1.4-8) unstable; urgency=low * Remove option Indexes from Apache configuration. * Remove whitespaces from shebangs. * Remove README.Debian. The information are deprecated with using apache2-maintscript-helper. * Add patch 05-apache2-deprecated-auth-config to fix lintian warning apache2-deprecated-auth-config.

    2013-05-06 - Patrick Matthäi <pmatthaei@debian.org> pnopaste (1.4-7) unstable; urgency=low * Uploading to unstable.

    2012-12-20 - Patrick Matthäi <pmatthaei@debian.org> pnopaste (1.4-6) experimental; urgency=low * Bump Standards-Version to 3.9.4 (no changes needed). * Convert package from cdbs to debhelper and also bump compat level to 9. * Switch to xz compression and add a Pre-Depends on dpkg. * Transition to Apache 2.4 packaging. Closes: #669838

    2012-04-06 - Patrick Matthäi <pmatthaei@debian.org> pnopaste (1.4-5) unstable; urgency=low * Bump Standards-Version to 3.9.3 (no changes needed). * Wrap all debian/control fields. * Set dbc_first_version.

    2011-04-30 - Patrick Matthäi <pmatthaei@debian.org> pnopaste (1.4-4) unstable; urgency=low * Bump Standards-Version to 3.9.2 (no changes needed). * Wrap build dependencies. * Limit Depends line to 80 chars.

    2011-02-06 - Patrick Matthäi <pmatthaei@debian.org> pnopaste (1.4-3) unstable; urgency=low * Pass --debconf-ok to ucf. * Bump Standards-Version to 3.9.1 (no changes needed). * Only execute ucf in postrm, if it is available. * Add patch from 04-amp-escape from Harri Porten <porten@froglogic.com>, to fix a missing amp escape in HTML. Closes: #606710

    2010-08-17 - Patrick Matthäi <pmatthaei@debian.org> pnopaste (1.4-2) unstable; urgency=low * Add upstream patch 03-empty-geoip-answer.diff, which ensures that pnopaste sets the default language english instead of writing Perl warnings to the webservers error log, if GeoIP does not return a country flag.

    Advertisement
    Advertisement