pmw_4.28-2_amd64.deb


Advertisement

Description

pmw - Philip's Music Writer

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: pmw
Package version: 4.28
Package release: 2
Package architecture: amd64
Package type: deb
Installed size: 1.85 KB
Download size: 338.73 KB
Official Mirror: archive.ubuntu.com
PMW is a computer program for high quality music typesetting. It was originally written for Acorn RISC OS computers (where it was called PMS) PMW operates by reading an input file containing an encoded description of the music; such a file can be constructed using any text editor or word processor. The music encoding is very straightforward and compact, and quick to enter. The input encoding is designed to be easy for a musician to remember, and tries to make use of as many familiar musical notations as possible within the limitations of an ASCII character set. PMW can output PostScript files for printing, and basic MIDI files for proof-hearing.

Alternatives

Requires

    Download

    Binary package: pmw_4.28-2_amd64.deb
    Source package: pmw

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install pmw deb package:
      # sudo apt-get install pmw

    Files

    • /etc/ghostscript/fontmap.d/20pmw.conf
    • /usr/bin/pmw
    • /usr/share/doc/pmw/changelog.Debian.gz
    • /usr/share/doc/pmw/copyright
    • /usr/share/fonts/type1/gsfonts/pmw
    • /usr/share/man/man1/pmw.1.gz
    • /usr/share/pmw/MIDIperc
    • /usr/share/pmw/MIDIvoices
    • /usr/share/pmw/PSheader
    • /usr/share/pmw/fontmetrics/AvantGarde-Book.afm
    • /usr/share/pmw/fontmetrics/AvantGarde-BookOblique.afm
    • /usr/share/pmw/fontmetrics/AvantGarde-Demi.afm
    • /usr/share/pmw/fontmetrics/AvantGarde-DemiOblique.afm
    • /usr/share/pmw/fontmetrics/Bookman-Demi.afm
    • /usr/share/pmw/fontmetrics/Bookman-DemiItalic.afm
    • /usr/share/pmw/fontmetrics/Bookman-Light.afm
    • /usr/share/pmw/fontmetrics/Bookman-LightItalic.afm
    • /usr/share/pmw/fontmetrics/Courier-Bold.afm
    • /usr/share/pmw/fontmetrics/Courier-BoldOblique.afm
    • /usr/share/pmw/fontmetrics/Courier-Oblique.afm
    • /usr/share/pmw/fontmetrics/Courier.afm
    • /usr/share/pmw/fontmetrics/Helvetica-Bold.afm
    • /usr/share/pmw/fontmetrics/Helvetica-BoldOblique.afm
    • /usr/share/pmw/fontmetrics/Helvetica-Oblique.afm
    • /usr/share/pmw/fontmetrics/Helvetica.afm
    • /usr/share/pmw/fontmetrics/MustRead.html
    • /usr/share/pmw/fontmetrics/NewCenturySchlbk-Bold.afm
    • /usr/share/pmw/fontmetrics/NewCenturySchlbk-BoldItalic.afm
    • /usr/share/pmw/fontmetrics/NewCenturySchlbk-Italic.afm
    • /usr/share/pmw/fontmetrics/NewCenturySchlbk-Roman.afm
    • /usr/share/pmw/fontmetrics/PMW-Alpha.afm
    • /usr/share/pmw/fontmetrics/PMW-Music.afm
    • /usr/share/pmw/fontmetrics/Palatino-Bold.afm
    • /usr/share/pmw/fontmetrics/Palatino-BoldItalic.afm
    • /usr/share/pmw/fontmetrics/Palatino-Italic.afm
    • /usr/share/pmw/fontmetrics/Palatino-Roman.afm
    • /usr/share/pmw/fontmetrics/Symbol.afm
    • /usr/share/pmw/fontmetrics/Times-Bold.afm
    • /usr/share/pmw/fontmetrics/Times-BoldItalic.afm
    • /usr/share/pmw/fontmetrics/Times-Italic.afm
    • /usr/share/pmw/fontmetrics/Times-Roman.afm
    • /usr/share/pmw/fontmetrics/Utopia-Bold.afm
    • /usr/share/pmw/fontmetrics/Utopia-BoldItalic.afm
    • /usr/share/pmw/fontmetrics/Utopia-Italic.afm
    • /usr/share/pmw/fontmetrics/Utopia-Regular.afm
    • /usr/share/pmw/fontmetrics/ZapfChancery-MediumItalic.afm
    • /usr/share/pmw/fontmetrics/ZapfDingbats.afm
    • /usr/share/pmw/psfonts/PMW-Alpha
    • /usr/share/pmw/psfonts/PMW-Music.pfa

    Changelog

    2015-11-24 - Wouter Verhelst <wouter@debian.org> pmw (1:4.28-2) unstable; urgency=medium * debian/rules: reorganize so that dpkg-buildpackage -A works. Closes: #806094 * debian/rules: also split up the build target so that we have a useful binary-arch target. * debian/control: move a few dependencies from Build-Depends to Build-Depends-Indep, in light of the above. * debian/compat: bump to level 9 * debian/control: bump debhelper build-dep to at least version 9, in light of the above. * debian/control: update Homepage: field to point to the new location.

    2013-12-31 - Wouter Verhelst <wouter@debian.org> pmw (1:4.28-1) unstable; urgency=medium * New upstream release * Fix Vcs-Git url to silence lintian warning * Update Standards-Version to 3.9.5 (no changes)

    2013-12-18 - Wouter Verhelst <wouter@debian.org> pmw (1:4.27-1) unstable; urgency=medium * New upstream release * Install doc/examples into pmw-doc, too

    2013-05-29 - Wouter Verhelst <wouter@debian.org> pmw (1:4.26-1) unstable; urgency=low * New upstream release * Update Standards-Version: to 3.9.4 (nothing relevant to pmw)

    2012-05-18 - Wouter Verhelst <wouter@debian.org> pmw (1:4.24-1) unstable; urgency=low * New upstream release * Add epoch, because I forgot that 231 > 23. Argl.

    2012-01-23 - Wouter Verhelst <wouter@debian.org> pmw (4.231-1) unstable; urgency=low * New upstream release - Fixes test suite; Closes: #658229. * Do 'set -e' in maintainer scripts, so we don't ignore errors * Fix update-gsfontmap stuff again, hopefully for good. Closes: #635550.

    2012-01-23 - Wouter Verhelst <wouter@debian.org> pmw (4.23-1) unstable; urgency=low * New upstream release

    2011-07-29 - Wouter Verhelst <wouter@debian.org> pmw (4.22-4) unstable; urgency=low * The 'ghostscript sucks' release. * Check for update-gsfontmap the right way. Closes: #635550. * add Build-Conflicts: pmw. Building the documentation requires access to the PMW fonts, which ghostscript allows either through adding a file to /etc/ghostscript, or through setting an environment variable, but not both (ghostscript breaks if you try). Using the package also requires the fonts. Building requires the environment variable (otherwise fixing bugs in a previous package could be problematic). Using requires the config file (requiring environment variables to be set is not allowed by Debian Policy, and wrapper scripts are ugly). Therefore, we can't build pmw if pmw itself is installed. Did I mention I'm not a ghostscript fan? * Declare Standards-Version 3.9.2 (no changes applicable to pmw) * Add Recommends: ghostscript

    2011-04-13 - Wouter Verhelst <wouter@debian.org> pmw (4.22-3) unstable; urgency=low * debian/pmw.postinst: Check for existence of update-gsfontmap before trying to run it. This way it will work without ghostscript installed, which we don't depend on. Closes: #622334. * Use dh_installdocs rather than override_dh_install to install pmw-doc's documents into /usr/share/doc/pmw. Closes: #621886. * To remain policy-compliant in light of the above, make pmw-doc depend on pmw.

    2011-03-04 - Wouter Verhelst <wouter@debian.org> pmw (4.22-2) unstable; urgency=low * Make PMW fonts available to ghostscript. * Add Vcs-Browser and Vcs-Git headers to source package

    Advertisement
    Advertisement