pmtools_2.0.0-1_all.deb


Advertisement

Description

pmtools - Perl module tools

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: pmtools
Package version: 2.0.0
Package release: 1
Package architecture: all
Package type: deb
Installed size: 188 B
Download size: 87.02 KB
Official Mirror: archive.ubuntu.com
Perl module tools is a suite of small tools that help manage and inspect perl modules, perl Plain Old Documentation files, and perl programs. Some of the things these tools can do include: - show the full path to a module - show the version and description of a module - list all installed modules with descriptions - show what files a given program or module loads at compile time - show what symbols a module exports - list the methods of a class - display the source code of a function of a module

Alternatives

Requires

    Download

    Binary package: pmtools_2.0.0-1_all.deb
    Source package: pmtools

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install pmtools deb package:
      # sudo apt-get install pmtools

    Files

    • /usr/bin/basepods
    • /usr/bin/faqpods
    • /usr/bin/modpods
    • /usr/bin/pfcat
    • /usr/bin/plxload
    • /usr/bin/pmall
    • /usr/bin/pman
    • /usr/bin/pmcat
    • /usr/bin/pmcheck
    • /usr/bin/pmdesc
    • /usr/bin/pmeth
    • /usr/bin/pmexp
    • /usr/bin/pmfunc
    • /usr/bin/pminclude
    • /usr/bin/pminst
    • /usr/bin/pmload
    • /usr/bin/pmls
    • /usr/bin/pmpath
    • /usr/bin/pmvers
    • /usr/bin/podgrep
    • /usr/bin/podpath
    • /usr/bin/pods
    • /usr/bin/podtoc
    • /usr/bin/sitepods
    • /usr/bin/stdpods
    • /usr/share/doc/pmtools/TODO
    • /usr/share/doc/pmtools/changelog.Debian.gz
    • /usr/share/doc/pmtools/copyright
    • /usr/share/man/man1/basepods.1p.gz
    • /usr/share/man/man1/faqpods.1p.gz
    • /usr/share/man/man1/modpods.1p.gz
    • /usr/share/man/man1/pfcat.1p.gz
    • /usr/share/man/man1/plxload.1p.gz
    • /usr/share/man/man1/pmall.1p.gz
    • /usr/share/man/man1/pman.1p.gz
    • /usr/share/man/man1/pmcat.1p.gz
    • /usr/share/man/man1/pmcheck.1p.gz
    • /usr/share/man/man1/pmdesc.1p.gz
    • /usr/share/man/man1/pmeth.1p.gz
    • /usr/share/man/man1/pmexp.1p.gz
    • /usr/share/man/man1/pmfunc.1p.gz
    • /usr/share/man/man1/pminclude.1p.gz
    • /usr/share/man/man1/pminst.1p.gz
    • /usr/share/man/man1/pmload.1p.gz
    • /usr/share/man/man1/pmls.1p.gz
    • /usr/share/man/man1/pmpath.1p.gz
    • /usr/share/man/man1/pmvers.1p.gz
    • /usr/share/man/man1/podgrep.1p.gz
    • /usr/share/man/man1/podpath.1p.gz
    • /usr/share/man/man1/pods.1p.gz
    • /usr/share/man/man1/podtoc.1p.gz
    • /usr/share/man/man1/sitepods.1p.gz
    • /usr/share/man/man1/stdpods.1p.gz
    • /usr/share/man/man3/Devel::Loaded.3pm.gz
    • /usr/share/man/man3/pmtools.3pm.gz
    • /usr/share/perl5/pmtools.pm
    • /usr/share/perl5/Devel/Loaded.pm

    Changelog

    2014-02-09 - Axel Beckert <abe@debian.org> pmtools (2.0.0-1) unstable; urgency=low * New upstream release + Refresh fix-carp-has-no-pod-for-test-suite.patch

    2014-01-17 - Damyan Ivanov <dmn@debian.org> pmtools (1.54-2) unstable; urgency=low * Team upload [ Axel Beckert ] * Bump Standard-Version to 3.9.5 (no changes). [ Damyan Ivanov ] * refresh patches using --no-timestamps --no-index -p ab --strip- trailing-whitespace * update fix-carp-has-no-pod-for-test-suite.patch to allow underscore in the version of English.pm Closes: #735818 -- FTBFS with perl 5.18.2

    2013-10-22 - Axel Beckert <abe@debian.org> pmtools (1.54-1) unstable; urgency=low * New upstream release

    2013-09-27 - Axel Beckert <abe@debian.org> pmtools (1.51-1) unstable; urgency=low * New upstream release * Add patch to use English instead of Carp in POD-related tests * Add patch to make pminst follow symlinks * Set $PAGER to cat as it's used by pman + pmcat, also inside the tests * Really bump debhelper compat. to 9, not only the build-dependency

    2013-09-10 - Axel Beckert <abe@debian.org> pmtools (1.40-1) unstable; urgency=low [ Axel Beckert ] * New upstream release * Make new upstream test suite pass. + Add Build-Dependency on perl-doc + Extend $PATH as needed * No more install upstream's README into /usr/share/doc/pmtools/ -- it only contains module name, version and license nowadays) * debian/rules: Remove no more needed empty overrides * Bump debhelper compatibility to 9 + Update versioned debhelper compatibility accordingly + Gets rid of the dh_pysupport deprecation warning [ Salvatore Bonaccorso ] * Change search.cpan.org based URIs to metacpan.org based URIs

    2013-01-21 - Xavier Guimard <x.guimard@free.fr> pmtools (1.30-1) unstable; urgency=low [ Axel Beckert ] * Switch homepage and watch file from search.cpan.org to metacpan.org. [ Salvatore Bonaccorso ] * Change Vcs-Git to canonical URI (git://anonscm.debian.org) [ Xavier Guimard ] * Imported Upstream version 1.30 * Update debian/copyright years

    2012-12-13 - Axel Beckert <abe@debian.org> pmtools (1.20-1) unstable; urgency=low [ Ansgar Burchardt ] * debian/control: Convert Vcs-* fields to Git. [ Xavier Guimard ] * Imported Upstream version 1.20 * Bump Standard-Version to 3.9.4 * Use debhelper 8 * Update debian/copyright (license and format) * Update source format to 3.0 (quilt) [ Axel Beckert ] * No more repacking needed. Cleanup debian/rules and README.source. * debian/copyright: Add Copyright years and holder for pmcheck.

    2010-04-03 - Axel Beckert <abe@debian.org> pmtools (1.10+ds1-2) unstable; urgency=low * Fix broken watch file

    2010-04-03 - Axel Beckert <abe@debian.org> pmtools (1.10+ds1-1) unstable; urgency=low * New upstream release (Closes: #570883) - More modern upstream packaging. Good. :-) - One file exists twice in the upstream tar.gz so dpkg-source fails and it had to be repackaged. Bad. :-( Add documentation and get-orig-source target. * New maintainer (Debian Perl Group) and new uploader (me) (Closes: #569525) * Added a watch file to point to new upstream URL at CPAN * Bumped Standards-Version to 3.8.4 - Changed dependency on perl5 to perl. * Used dh-make-perl to refresh debian/rules (one-liner dh format) and debian/copyright (DEP5 format). - Build-Depends on debhelper (>= 7.0.50~) - Bumped debhelper compatibility to 7 This also fixed the following Lintian warnings as well as many other issues: - debhelper-but-no-misc-depends - clean-should-be-satisfied-by-build-depends debhelper * Removed obsolete postinst. This fixed the following Lintian warning: - maintainer-script-ignores-errors postinst * Added Homepage and Vcs-* headers. * Updated source URL in debian/copyright * Added debian/source/format to fix lintian warning missing-debian-source-format

    Advertisement
    Advertisement