pluma_1.12.2-2_amd64.deb


Advertisement

Description

pluma - official text editor of the MATE desktop environment

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: pluma
Package version: 1.12.2
Package release: 2
Package architecture: amd64
Package type: deb
Installed size: 1.70 KB
Download size: 422.69 KB
Official Mirror: archive.ubuntu.com
Pluma is a text editor which supports most standard editor features, extending this basic functionality with other features not usually found in simple text editors. Pluma is a graphical application which supports editing multiple text files in one window (known sometimes as tabs or MDI). Pluma fully supports international text through its use of the Unicode UTF-8 encoding in edited files. Its core feature set includes syntax highlighting of source code, auto indentation and printing and print preview support. Pluma is also extensible through its plugin system, which currently includes support for spell checking, comparing files, viewing CVS ChangeLogs, and adjusting indentation levels.

Alternatives

Provides

  • mate-text-editor

Replaces

  • mate-text-editor << 1.5.0

    Download

    Binary package: pluma_1.12.2-2_amd64.deb
    Source package: pluma

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install pluma deb package:
      # sudo apt-get install pluma

    Files

    • /usr/bin/pluma
    • /usr/lib/pluma/pluma-bugreport.sh
    • /usr/lib/x86_64-linux-gnu/pluma/plugin-loaders/libcloader.so
    • /usr/lib/x86_64-linux-gnu/pluma/plugin-loaders/libpythonloader.so
    • /usr/lib/x86_64-linux-gnu/pluma/plugins/changecase.pluma-plugin
    • /usr/lib/x86_64-linux-gnu/pluma/plugins/docinfo.pluma-plugin
    • /usr/lib/x86_64-linux-gnu/pluma/plugins/externaltools.pluma-plugin
    • /usr/lib/x86_64-linux-gnu/pluma/plugins/filebrowser.pluma-plugin
    • /usr/lib/x86_64-linux-gnu/pluma/plugins/libchangecase.so
    • /usr/lib/x86_64-linux-gnu/pluma/plugins/libdocinfo.so
    • /usr/lib/x86_64-linux-gnu/pluma/plugins/libfilebrowser.so
    • /usr/lib/x86_64-linux-gnu/pluma/plugins/libmodelines.so
    • /usr/lib/x86_64-linux-gnu/pluma/plugins/libsort.so
    • /usr/lib/x86_64-linux-gnu/pluma/plugins/libspell.so
    • /usr/lib/x86_64-linux-gnu/pluma/plugins/libtaglist.so
    • /usr/lib/x86_64-linux-gnu/pluma/plugins/libtime.so
    • /usr/lib/x86_64-linux-gnu/pluma/plugins/libtrailsave.so
    • /usr/lib/x86_64-linux-gnu/pluma/plugins/modelines.pluma-plugin
    • /usr/lib/x86_64-linux-gnu/pluma/plugins/pythonconsole.pluma-plugin
    • /usr/lib/x86_64-linux-gnu/pluma/plugins/quickopen.pluma-plugin
    • /usr/lib/x86_64-linux-gnu/pluma/plugins/snippets.pluma-plugin
    • /usr/lib/x86_64-linux-gnu/pluma/plugins/sort.pluma-plugin
    • /usr/lib/x86_64-linux-gnu/pluma/plugins/spell.pluma-plugin
    • /usr/lib/x86_64-linux-gnu/pluma/plugins/taglist.pluma-plugin
    • /usr/lib/x86_64-linux-gnu/pluma/plugins/time.pluma-plugin
    • /usr/lib/x86_64-linux-gnu/pluma/plugins/trailsave.pluma-plugin
    • /usr/lib/x86_64-linux-gnu/pluma/plugins/externaltools/__init__.py
    • /usr/lib/x86_64-linux-gnu/pluma/plugins/externaltools/capture.py
    • /usr/lib/x86_64-linux-gnu/pluma/plugins/externaltools/filelookup.py
    • /usr/lib/x86_64-linux-gnu/pluma/plugins/externaltools/functions.py
    • /usr/lib/x86_64-linux-gnu/pluma/plugins/externaltools/library.py
    • /usr/lib/x86_64-linux-gnu/pluma/plugins/externaltools/linkparsing.py
    • /usr/lib/x86_64-linux-gnu/pluma/plugins/externaltools/manager.py
    • /usr/lib/x86_64-linux-gnu/pluma/plugins/externaltools/outputpanel.py
    • /usr/lib/x86_64-linux-gnu/pluma/plugins/pythonconsole/__init__.py
    • /usr/lib/x86_64-linux-gnu/pluma/plugins/pythonconsole/config.py
    • /usr/lib/x86_64-linux-gnu/pluma/plugins/pythonconsole/console.py
    • /usr/lib/x86_64-linux-gnu/pluma/plugins/quickopen/__init__.py
    • /usr/lib/x86_64-linux-gnu/pluma/plugins/quickopen/popup.py
    • /usr/lib/x86_64-linux-gnu/pluma/plugins/quickopen/virtualdirs.py
    • /usr/lib/x86_64-linux-gnu/pluma/plugins/quickopen/windowhelper.py
    • /usr/lib/x86_64-linux-gnu/pluma/plugins/snippets/Completion.py
    • /usr/lib/x86_64-linux-gnu/pluma/plugins/snippets/Document.py
    • /usr/lib/x86_64-linux-gnu/pluma/plugins/snippets/Exporter.py
    • /usr/lib/x86_64-linux-gnu/pluma/plugins/snippets/Helper.py
    • /usr/lib/x86_64-linux-gnu/pluma/plugins/snippets/Importer.py
    • /usr/lib/x86_64-linux-gnu/pluma/plugins/snippets/LanguageManager.py
    • /usr/lib/x86_64-linux-gnu/pluma/plugins/snippets/Library.py
    • /usr/lib/x86_64-linux-gnu/pluma/plugins/snippets/Manager.py
    • /usr/lib/x86_64-linux-gnu/pluma/plugins/snippets/Parser.py
    • /usr/lib/x86_64-linux-gnu/pluma/plugins/snippets/Placeholder.py
    • /usr/lib/x86_64-linux-gnu/pluma/plugins/snippets/Snippet.py
    • /usr/lib/x86_64-linux-gnu/pluma/plugins/snippets/SubstitutionParser.py
    • /usr/lib/x86_64-linux-gnu/pluma/plugins/snippets/WindowHelper.py
    • /usr/lib/x86_64-linux-gnu/pluma/plugins/snippets/__init__.py
    • /usr/share/applications/pluma.desktop
    • /usr/share/doc/pluma/changelog.Debian.gz
    • /usr/share/doc/pluma/copyright
    • /usr/share/man/man1/pluma.1.gz

    Changelog

    2016-03-21 - Mike Gabriel <sunweaver@debian.org> pluma (1.12.2-2) unstable; urgency=medium [ Martin Wimpress ] * debian/patches: + Add 0000_prevent_shell_code_injection.patch. Closes (LP: #1466633) [ Mike Gabriel ] * debian/control: + Bump Standards: to 3.9.7. No changes needed.

    2016-02-16 - Mike Gabriel <sunweaver@debian.org> pluma (1.12.2-1) unstable; urgency=medium [ Martin Wimpress ] * New upstream release. [ Mike Gabriel ] * debian/control: + Use encrypted URLs for Vcs-*: field. + Versioned B-D on dpkg-dev (>= 1.16.1.1). * debian/rules: + Enable all hardening flags.

    2016-01-02 - Mike Gabriel <sunweaver@debian.org> pluma (1.12.1-1) unstable; urgency=medium [ Martin Wimpress ] * New upstream release. * debian/copyright: + Update copyright attributions. * debian/patches: + Drop 2003_omit-non-linux-build-files.patch. Applied upstream. * debian/watch: + Drop +dfsg1 suffix. * debian/rules: + Remove obsolete repacking. * debian/control: + Versioned B-D: mate-common (>= 1.12) and libmate-desktop-dev (>= 1.12). [ Mike Gabriel ] * Bug triaging: Check that pluma really builds against Python2 and the correct build rules are enabled. This is solved since 1.10.2+dfsg1-2. (Closes: #796883).

    2015-08-30 - Mike Gabriel <sunweaver@debian.org> pluma (1.10.2+dfsg1-2) unstable; urgency=medium [ Mike Gabriel ] * debian/rules: + Use NEWS file as upstream changelog. [ Martin Wimpress ] * debian/pluma-common.lintian-overrides: + Catch false positive for privacy-breach-generic. * debian/control: + Add Python dependencies for plugins. (Closes: #797130). * debian/rules: + Update build rules to use Python.

    2015-08-19 - Mike Gabriel <sunweaver@debian.org> pluma (1.10.2+dfsg1-1) unstable; urgency=medium [ Martin Wimpress ] * New upstream release. * debian/patches: + Drop 0002_use-zenity-instead-of-mate-dialogs.patch, applied upstream. + Drop 1001_no-timestamped-gzip-files.patch, applied upstream. + Drop 0003_glib243-compat.patch, applied upstream. + Drop 2001_fix-man-page-errors.patch, applied upstream. + Drop 2002_omit-gfdl-licensed-help-files.patch, applied upstream. + Rebase 2003_omit-non-linux-build-files.patch. * debian/control: + Add new package pluma-doc.install. + Update build dependencies for new upstream release. + Update descriptions. + Process with wrap-and-sort. * debian/pluma-common.install: + Add usr/share/{appdata,help}. + Process with wrap-and-sort. * debian/pluma.install: + Process with wrap-and-sort. * debian/rules: + Update for new upstream released. * debian/copyright: + Add help/ files, update for this upstream release. [ Mike Gabriel ] * debian/rules: + Create orig tar ball in ../ rather than in $(CURDIR). * debian/control: + Versioned B-D: mate-common (>= 1.10). * debian/copyright: + Add copyright.in template file. + More fine-tuning before uploading. * lintian: + Drop obsolete override "privacy-breach-generic" (pluma-common).

    2015-06-06 - Mike Gabriel <sunweaver@debian.org> pluma (1.8.1+dfsg1-4) unstable; urgency=medium * debian/control: + Add D (pluma): python-gtksourceview2. (Closes: #785243). + Add to B-D: dh-python. * debian/copyright: + Fix several mentioned files reported as wildcard-matches-nothing by lintian. * debian/pluma-common.lintian-overrides: + Fix URL in privacy-breach-generic lintian override. * debian/rules: + Remove .pyc and .pyo files before installing plugin files into the pluma bin:package. * debian/patches: + Add 1001_no-timestamped-gzip-files.patch. No timestamps in gzip compressed package files.

    Advertisement
    Advertisement